View Issue Details

IDProjectCategoryView StatusLast Update
0000680SOGoWeb Mailpublic2016-05-12 10:26
Reportergreenshift Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Fixed in Version2.3.7 
Summary0000680: Junk Mail Treatment
Description

I think it would be great if a Junk mail button and or preferences could be added.
This could do one or all of the following:

  • Based on mail headers junk mail directly
  • When clicked move junk to the Junk folder
  • When clicked trigger a hook to update a Bayesian filter
    Thanks
    Alex
TagsNo tags attached.

Relationships

has duplicate 0003145 resolvedludovic button Junk mail 
has duplicate 0001123 resolvedludovic Spam report button 

Activities

alessio

alessio

2010-07-08 06:01

reporter   ~0001165

  • When clicked trigger a hook to update a Bayesian filter
    This is a good idea, a button for ham too. We have an addon for thunderbird that make this, if you put it in SOGo it's a good thing!
mira

mira

2011-12-03 19:37

reporter   ~0003101

Very important for us.

djordjije

djordjije

2014-04-01 15:51

reporter   ~0006815

It would be nice to have a "Mark as Junk" toolbar button in addition to the main toolbar buttons when working with messages (reply, delete, etc.).
I don't believe it is up to webmail client to implement Bayesian filter, but at least this can perform checking existance of Spamassassin headers (X-Spam-Flag, X-Spam-Score & X-Spam-Status), moving marked message to (or moving out from) Junk folder (if enabled), as well as setting imap flag (for more details, see http://wiki2.dovecot.org/MailboxFormat/Maildir).

ludovic

ludovic

2016-05-12 10:26

administrator   ~0010118

Available since SOGo v2.3.7 - the GUI part will be done shortly for SOGo v3.

Issue History

Date Modified Username Field Change
2010-07-06 09:50 greenshift New Issue
2010-07-08 06:01 alessio Note Added: 0001165
2011-12-03 19:37 mira Note Added: 0003101
2014-04-01 15:51 djordjije Note Added: 0006815
2015-03-24 09:06 francis Relationship added has duplicate 0003145
2015-03-24 09:07 francis Relationship added has duplicate 0001123
2016-05-12 10:26 ludovic Note Added: 0010118
2016-05-12 10:26 ludovic Status new => resolved
2016-05-12 10:26 ludovic Fixed in Version => 2.3.7
2016-05-12 10:26 ludovic Resolution open => fixed
2016-05-12 10:26 ludovic Assigned To => ludovic