View Issue Details

IDProjectCategoryView StatusLast Update
0004801SOGoBackend Calendarpublic2021-09-22 12:43
ReporterFoZo Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version16.04 LTS
Product Version4.0.8 
Fixed in Versionnightly master 
Summary0004801: Sogo's event invetetion with reminder is not working for MS clients - not supported calendar message.ics
Description

If Sogo user create event invitation trough webmail with reminder inside and send it to a Microsoft/Exchange/Outlook user, the Microsoft/Exchange/Outlook receives the invitation with "not supported calendar message.ics" attachment to it and is not able to add it to his calendar.

Also, if the same sogo user use MS Outlook as client with activesync in addition to the sogo's webmail, he is unable to see the event in the Outook client unless he remove the Reminder trough webmail.

Steps To Reproduce
  1. Login to SOGO webmail
  2. Create an event with reminder to it and send it to MS user.
Additional Information

I can see that there is an old bug report with id 3925 , that is marked as solved, but the problem is present in version 4.0.8 .

TagsNo tags attached.

Relationships

related to 0003925 resolvedludovic Accepting an outlook invitation sends not supported calendar message.ics to organizer 

Activities

dodesogo

dodesogo

2021-06-10 19:31

reporter   ~0015315

Same issue with Version 5.1.0 (@shiva2.inverse 202104160119) sending invitations with reminder to outlook.office.com.

FoZo

FoZo

2021-09-22 09:23

reporter   ~0015484

The issue stil exists in version 5.2.0. The issue is there even when using iPhone or iOS for creating the event.
Seems to be issue with the formating of the .ics calendar inside the email.
3D is duplicated. You can see it in the attached .eml file.

Here is an output from Thunderbird's error console:

Lightning: Couldn't find 3DEurope/Stockholm CalTimezoneService.jsm:201
Lightning: Unknown timezone "3DEurope/Stockholm" in "Europe". Treated as 'floating' local timezone instead: 22/09/2021 13:15
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20210922T091254Z
LAST-MODIFIED:20210922T091254Z
DTSTAMP:20210922T091254Z
UID:5660-614AF380-1-38F39B80
SUMMARY:Europe
ORGANIZER;CN=3DKo:mailto:ko@someemail.se
ATTENDEE;RSVP=3DTRUE;PARTSTAT=3DNEEDS-ACTION;ROLE=3DREQ-PARTICIPANT:mai=
DTSTART;TZID=3DEurope/Stockholm:20210922T111500
DTEND;TZID=3DEurope/Stockholm:20210922T121500
CLASS:PUBLIC
X-LIC-ERROR;X-LIC-ERRORTYPE=PROPERTY-PARSE-ERROR:Parse error in property n
ame: lto
TRANSP:OPAQUE
END:VEVENT
END:VCALENDAR

When checking the email source you will notice this prefix "3D3D" at front of many values and that isn't correct (some lines were removed):
BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 5.2.0//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:Europe/Stockholm
LAST-MODIFIED:20210303T135712Z
X-LIC-LOCATION:Europe/Stockholm
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19700329T020000
RRULE:FREQ=3D3DYEARLY;BYMONTH=3D3D3;BYDAY=3D3D-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19701025T030000
RRULE:FREQ=3D3DYEARLY;BYMONTH=3D3D10;BYDAY=3D3D-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:5660-614AF380-1-38F39B80
SUMMARY:Europe
CLASS:PUBLIC
ATTENDEE;ROLE=3D3DREQ-PARTICIPANT;PARTSTAT=3D3DNEEDS-ACTION;RSVP=3D3DTR=
UE:mai=3D
ATTENDEE;ROLE=3D3DREQ-PARTICIPANT;PARTSTAT=3D3DNEEDS-ACTION;RSVP=3D3DTR=
UE:mai=3D
TRANSP:OPAQUE
DTSTART;TZID=3D3DEurope/Stockholm:20210922T111500
DTEND;TZID=3D3DEurope/Stockholm:20210922T121500
ORGANIZER;CN=3D3DKo:mailto:ko@somedomain.se

Event Invitation: %22Europe%22.eml (2,870 bytes)   
------=_=-_OpenGroupware_org_NGMime-22092-1632301974.784493-0------
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable
Content-Length: 1211

<html>

  <head>
    <style type=3D"text/css">
th, td { font-family: Lucida Grande, Bitstream VeraSans, Tahoma, sans-s=
erif; font-size: 12px; line-height: 18px; }
    </style>
  </head>
  <body>
    <table style=3D"width: 100%; max-width: 600px;" border=3D"0" cellsp=
acing=3D"2" cellpadding=3D"2">
      <tr>
        <th />
        <td><h1 class=3D"ng-hide" style=3D"font-size: 18px; font-weight=
: normal;           padding-bottom: 9px; border-bottom: 1px solid #ccc;=
">Event Invitation: "Europe" <small style=3D"font-size: 12px; color: #9=
99;">Ko</small></h1></td>
      </tr>
      <tr>
        <th />
        <td><h1 style=3D"font-size: 14px; font-weight: normal;         =
  padding-bottom: 9px; border-bottom: 1px solid #ccc;">Your participati=
on is required to this event</h1></td>
      </tr>  

      
      
      <tr>
	<th align=3D"right" style=3D"font-weight: bold;">Start</th>
        <td>Wednesday, September 22, 2021 - 11:15 Europe/Stockholm
           </td>
      </tr>
      <tr>
        <th align=3D"right" style=3D"font-weight: bold;">End</th>
        <td>Wednesday, September 22, 2021 - 12:15 Europe/Stockholm
           </td>
	 </tr>
      
      
    </table>
  </body>
</html>

------=_=-_OpenGroupware_org_NGMime-22092-1632301974.784493-0------
Content-Class: urn:content-classes:calendarmessage
Content-Type: text/calendar; method=REQUEST; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Content-Length: 1106

BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 5.2.0//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:Europe/Stockholm
LAST-MODIFIED:20210303T135712Z
X-LIC-LOCATION:Europe/Stockholm
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19700329T020000
RRULE:FREQ=3D3DYEARLY;BYMONTH=3D3D3;BYDAY=3D3D-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19701025T030000
RRULE:FREQ=3D3DYEARLY;BYMONTH=3D3D10;BYDAY=3D3D-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:5660-614AF380-1-38F39B80
SUMMARY:Europe
CLASS:PUBLIC
ATTENDEE;ROLE=3D3DREQ-PARTICIPANT;PARTSTAT=3D3DNEEDS-ACTION;RSVP=3D3DTR=
UE:mai=3D
lto:dsadsa
 .gdsfasdas@gmail.com
ATTENDEE;ROLE=3D3DREQ-PARTICIPANT;PARTSTAT=3D3DNEEDS-ACTION;RSVP=3D3DTR=
UE:mai=3D
lto:gfdfdsdas
 .fasfgdfa@svenskadomaner.se
TRANSP:OPAQUE
DTSTART;TZID=3D3DEurope/Stockholm:20210922T111500
DTEND;TZID=3D3DEurope/Stockholm:20210922T121500
ORGANIZER;CN=3D3DKo:mailto:ko@somedomain.se
CREATED:20210922T091254Z
DTSTAMP:20210922T091254Z
LAST-MODIFIED:20210922T091254Z
END:VEVENT
END:VCALENDAR


------=_=-_OpenGroupware_org_NGMime-22092-1632301974.784493-0--------
invite.ics (1,064 bytes)   
BEGIN:VCALENDAR
PRODID:-//Inverse inc./SOGo 5.2.0//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VTIMEZONE
TZID:Europe/Stockholm
LAST-MODIFIED:20210303T135712Z
X-LIC-LOCATION:Europe/Stockholm
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19700329T020000
RRULE:FREQ=3DYEARLY;BYMONTH=3D3;BYDAY=3D-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19701025T030000
RRULE:FREQ=3DYEARLY;BYMONTH=3D10;BYDAY=3D-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
UID:5660-614AF380-1-38F39B80
SUMMARY:Europe
CLASS:PUBLIC
ATTENDEE;ROLE=3DREQ-PARTICIPANT;PARTSTAT=3DNEEDS-ACTION;RSVP=3DTRUE:mai=
lto:fsdfds
 .dsadasd@gmail.com
ATTENDEE;ROLE=3DREQ-PARTICIPANT;PARTSTAT=3DNEEDS-ACTION;RSVP=3DTRUE:mai=
lto:dsdadsa
 .gsfds@gdsfdsr.se
TRANSP:OPAQUE
DTSTART;TZID=3DEurope/Stockholm:20210922T111500
DTEND;TZID=3DEurope/Stockholm:20210922T121500
ORGANIZER;CN=3DKo:mailto:ko@somedomain.se
CREATED:20210922T091254Z
DTSTAMP:20210922T091254Z
LAST-MODIFIED:20210922T091254Z
END:VEVENT
END:VCALENDAR

invite.ics (1,064 bytes)   
Screenshot_20210922_111754.png (25,584 bytes)   
Screenshot_20210922_111754.png (25,584 bytes)   
Screenshot_20210922_111817.png (35,196 bytes)   
Screenshot_20210922_111817.png (35,196 bytes)   
FoZo

FoZo

2021-09-22 10:12

reporter   ~0015485

Seems to be resolved in 0005391

Issue History

Date Modified Username Field Change
2019-08-27 15:30 FoZo New Issue
2019-09-06 08:16 Christian Mack Relationship added related to 0003925
2021-06-10 19:31 dodesogo Note Added: 0015315
2021-09-22 09:23 FoZo Note Added: 0015484
2021-09-22 09:23 FoZo File Added: Event Invitation: %22Europe%22.eml
2021-09-22 09:23 FoZo File Added: invite.ics
2021-09-22 09:23 FoZo File Added: Screenshot_20210922_111754.png
2021-09-22 09:23 FoZo File Added: Screenshot_20210922_111817.png
2021-09-22 10:12 FoZo Note Added: 0015485
2021-09-22 12:43 francis Assigned To => francis
2021-09-22 12:43 francis Status new => resolved
2021-09-22 12:43 francis Resolution open => fixed
2021-09-22 12:43 francis Fixed in Version => nightly master