View Issue Details

IDProjectCategoryView StatusLast Update
0003925SOGoBackend Calendarpublic2019-09-06 08:16
Reporterzeroone Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version3.2.3 
Fixed in Version3.2.6 
Summary0003925: Accepting an outlook invitation sends not supported calendar message.ics to organizer
Description

User (Exchange 2013/2016) sends an invitation (from Outlook 2016 or from OWA), attendee is on SOGo 3.1.3. Attendee accepts invitation in SOGo's web interface. Organizer gets acceptance mail, but with an attachment "unsupported calendar message.ics". As long as he does not open this attachment, the appointment will not be updated with attendee status. Most users are afraid to open this attachment.

Steps To Reproduce

Send invitation to SOGO user from Exchange server (using Outlook 2016 or Outlook Web App). Accepting invitation from SOGO's web interface. Organizer gets mail with attachment "unsupported calendar message.ics"

TagsNo tags attached.

Relationships

related to 0004801 new Sogo's event invetetion with reminder is not working for MS clients - not supported calendar message.ics 

Activities

zeroone

zeroone

2016-12-02 01:48

reporter  

finalgene

finalgene

2017-01-02 04:51

reporter   ~0011161

The same Problem exits, when accepting an invitation with an ActiveSync client.
The problem seems to be a wrong formated DTSTART and DTEND field.
This is no SOGo (only) problem.

http://stackoverflow.com/questions/37622750/getting-not-supported-calendar-message-ics-attachment-with-outlook-email-invit

I think it's an Exchange issue, but should be handled by SOGo, as Microsoft wouldn't change it's behavior.

ludovic

ludovic

2017-01-06 14:40

administrator   ~0011175

When testing with Outlook 2016 NOT connected with SOGo in any way (so just over a standard IMAP server), all works fine.

The IMIP reply sent by SOGo to Outlook is correctly processed.

finalgene

finalgene

2017-01-07 17:13

reporter   ~0011176

The problem isn't by Outlook, it's an Exchange problem.

zeroone

zeroone

2017-01-11 11:43

reporter   ~0011191

Even with 3.2.5 the problem exists: User A is on Exchange (e.g. Office 365), no matter if he uses Outlook or Exchange WebMail. User A sends an invitation to User B, User B is on SOGo. User B accepts invitation, User A gets the response with the "not-supported-message.ics attachment.

tfu

tfu

2017-01-12 02:06

reporter   ~0011196

The problem could be caused by a valarm element in the IMIP reply.
Can you try to send an invite (user A on Exchange) without a reminder and check whether the is behavior different?

zeroone

zeroone

2017-01-12 04:55

reporter   ~0011199

I can confirm what tfu wrote: without a reminder all works fine, there is no "not-supported.message" ics attachment and Outlook show the response in its calendar. So it seems the problem is caused by a VALARM entry.

tfu

tfu

2017-01-12 11:30

reporter   ~0011203

If I read section 3.2.3 https://tools.ietf.org/html/rfc2446#section-3.2.3 correctly valarm should/must not be percent in a calendar reply.

ludovic

ludovic

2017-01-12 15:24

administrator   ~0011204

Fix pushed - please test.

finalgene

finalgene

2017-01-13 07:48

reporter   ~0011206

Last edited: 2017-01-13 08:03

View 2 revisions

It works. Thank you.

But during my last test, I found another issue.
I created an invitation from an Exchange user to an SOGo user => it works
The SOGo user accepts the invitation => (wow) it works
As it was a test invitation, the Exchange user send a cancellation to the SOGo user => The date in the SOGo calendar still exists :(

Should I open a new issue for this behavior?

zeroone

zeroone

2017-01-13 07:52

reporter   ~0011207

For me it works as well, thanks a lot!

I cannot confirm the problem with the cancellation described above. My SOGo user receives an email upon cancellation (you have to instruct Outlook or Exchange WebMail to send this notification) and I see a button "remove from calendar". After clicking this button the appointment disappears.

finalgene

finalgene

2017-01-13 08:05

reporter   ~0011209

My SOGo user also receives the cancellation mail.
But on my Activesync device, the date still exists.
Maybe this is a problem with Activesync (sorry that I forgot to give this information)

ludovic

ludovic

2017-01-13 11:03

administrator   ~0011212

"The date in the SOGo calendar still exists"

That is normal - Exchange is an external system, and won't automatically delete the event on SOGo's calendar.

The user has to click on the "delete button" to wipe it.

Related Changesets

sogo: master 9d7d2575

2017-01-12 15:23:09

ludovic

Details Diff
(ix) remove alarms in IMIP responses (fixes 0003925) Affected Issues
0003925
mod - SoObjects/Appointments/SOGoCalendarComponent.m Diff File

sogo: v2 a42d6ce4

2017-01-13 13:17:20

ludovic

Details Diff
(fix) remove all alarms before IMIP reply (fixes 0003925) Affected Issues
0003925
mod - SoObjects/Appointments/SOGoCalendarComponent.m Diff File

Issue History

Date Modified Username Field Change
2016-12-02 01:48 zeroone New Issue
2016-12-02 01:48 zeroone File Added: Screenshot 2016-12-02 07.36.07.png
2017-01-02 04:51 finalgene Note Added: 0011161
2017-01-06 14:40 ludovic Note Added: 0011175
2017-01-07 17:13 finalgene Note Added: 0011176
2017-01-11 11:43 zeroone Note Added: 0011191
2017-01-12 02:06 tfu Note Added: 0011196
2017-01-12 04:55 zeroone Note Added: 0011199
2017-01-12 11:30 tfu Note Added: 0011203
2017-01-12 15:24 ludovic Changeset attached => sogo master 9d7d2575
2017-01-12 15:24 ludovic Assigned To => ludovic
2017-01-12 15:24 ludovic Resolution open => fixed
2017-01-12 15:24 ludovic Note Added: 0011204
2017-01-13 07:48 finalgene Note Added: 0011206
2017-01-13 07:52 zeroone Note Added: 0011207
2017-01-13 08:03 finalgene Note Edited: 0011206 View Revisions
2017-01-13 08:05 finalgene Note Added: 0011209
2017-01-13 11:03 ludovic Note Added: 0011212
2017-01-13 13:18 ludovic Changeset attached => sogo v2 a42d6ce4
2017-01-13 13:20 ludovic Status new => resolved
2017-01-13 13:20 ludovic Fixed in Version => 3.2.6
2019-09-06 08:16 Christian Mack Relationship added related to 0004801