View Issue Details

IDProjectCategoryView StatusLast Update
0000438SOGoWeb Address Bookpublic2016-02-25 09:15
Reporteraschild Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Fixed in Version3.0.2 
Summary0000438: Display all entries of LDAP address book by default (if enabled)
Description

Currently all ldap address books initially show no entries.

Only when the user enters the wildcard (dot) in the search box, all addresses are shown.

For large ldap address books this is OK.
But for small sogo installations, it's somewhat "annoying" for the end users, if they don't directly see all available users.
So we have to educate the end users on how to find the other users, just to assign rights to them. (Or subscribe to calendars etc.)

It would be nice, if we had a configuration option per domain, which would allow the ldap address books be initially show filled.
Something like: SOGoShowAllLdapEntries = YES per domain.

Perhaps just prefill the searchbox with the dot ?

Additional Information

For small installations with < 100 users in the address book, this would be a great help, so the enduser don't have to know about the . character, and there is also no performance reason to not directly show all entries available.

Of course this should behave always the same way, anywhere where the ldap address book is shown (System address book, Assign rights, share folders, subscribe folders/calendars etc.)

TagsNo tags attached.

Relationships

has duplicate 0003464 resolvedfrancis Empty Adressbook in WebGUI with LDAP/ADS 
related to 0000608 new Display all entries of LDAP address book by default (if enabled) for Thunderbird 
related to 0002201 new Shared address book and carddav 

Activities

2010-05-04 11:55

 

SOGo-default_ldap_search_string.patch (730 bytes)   
--- /usr/lib/GNUstep/SOGo/WebServerResources/ContactsUI.js      f33090bc0bb6db51fcc94b95da6d67a3f67e9fec
+++ /usr/lib/GNUstep/SOGo/WebServerResources/ContactsUI.js      86ea9e5bf22f3747edbed0e5e5f237923d7010e5
@@ -42,6 +42,9 @@ function openContactsFolder(contactsFold
         if (searchValue && searchValue.length > 0)
             url += ("&search=" + search["criteria"]
                     + "&value=" + escape(searchValue.utf8encode()));
+        else if (currentFolderIsRemote())
+            url += ("&search=name_or_address"
+                    + "&value=.");
         var sortAttribute = sorting["attribute"];
         if (sortAttribute && sortAttribute.length > 0)
             url += ("&sort=" + sorting["attribute"]
Jason Oster

Jason Oster

2010-05-04 11:57

reporter   ~0000992

Probably not the right way to fix this bug, but this patch is a quick work around for the problem. I wouldn't recommend it on large LDAP directories, but for small directories (<= 200 contacts) it works great.

alessio

alessio

2011-02-22 04:57

reporter   ~0002144

Very useful, some users think that address book is empty. You can display first 100/2o0 entry by default. Like in Thunderbird

sim

sim

2012-10-15 08:12

reporter   ~0004661

I thought I installed SOGo wrong because of this. I understand it now. But I think my users will be baffled. The title says "for Thunderbird". It would be nice to have on the web GUI too.

aschild

aschild

2013-02-06 16:13

reporter   ~0005364

I think the "best" (tm) approach for this wouold be to define in the addressbook definition when we wish to see all entries.
So the admin can decide if the load on the system(s) is acceptable or not

Flamewires

Flamewires

2013-04-01 18:54

reporter   ~0005460

I'd also like this feature, using patch atm.

gmuldoon

gmuldoon

2014-07-28 02:31

reporter   ~0007359

I've never had to apply a patch to SOGo, but I'd certainly like to use this one. How do I apply it?

faisal

faisal

2016-01-29 03:00

reporter   ~0009363

An alternative could be a button like [Show All Contacts] where the user just click. It is easier to understand. Now, if there is too many contact, then SOGo can just show the first 300 and pop a dialog to inform the user that there is too many contacts. Maybe a config, to specify the max no. of contacts to show on [Show All Contacts] button.

Related Changesets

sogo: master 70fbeab2

2016-02-24 21:30:33

francis

Details Diff
(js) Improve sg-search directive

Will now respect the "listRequiresDot" source parameter and uses
ng-messages to show an error if the minimum number of characters is not
reached.

Fixes 0000438, 0003464
Affected Issues
0000438, 0003464
mod - Documentation/SOGoInstallationGuide.asciidoc Diff File
mod - NEWS Diff File
mod - UI/Common/English.lproj/Localizable.strings Diff File
mod - UI/Common/UIxPageFrame.m Diff File
mod - UI/Contacts/UIxContactFoldersView.m Diff File
mod - UI/SOGoUI/UIxComponent.h Diff File
mod - UI/SOGoUI/UIxComponent.m Diff File
mod - UI/Templates/ContactsUI/UIxContactFoldersView.wox Diff File
mod - UI/Templates/MailerUI/UIxMailFolderTemplate.wox Diff File
mod - UI/Templates/SchedulerUI/UIxCalMainView.wox Diff File
mod - UI/Templates/UIxPageFrame.wox Diff File
mod - UI/WebServerResources/js/Common/sgSearch.directive.js Diff File

Issue History

Date Modified Username Field Change
2010-02-18 12:45 aschild New Issue
2010-05-04 11:55 Jason Oster File Added: SOGo-default_ldap_search_string.patch
2010-05-04 11:57 Jason Oster Note Added: 0000992
2011-02-22 04:57 alessio Note Added: 0002144
2012-10-15 08:06 Christian Mack Relationship added related to 0000608
2012-10-15 08:12 sim Note Added: 0004661
2013-01-29 07:29 Christian Mack Relationship added related to 0002201
2013-02-06 16:13 aschild Note Added: 0005364
2013-04-01 18:54 Flamewires Note Added: 0005460
2014-07-28 02:31 gmuldoon Note Added: 0007359
2016-01-28 02:59 Christian Mack Relationship added has duplicate 0003464
2016-01-29 03:00 faisal Note Added: 0009363
2016-02-24 21:44 francis Changeset attached => sogo master 70fbeab2
2016-02-24 21:44 francis Assigned To => francis
2016-02-24 21:44 francis Resolution open => fixed
2016-02-25 09:15 francis Status new => resolved
2016-02-25 09:15 francis Fixed in Version => 3.0.2