View Issue Details

IDProjectCategoryView StatusLast Update
0004008SOGoGUIpublic2018-02-27 09:36
Reporterppjet Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.5 
Fixed in Version4.0.0 
Summary0004008: Can't scroll in the window where mail content is displayed on Firefox
Description

I am unable to scroll in the window where mail content is displayed. Using touchpad/trackpoint doesn't work, nor does moving the scrollbar with my pointer, (it won't move).

Steps To Reproduce
  • Go to Mail
  • Open any email long enough to get a scrollbar, (or reduce window size, etc.)
Additional Information

I tried on Firefox stable (50.1.0) and Nightly (54.0a1). I was told it works on 45.5.1.
I works on chromium stable (55.0.2883.87).

TagsNo tags attached.

Relationships

has duplicate 0004282 resolvedfrancis Can't scroll mail content using Firefox 
has duplicate 0004398 resolvedfrancis Can't scroll contents of email using scrollwheel or scrollbar 

Activities

ppjet

ppjet

2017-01-25 09:14

reporter   ~0011241

I thought I had filled the OS field but I can't see it. I run GNU/Linux (Archlinux).

mindsolve

mindsolve

2017-05-31 18:27

reporter   ~0011893

Last edited: 2017-05-31 18:29

This bug is reproducible with Firefox (Nightly) 55 and SOGo 3.2.9,
but not with Google Chrome 54. (both on Linux Ubuntu 16.10)

francis

francis

2017-06-29 11:37

administrator   ~0012019

Seems solved with the latest Angular Material + Firefox. Can you confirm on demo.sogo.nu? Thanks.

mindsolve

mindsolve

2017-06-29 15:59

reporter   ~0012020

@francis Is not solved with newest FF nightly 55 on Ubuntu. Still cannot scroll.

Steps to reproduce: Open first mail in demo.sogo.nu, login with sogo1, click on first mail, resize window until scrollbar appears in mailcontent area, try to scroll.

Expected result: The text should scoll

Actual result: It doesn't

buzzdee

buzzdee

2017-07-06 17:19

reporter   ~0012049

I had seen the same with FF 54.0.1 on OpenBSD and SOGo 3.2.9, just updated today to SOGo 3.2.10 and now it scrolls.

ppjet

ppjet

2017-07-06 17:33

reporter   ~0012050

I just tried on demo.sogo.nu. Not much content to try on but I reduced the window enough so I get a scroll bar.

There is a calendar invite in the sogo2 account that I had no problem with. Though on sogo3 the one mail I managed to get a scrollbar with I still had the same behavior as the original report.

Using Firefox Nightly (56.0a1 - 2017-06-28)

francis

francis

2017-07-06 20:31

administrator   ~0012053

The demo site wasn't updated. Test again please.

mindsolve

mindsolve

2017-07-07 12:50

reporter   ~0012063

Me (on Nightly 55) can still reproduce the issue.

To simply verify: Create a long (!) new message in one of the demo accounts on demo.sogo.nu, click on save, got to the drafts folder, open the mail and try to scroll.

francis

francis

2017-07-07 13:14

administrator   ~0012064

I can't reproduce the problem with FF 54.0.1.

buzzdee

buzzdee

2017-07-07 16:45

reporter   ~0012065

As I reported yesterday, the problem is gone with FF 54.0.1 (64-bit), but I can reproduce it sill on my work computer Windows 10 with FF 54.0.1 (32-bit)

evilstiefel

evilstiefel

2017-09-04 05:51

reporter   ~0012251

I can confirm this issue with 55.0.3 (32-Bit) of Firefox. When opening a long email, I cannot scoll with the mousewheel hovering over the window. Grabbing the scollbar with the mouse also does not allow me to move the slider.

The only way to "scroll" down or up is giving focus to the mail window and using the up and down arrow-keys.

Corentin

Corentin

2017-11-13 11:55

reporter   ~0012429

I can confirm this issue with FF 56.0 (64 bits) under Ubuntu on demo.sogo.nu with 3.2.10.
It seems to be specific to FF as it works normally on Chronium 62.

A possible hint:
When I open FF webinspector on the message part, there are two div under a div with the class "sg-reversible".
The mouse scrolling works if I remove the seemingly empty div with the class "sg-back layout-fill layout-column", and keep only the div with the class "sg-face layout-fill layout-column".

landry

landry

2017-11-29 04:32

reporter   ~0012455

Can totally confirm corentin's analysis, if i remove the empty div with "sg-back layout-fill layout-column" the scrollbar is active again, using firefox 58.0b6.

This div seems to come from https://github.com/inverse-inc/sogo/blob/master/UI/Templates/MailerUI/UIxMailViewTemplate.wox#L278 but i dunno what it's supposed to be used for, norwhy removing it in the inspector helps.

landry

landry

2017-11-29 04:43

reporter   ~0012456

Ah, the sg-back div is the 'view source' window, and they're swappable with the sg-face which is the 'default msg view' window. Interestingly, the scrollbar works in the sg-back/view-source div... but maybe because the latter is simpler. I understand nothing to the css :)

landry

landry

2017-11-29 05:00

reporter   ~0012457

And i found out that disabling animations (in the general config) works around the issue, even if its not a proper fix.

dr4Ke

dr4Ke

2017-12-08 07:59

reporter   ~0012466

I have this same issue using Windows 8.1 with Firefox 57.0 (64bits).
The scrolling actually works, in the background, for the source view. Ie: when I scroll on the email view, nothing happens, but when I switch to the source view, I can see it has scrolled.
Strangely, I didn't have this issue with Firefox 56 and previous versions.

dr4Ke

dr4Ke

2017-12-08 08:07

reporter   ~0012468

I tried with all extensions disabled (--safe-mode) and it's still an issue for me. A precision on my previous comment: the scrolling in the background happens only when I have activated at least once the source view and switched back to the email view.

FoZo

FoZo

2018-01-15 07:07

reporter   ~0012510

I have the same problem.
Gentoo with FF 57.0.4

Related Changesets

sogo: master a75ae849

2018-02-27 09:30:12

francis

Details Diff
(css) Fix scrolling of message with Firefox

Fixes 0004008, 0004282, 0004398
Affected Issues
0004008, 0004282, 0004398
mod - NEWS Diff File
mod - UI/WebServerResources/scss/views/_view.scss Diff File

Issue History

Date Modified Username Field Change
2017-01-25 09:09 ppjet New Issue
2017-01-25 09:14 ppjet Note Added: 0011241
2017-05-31 18:27 mindsolve Note Added: 0011893
2017-05-31 18:29 mindsolve Note Edited: 0011893
2017-06-29 11:37 francis Note Added: 0012019
2017-06-29 15:59 mindsolve Note Added: 0012020
2017-07-06 17:19 buzzdee Note Added: 0012049
2017-07-06 17:21 francis Status new => resolved
2017-07-06 17:21 francis Fixed in Version => 3.2.10
2017-07-06 17:21 francis Resolution open => fixed
2017-07-06 17:21 francis Assigned To => francis
2017-07-06 17:33 ppjet Note Added: 0012050
2017-07-06 17:33 ppjet Status resolved => feedback
2017-07-06 17:33 ppjet Resolution fixed => reopened
2017-07-06 20:31 francis Note Added: 0012053
2017-07-07 12:50 mindsolve Note Added: 0012063
2017-07-07 13:14 francis Note Added: 0012064
2017-07-07 16:45 buzzdee Note Added: 0012065
2017-09-04 05:51 evilstiefel Note Added: 0012251
2017-09-10 08:59 francis Relationship added has duplicate 0004282
2017-11-13 11:55 Corentin Note Added: 0012429
2017-11-29 04:32 landry Note Added: 0012455
2017-11-29 04:43 landry Note Added: 0012456
2017-11-29 05:00 landry Note Added: 0012457
2017-12-08 07:59 dr4Ke Note Added: 0012466
2017-12-08 08:07 dr4Ke Note Added: 0012468
2018-01-15 07:07 FoZo Note Added: 0012510
2018-02-27 09:35 francis Changeset attached => sogo master a75ae849
2018-02-27 09:35 francis Status feedback => resolved
2018-02-27 09:35 francis Fixed in Version 3.2.10 => 4.0.0
2018-02-27 09:35 francis Resolution reopened => fixed
2018-02-27 09:36 francis Relationship added has duplicate 0004398