View Issue Details

IDProjectCategoryView StatusLast Update
0003494SOGoWeb Calendarpublic2016-03-04 09:45
Reporterandre.peters Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version3.0.0 
Fixed in Version3.0.2 
Summary0003494: Calendar selects date 1 day in the past
Description

Made a gifv: http://i.imgur.com/hGvjuge.gifv

Example: Selecting March 21th in the calendar gives me March 20th as date in the popup.

SOGoFirstDayOfWeek is 1.

TagsNo tags attached.

Relationships

related to 0003481 resolvedfrancis Day Selected in the Addressbook Calendar is off by one form the one shown after selection 
has duplicate 0003550 resolvedfrancis Time shifts when saving/modifying all-day-events in SOGo web interface 

Activities

francis

francis

2016-02-03 17:39

administrator   ~0009439

What is your timezone?

andre.peters

andre.peters

2016-02-05 05:41

reporter   ~0009445

Hi, sorry - BugTracker told me this issue was gone, now I can see it again.
TZ is Europe/Berlin.

Arvoreen

Arvoreen

2016-02-05 12:17

reporter   ~0009449

Last edited: 2016-02-05 12:19

Seems to be the same problem as in the Addressbook (see 0003481)
SOGoTimeZone = Europe/Luxembourg;

francis

francis

2016-02-08 16:11

administrator   ~0009469

Can you reproduce the problem with the latest nightly build or on demo.sogo.nu?

andre.peters

andre.peters

2016-02-09 02:19

reporter   ~0009472

Yes, same problem.

andre.peters

andre.peters

2016-02-09 12:14

reporter   ~0009483

Last edited: 2016-02-09 12:44

Set my computers timezone to UTC-8 and now it show the correct date.
It seems like something (JS?) does not respect the clients timezone.
Edit: Related? https://github.com/angular-ui/bootstrap/issues/2072

Related Changesets

sogo: master 9dd444e6

2016-03-02 16:14:36

francis

Details Diff
(js) Fix date parsing for timezone after UTC+0

Fixes 0003481, 0003494
Affected Issues
0003481, 0003494
mod - NEWS Diff File
mod - UI/WebServerResources/js/Common/utils.js Diff File

Issue History

Date Modified Username Field Change
2016-02-03 08:40 andre.peters New Issue
2016-02-03 17:39 francis Note Added: 0009439
2016-02-05 05:41 andre.peters Note Added: 0009445
2016-02-05 12:17 Arvoreen Note Added: 0009449
2016-02-05 12:19 Arvoreen Note Edited: 0009449
2016-02-08 09:45 Christian Mack Relationship added related to 0003481
2016-02-08 16:11 francis Note Added: 0009469
2016-02-09 02:19 andre.peters Note Added: 0009472
2016-02-09 12:14 andre.peters Note Added: 0009483
2016-02-09 12:44 andre.peters Note Edited: 0009483
2016-03-02 16:15 francis Changeset attached => sogo master 9dd444e6
2016-03-02 16:15 francis Assigned To => francis
2016-03-02 16:15 francis Resolution open => fixed
2016-03-03 09:16 francis Status new => resolved
2016-03-03 09:16 francis Fixed in Version => 3.0.2
2016-03-04 09:45 francis Relationship added has duplicate 0003550