View Issue Details

IDProjectCategoryView StatusLast Update
0003481SOGoWeb Address Bookpublic2016-03-04 09:45
ReporterArvoreen Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version8
Product Version3.0.0 
Fixed in Version3.0.2 
Summary0003481: Day Selected in the Addressbook Calendar is off by one form the one shown after selection
Description

When you select for example a birthday in the Addressbook. The day show after you clicked on the date is the selected date -1. Perhaps a locale problem?

Steps To Reproduce

Select for example the 4 march 2008 in the Addressbook as birtday for a contact and you will be shown the 3 march 2008.

Additional Information

Perhaps a locale problem?
I tested it on the official Sogo3 demo after I found out on my debian server. I use the packages form : deb http://inverse.ca/debian-v3 jessie jessie

TagsNo tags attached.

Relationships

has duplicate 0003550 resolvedfrancis Time shifts when saving/modifying all-day-events in SOGo web interface 
related to 0003494 resolvedfrancis Calendar selects date 1 day in the past 

Activities

Arvoreen

Arvoreen

2016-02-05 12:15

reporter   ~0009448

Seems to be the same Problem in the Addressbook as in Calendar (seen 0003494)

Related Changesets

sogo: master 9dd444e6

2016-03-02 16:14:36

francis

Details Diff
(js) Fix date parsing for timezone after UTC+0

Fixes 0003481, 0003494
Affected Issues
0003481, 0003494
mod - NEWS Diff File
mod - UI/WebServerResources/js/Common/utils.js Diff File

Issue History

Date Modified Username Field Change
2016-02-01 16:36 Arvoreen New Issue
2016-02-05 12:15 Arvoreen Note Added: 0009448
2016-02-08 09:45 Christian Mack Relationship added related to 0003494
2016-03-02 16:15 francis Changeset attached => sogo master 9dd444e6
2016-03-02 16:15 francis Assigned To => francis
2016-03-02 16:15 francis Resolution open => fixed
2016-03-03 09:16 francis Status new => resolved
2016-03-03 09:16 francis Fixed in Version => 3.0.2
2016-03-04 09:45 francis Relationship added has duplicate 0003550