View Issue Details

IDProjectCategoryView StatusLast Update
0003364SOGoActiveSyncpublic2016-01-08 07:26
Reporterdanbet Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platform[Server] LinuxOSUbuntuOS Version14.04 LTS
Product Version2.3.2 
Fixed in Version2.3.4 
Summary0003364: Repetitive eventswith occurrences exceptions are currently not supported.
Description

This is what you mention in your installation instructions. I assumed that this restriction is only valid for Outlook 2013, but I see this on every device that is synched with EAS. This is unusable and I ask you if there is the chance that you fix this, especially because ActiveSync is the only sync method for Windows Phone. Z-Push and Syncroton doesn't have this problem as I know, so it should be possible for you to make it away.

TagsNo tags attached.

Activities

nimm

nimm

2015-10-13 03:11

reporter   ~0008989

For Outlook you can use Outlook CalDavSynchronizer which supports recurrence exceptions. And for Windows Phone 8.1 or later you can sync via CalDAV with the help of a fake icloud sync profile, see https://www.reddit.com/r/windowsphone/comments/23o89h/setting_up_carddav_and_caldav_on_windows_phone_81/

danbet

danbet

2015-10-16 05:24

reporter   ~0009012

Microsoft and Outlook is the first thing you mention on http://www.sogo.nu. I choosed SOGo not only because of the DAV compatibility (the green color in your graphic in the product overview) but also because of the promise to work with ActiveSync and even native with OpenChange (the blue and red color in the overview).
Your recommondation to use CalDavSynchronizer and the workaround on WP with the iCloud account helps me. Thank you. But it says me also that only the green color from the overview is working for production.
In the past it seems that I have the choice of a server product that supports DAV or ActiveSync, but not both. In SOGo i hoped to find the one that support both. In theory yes, in practice no. This is only a statement, not more.
Thank you for your work. It's great!

ethoms

ethoms

2015-11-19 10:12

reporter   ~0009121

I think this is related to bug 0003371:

http://www.sogo.nu/bugs/view.php?id=3371

It's my understanding, this isn't really SOGos' fault. It's Outlook that doesn't support advanced recurrence. If these recurrence types are in the RFC, it's Outlook that is to blame. And how long they have been in RFC without being implemeneted would determine the degree of shame.

ludovic

ludovic

2016-01-08 07:26

administrator   ~0009255

This has been fixed 2.3.4

Issue History

Date Modified Username Field Change
2015-10-12 05:42 danbet New Issue
2015-10-13 03:11 nimm Note Added: 0008989
2015-10-16 05:25 danbet Note Added: 0009012
2015-11-19 10:12 ethoms Note Added: 0009121
2016-01-08 07:26 ludovic Note Added: 0009255
2016-01-08 07:26 ludovic Status new => closed
2016-01-08 07:26 ludovic Assigned To => ludovic
2016-01-08 07:26 ludovic Resolution open => fixed
2016-01-08 07:26 ludovic Fixed in Version => 2.3.4