View Issue Details

IDProjectCategoryView StatusLast Update
0000289SOGoBackend Calendarpublic2009-12-19 21:01
ReporterwsourdeauAssigned Toludovic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version1.2.0 
Summary0000289: error with CalDAV POSTS (url handling)
Description

When responding to an invitation, I get this error message during the CalDAV post:

refresh completed with status 207 at https://XXX/SOGo/dav/XXX/Calendar/personal/
Sending iITIP failed with status 404CalDAV: recv: <?xml version="1.0" encoding="ISO-8859-1"?>
<html xmlns="http://www.w3.org/1999/xhtml&quot;>
<body><h3>An error occurred during object publishing</h3><p>the requested object could not be found!</p></body>
</html>
CalDAV: failed delivery to

(the last sentence is indeed ellided)

Server-side, the log shows this, which is related to URL handling:

localhost - - [15/Dec/2009:10:34:31 GMT] "POST /SOGo/dav/wsourdeau/Calendarpersonal/ HTTP/1.1" 404 208/1047 0.021 - - 0

TagsNo tags attached.

Relationships

related to 0000276 assignedwsourdeau iCal work-around: davURL should become davURLAsString 
related to 0000074 resolvedludovic CalDAV URL issues with scheduling 

Activities

wsourdeau

wsourdeau

2009-12-15 10:37

viewer   ~0000351

The issues might be a bug in Lightning. This needs to be checked.

ludovic

ludovic

2009-12-19 21:01

administrator   ~0000364

Fixed by http://mtn.inverse.ca/revision/diff/9450e3b1be295b0872d67069c597a4a4929f1b64/with/d128523a11c890ea68c1606ab37270a6740d6e8e

Also tested an invitation, everything seems to be working as expected.

Issue History

Date Modified Username Field Change
2009-12-15 10:36 wsourdeau New Issue
2009-12-15 10:36 wsourdeau Relationship added related to 0000276
2009-12-15 10:37 wsourdeau Note Added: 0000351
2009-12-18 16:36 ludovic Relationship added related to 0000074
2009-12-18 16:36 ludovic Status new => assigned
2009-12-18 16:36 ludovic Assigned To => ludovic
2009-12-19 21:01 ludovic Note Added: 0000364
2009-12-19 21:01 ludovic Status assigned => resolved
2009-12-19 21:01 ludovic Fixed in Version => 1.1.1
2009-12-19 21:01 ludovic Resolution open => fixed