View Issue Details

IDProjectCategoryView StatusLast Update
0000276SOGoBackend Generalpublic2021-09-16 17:43
ReporterwsourdeauAssigned Towsourdeau 
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0000276: iCal work-around: davURL should become davURLAsString
Description

iCal is pretty picky on urls and currently does not work with SOGo. Collection urls should end with "/" while regular object urls should not. On the other hand, SOPE does not return that kind of url in its response hrefs when answering to PROPFIND requests (and it actually does not have to, since the bug is in iCal). The easiest way to fix this is to make davURL return an NSString in SOGoObject and have SOGoFolder override the method and add a "/" to the result of the super method.

The full fix would also require SOPE to return the url as it was specified in the PROPFIND request.

This takes time (possibly 1/2 day) and requires full testing with iCal 3, iCal 4, the extensions and possibly the web interface. The test script "test-webdav.py" should be enhanced to ensure the behaviour mentionned above:

PROPFIND with depth 0 on /collection/ should return /collection/, and on /object should return /object
PROPFIND with depth 1 on /collection(/) should return /collection(/) and /subsequent-collection/ and /subsequent-object.

TagsNo tags attached.

Relationships

related to 0000074 resolvedludovic CalDAV URL issues with scheduling 
related to 0000233 resolvedludovic iCal 4 won't sync with SOGo with multiple calendars 
related to 0000289 resolvedludovic error with CalDAV POSTS (url handling) 

Activities

wsourdeau

wsourdeau

2010-01-14 23:21

viewer   ~0000443

implemented for PROPFIND. REPORT returns all collection URLS with an ending /. Since this latter behaviour is sufficient for the Apple products but not compliant with the bug description, the bug is left open.

Issue History

Date Modified Username Field Change
2009-12-08 17:18 wsourdeau New Issue
2009-12-08 17:26 wsourdeau Relationship added related to 0000233
2009-12-15 10:36 wsourdeau Relationship added related to 0000289
2009-12-18 16:35 ludovic Relationship added related to 0000074
2010-01-07 09:20 ludovic Target Version => 1.2.0
2010-01-14 23:21 wsourdeau Note Added: 0000443
2010-01-14 23:22 wsourdeau Assigned To => wsourdeau
2010-01-14 23:22 wsourdeau Priority normal => low
2010-01-14 23:22 wsourdeau Status new => assigned
2010-01-22 11:50 francis Target Version 1.2.0 => 1.2.1
2010-02-15 16:31 wsourdeau Target Version 1.2.1 =>
2021-09-16 17:43 francis Status assigned => resolved
2021-09-16 17:43 francis Resolution open => fixed