View Issue Details

IDProjectCategoryView StatusLast Update
0000968SOGo IntegratorBackend Address Bookpublic2010-11-15 11:26
Reporteralessio Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version3.104 
Summary0000968: Duplicate contacts every restart if user had contacts in their address book before the extensions are installed
Description

If a user had contacts in their address book before the extensions are installed those contacts are correctly imported to the "personal" address book. However every time the user starts TB they are again imported in the address book duplicating every entry. Deleting the contacts does not help. They are recreated every time. Only a new TB profile with empty address book helps. This gets ugly pretty fast (had a user with 14000 contacts after just a week).

Additional Information

It's very difficult to clean this situation!

TagsNo tags attached.

Activities

ludovic

ludovic

2010-11-11 06:45

administrator   ~0001755

Try with the updated SOGo Connector and Integrator (CUSTOMIZE IT) available from http://inverse.ca/downloads/extensions/nightly/

alessio

alessio

2010-11-11 07:15

reporter   ~0001756

With last SOGo Connector and Integrator the problem is fixed. Because Personal and Colletioned Address Book are not merged, they remains local. I think that is better.

ludovic

ludovic

2010-11-11 07:16

administrator   ~0001758

Post your feedback on the list so others can benefit from it and try the extensions as a release is coming up.

alessio

alessio

2010-11-11 08:26

reporter   ~0001759

Done, but how can i delete duplicate contacts? By hand with thousands of contacts, for every client, is very very hard.

ludovic

ludovic

2010-11-11 08:30

administrator   ~0001760

sogo-tool remove-doubles, and clear the mab files in TB.

alessio

alessio

2010-11-11 08:58

reporter   ~0001761

sogo@sogo root]$ sogo-tool -v check-doubles
The warning limit for folder records is set at 1000
2010-11-02 15:21:21.868 sogo-tool[5366] ERROR: could not open MySQL4 connection to database 'sogo': Access denied for user 'sogo'@'localhost' (using password: YES)
<0x0x909d450[GCSChannelManager]> could not open channel <MySQL4Channel[0x0x911acf0] connection=0x(null)> for URL: mysql://sogo:sogo@127.0.0.1:3306/sogo/sogocristian00177046988
<0x0x909d450[GCSChannelManager]> will prevent opening of this channel 5 seconds after 2010-11-02 15:21:21 +0100

How can i pass mysql sogo password to sogo-tool?

This is my conf:

OCSFolderInfoURL = "mysql://sogo:BSgN98cxQ238zr.3L6IcAH.Hsg5etHYVrE6L3YDIKqDkNNNyydDKnVw2S+4ptktMwTCSvuT79gSU@localhost/sogo/sogo_folder_info";
..
SOGoProfileURL = "mysql://sogo:BSgN98cxQ238zr.3L6IcAH.Hsg5etHYVrE6L3YDIKqDkNNNyydDKnVw2S+4ptktMwTCSvuT79gSU@localhost/sogo/sogo_user_profile";

ludovic

ludovic

2010-11-11 09:02

administrator   ~0001762

run sogo-tool under the same user as the sogod daemon.

alessio

alessio

2010-11-11 09:13

reporter   ~0001763

Last edited: 2010-11-11 09:14

I'm sogo user

[sogo@sogo root]$ id
uid=3000(sogo) gid=3000(sogo) gruppi=3000(sogo)

the same user as the sogod daemon

sogo 4638 1.3 2.2 22580 5688 ? S 14:29 0:46 /usr/GNUstep/System/Tools/Admin/sogod -WOWorkersCount 1 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log/sogo/sogo.log
sogo 4639 0.2 6.8 31696 17488 ? Ss 14:29 0:07 /usr/GNUstep/System/Tools/Admin/sogod -WOWorkersCount 1 -WOPidFile /var/run/sogo/sogo.pid -WOLogFile /var/log/sogo/sogo.log

alessio

alessio

2010-11-11 09:31

reporter   ~0001765

Why it use password "sogo"? For user "sogo" ?

for URL: mysql://sogo:sogo@127.0.0.1:3306/sogo/sogocristian00177046988

IMy password is set above (last note) and it's different. Where sogo-tool read password? How can i change it?

wsourdeau

wsourdeau

2010-11-15 09:42

viewer   ~0001806

sogo-tool uses the same code as SOGo for connecting to the database and make use of the infos stored in the record for OCSFolderInfo. So this should not happen because no password handling is performed from sogo-tool itself.

alessio

alessio

2010-11-15 09:54

reporter   ~0001807

you're right, i don't understand why my db was dirty like above :-|

wsourdeau

wsourdeau

2010-11-15 11:24

viewer   ~0001810

Hi Alessio,

Probably because you have changed your db coordinates of your production system. Old coordinates, created before the change have been kept and are still used. This likely cause issues with the users in question as well...

wsourdeau

wsourdeau

2010-11-15 11:26

viewer   ~0001811

Fixed one week ago.

Issue History

Date Modified Username Field Change
2010-11-11 04:04 alessio New Issue
2010-11-11 06:45 ludovic Note Added: 0001755
2010-11-11 07:15 alessio Note Added: 0001756
2010-11-11 07:16 ludovic Note Added: 0001758
2010-11-11 08:26 alessio Note Added: 0001759
2010-11-11 08:30 ludovic Note Added: 0001760
2010-11-11 08:58 alessio Note Added: 0001761
2010-11-11 09:02 ludovic Note Added: 0001762
2010-11-11 09:13 alessio Note Added: 0001763
2010-11-11 09:14 alessio Note Edited: 0001763
2010-11-11 09:31 alessio Note Added: 0001765
2010-11-15 09:42 wsourdeau Note Added: 0001806
2010-11-15 09:54 alessio Note Added: 0001807
2010-11-15 11:22 wsourdeau Project SOGo => SOGo Integrator
2010-11-15 11:24 wsourdeau Note Added: 0001810
2010-11-15 11:26 wsourdeau Note Added: 0001811
2010-11-15 11:26 wsourdeau Status new => resolved
2010-11-15 11:26 wsourdeau Fixed in Version => 3.104
2010-11-15 11:26 wsourdeau Resolution open => fixed
2010-11-15 11:26 wsourdeau Assigned To => wsourdeau