View Issue Details

IDProjectCategoryView StatusLast Update
0000955SOGoWeb Preferencespublic2010-11-08 13:46
Reporterwbrune Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.4Fixed in Version1.3.4 
Summary0000955: sieve server searched at localhost instead of mailserver
Description

when clicking on 'save and close' in the preference window i get an proxy error. i think sogo tries to connect to the sieve server (port 2000) but my sieve server is located at my mailserver which is not localhost.
in 1.3.3 everything was fine and sogo used the sieve server located at my mailserver.

Additional Information

Nov 07 15:52:26 sogod [19220]: <0x0x254d490[WOPasswordField]> -[WOInput takeValuesFromRequest:inContext:]: form value is not settable: <0x0x254d700[WOValueAssociation]: value="">
Nov 07 15:52:26 sogod [19220]: <0x0x254dfd0[WOPasswordField]> -[WOInput takeValuesFromRequest:inContext:]: form value is not settable: <0x0x254e240[WOValueAssociation]: value="">
EXCEPTION: <NGCouldNotConnectException: 0x2690250> NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0x259f850[NGInternetSocketAddress]: host=localhost port=2000>: connection refused INFO:(nil)
Nov 07 15:52:26 sogod [13240]: <0x0x1e3ea30[WOWatchDogChild]> child 19220 exited
Nov 07 15:52:26 sogod [13240]: <0x0x1e3ea30[WOWatchDogChild]> (terminated due to signal 6)

TagsNo tags attached.

Activities

ludovic

ludovic

2010-11-07 10:08

administrator   ~0001724

Right now it indeed defaults to localhost but it should indeed default to the IMAP server. You can set the Sieve server through a pref, see:

http://sogo.nu/bugs/view.php?id=821

ludovic

ludovic

2010-11-08 13:46

administrator   ~0001734

Fixed with http://mtn.inverse.ca/revision/diff/b35d04c6cd2614e48feea1b1dacb0a61aa27fe44/with/19bd38381f65942b0903a2e2aaa8abbc9c9862ab

Issue History

Date Modified Username Field Change
2010-11-07 10:05 wbrune New Issue
2010-11-07 10:08 ludovic Note Added: 0001724
2010-11-07 11:13 ludovic Target Version => 1.3.4
2010-11-08 13:46 ludovic Note Added: 0001734
2010-11-08 13:46 ludovic Status new => resolved
2010-11-08 13:46 ludovic Fixed in Version => 1.3.4
2010-11-08 13:46 ludovic Resolution open => fixed
2010-11-08 13:46 ludovic Assigned To => ludovic