View Issue Details

IDProjectCategoryView StatusLast Update
0000842SOGoSOPEpublic2011-03-30 15:47
Reporterbuzzdee Assigned Towsourdeau 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.1 
Fixed in Version1.3.6 
Summary0000842: prevent SOPE from linking against gnustep-gui when it is installed -- with patch
Description

I recognized that when compiling SOPE, from the sope-1.3.1.tar.gz, then it links against gnustep-gui, in case it is installed.

A patch to the ./configure script is attached, in order to add a
NEEDS_GUI=no statement to the config.make file that gets created.

Additional Information

tested with gnustep-make-2.4.0 and gnustep-base-1.20.1 on OpenBSD 4.8.

NOTE: This patch also switches the shell to use, now /bin/sh instead of /bin/bash.
Since on OpenBSD bash installs to /usr/local/bin/bash and there is no link in /bin to it. This is probably also true for other *BSD. /bin/sh is a hardlink to /bin/ksh on OpenBSD.

TagsNo tags attached.

Activities

2010-09-18 11:27

 

patch-configure (563 bytes)   
$OpenBSD$

do not link against gnustep-gui in case its installed

--- configure.orig	Thu Aug 19 17:13:13 2010
+++ configure	Sat Sep 18 16:28:34 2010
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
 
 #
 # Note: When adding make options to this script, ensure that the source still
@@ -318,6 +318,7 @@ genConfigMake() {
   cfgwrite "# Note: you can override any option as a 'make' parameter, eg:"
   cfgwrite "#         make debug=yes"
   cfgwrite ""
+  cfgwrite "NEEDS_GUI=no"
   
   #cfgwrite "# print on the cmdline that this file is being used"
   #cfgwrite "all :: "
patch-configure (563 bytes)   
wsourdeau

wsourdeau

2010-09-20 10:01

viewer   ~0001483

The reason why "/bin/bash" is used is because the script makes use of "bashisms" and on FHS systems all the shells are available from /bin/. Is it possible to work-around this in your port file instead?

buzzdee

buzzdee

2010-09-20 10:51

reporter   ~0001485

In 1.3.0, the configure script was full with bashisms, but in 1.3.1, its not anymore, at least it works for me with ksh. I have to admit, haven't tested with other possible /bin/sh's. Anyways, its no problem for the port to patch the configure script to exchange /bin/bash with /bin/sh.

But the NEEDS_GUI=no hopefully makes sense to add.

wsourdeau

wsourdeau

2011-03-30 15:47

viewer   ~0002325

Fixed in a3d4e55651cc3665bc700bca6ff9fe90cfdd5a85. Thanks. NOte that this does not seem to be needed with recent versinos of gnustep-make...

Issue History

Date Modified Username Field Change
2010-09-18 11:27 buzzdee New Issue
2010-09-18 11:27 buzzdee File Added: patch-configure
2010-09-20 10:01 wsourdeau Note Added: 0001483
2010-09-20 10:51 buzzdee Note Added: 0001485
2011-03-30 15:47 wsourdeau Note Added: 0002325
2011-03-30 15:47 wsourdeau Status new => resolved
2011-03-30 15:47 wsourdeau Fixed in Version => 1.3.6
2011-03-30 15:47 wsourdeau Resolution open => fixed
2011-03-30 15:47 wsourdeau Assigned To => wsourdeau