View Issue Details

IDProjectCategoryView StatusLast Update
0000821SOGoBackend Generalpublic2010-11-02 16:48
Reporteraschild Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.1 
Target Version1.3.4Fixed in Version1.3.4 
Summary0000821: Allow to specify sieve port
Description

In the past cyrus sieve did use port 2000.

Now with the new debian releases the default port has changed
to the officially IANA assigned port 4190.

But it looks like sogo (installed on another server) is not using the new port.

We did change it in /etc/services and restarted sogo, but it looks like
it does not take the port from /etc/services....

It would be nice to able to specify the sieve port (and/or) perhaps take it from the /etc/services file (with the option to override it per domain/mailserver)

Additional Information

As a work arround,
it's possible to tell cyrus to listen on multiple ports for sieve.

TagsNo tags attached.

Activities

ludovic

ludovic

2010-11-02 16:48

administrator   ~0001694

Implemented with :

http://mtn.inverse.ca/revision/diff/e6342c0609e8ea9e5aa666ae499c259d902adbec/with/a9b4a2aae19f072168fdfc23b91ebc443e0d55c4

You can now specify :

sieve://foo.bar
sieve://foo.bar:4190

Issue History

Date Modified Username Field Change
2010-09-10 10:29 aschild New Issue
2010-09-14 14:56 ludovic Status new => assigned
2010-09-14 14:56 ludovic Assigned To => ludovic
2010-10-25 15:21 ludovic Target Version => 1.3.4
2010-11-02 16:48 ludovic Note Added: 0001694
2010-11-02 16:48 ludovic Status assigned => resolved
2010-11-02 16:48 ludovic Fixed in Version => 1.3.4
2010-11-02 16:48 ludovic Resolution open => fixed