View Issue Details

IDProjectCategoryView StatusLast Update
0000786SOGoWeb Calendarpublic2010-09-03 15:55
Reporterbertails Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.0 
Target Version1.3.2Fixed in Version1.3.2 
Summary0000786: SOGo crashes with 5000 events
Description

If I import more than 5000 events from an ics file in a calendar, then each time I try to access the web interface with this user, SOGo crashes and reloads itself.

I have tried to increase the amount of memory but it does not change anything.

It seems that SOGo actually restarts several times (maybe because of several requests from the web interface).

Here are the logs:
[[
127.0.0.1 - - [27/Aug/2010:15:43:20 GMT] "GET /SOGo/ HTTP/1.1" 302 0/0 0.008 - - 8K
127.0.0.1 - - [27/Aug/2010:15:43:20 GMT] "GET /SOGo/XXX HTTP/1.1" 302 0/0 0.000 - - 4K
127.0.0.1 - - [27/Aug/2010:15:43:20 GMT] "GET /SOGo/XXX/view HTTP/1.1" 302 0/0 0.004 - - 0
127.0.0.1 - - [27/Aug/2010:15:43:20 GMT] "GET /SOGo/so/XXX/Calendar HTTP/1.1" 302 0/0 0.004 - - 0
127.0.0.1 - - [27/Aug/2010:15:43:20 GMT] "GET /SOGo/so/XXX/Calendar/view HTTP/1.1" 200 10183/0 0.048 40815 75% 0
127.0.0.1 - - [27/Aug/2010:15:43:21 GMT] "POST /SOGo/so/XXX/Calendar/personal/canAccessContent HTTP/1.1" 204 0/0 0.004 - - 0
127.0.0.1 - - [27/Aug/2010:15:43:21 GMT] "POST /SOGo/so/XXX/Calendar/1D02-4C76C980-19-2D620B00/canAccessContent HTTP/1.1" 204 0/0 0.004 - - 0
127.0.0.1 - - [27/Aug/2010:15:43:21 GMT] "POST /SOGo/so/XXX/Calendar/alarmslist?browserTime=1282938202 HTTP/1.1" 200 2/0 0.092 - - 0
EXCEPTION: <NSException: 0xda77e0> NAME:NSGenericException REASON:Parse failed - Parse failed at line 1 (char 1001) - reached end of string while parsing quoted string INFO:(nil)
Aug 27 15:43:21 sogod: SOGo watchdog [15754]: <0x0x89c1f0[WOWatchDogChild]> child 16397 exited
Aug 27 15:43:21 sogod: SOGo watchdog [15754]: <0x0x89c1f0[WOWatchDogChild]> (terminated due to signal 6)
Aug 27 15:43:21 sogod: SOGo watchdog [16443]: SNS support disabled.
Aug 27 15:43:21 sogod: SOGo watchdog [15754]: <0x0x864b40[WOWatchDog]> child spawned with pid 16443
Aug 27 15:43:21 sogod: SOGo watchdog [16443]: <0x0xc44000[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
Aug 27 15:43:21 sogod: SOGo watchdog [16443]: <0x0xc44000[SOGoProductLoader]> Mailer.SOGo, CommonUI.SOGo, MailPartViewers.SOGo, AdministrationUI.SOGo, MailerUI.SOGo, Appointments.SOGo, MainUI.SOGo, PreferencesUI.SOGo, SchedulerUI.SOGo, ContactsUI.SOGo, Contacts.SOGo
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: |SOGo| version 1.3.0 (build @vizzini.inverse.ca 201007211512) -- starting
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: |SOGo| vmem size check enabled: shutting down app when vmem > 384 MB
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: <0x0x89d3f0[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: <0x0x89d3f0[SOGoCache]> Using host(s) 'localhost' as server(s)
2010-08-27 15:43:22.189 sogod[16443] Note(SoObject): SoDebugKeyLookup is enabled!
2010-08-27 15:43:22.189 sogod[16443] Note(SoObject): SoDebugBaseURL is enabled!
2010-08-27 15:43:22.189 sogod[16443] Note(SoObject): relative base URLs are enabled.
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: [WARN] <0x0x6f27a0[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: [WARN] <0x0x6f27a0[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Aug 27 15:43:22 sogod: SOGo watchdog [16443]: [WARN] <0x0x6f27a0[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
127.0.0.1 - - [27/Aug/2010:15:43:22 GMT] "POST /SOGo/so/XXX/Calendar/taskslist?show-completed=NaN HTTP/1.1" 200 140/0 0.124 - - 636K
2010-08-27 15:43:22.317 sogod[16443] ERROR(-[NGBundleManager bundleWithPath:]): could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.16/Resources/SSL.bundle'
2010-08-27 15:43:22.325 sogod[16443] WOCompoundElement: pool embedding is on.
2010-08-27 15:43:22.325 sogod[16443] WOCompoundElement: id logging is on.
127.0.0.1 - - [27/Aug/2010:15:43:22 GMT] "POST /SOGo/so/XXX/Calendar/monthview HTTP/1.1" 200 1138/0 0.040 6459 82% 940K
EXCEPTION: <NSException: 0x8a3820> NAME:NSGenericException REASON:Parse failed - Parse failed at line 1 (char 1001) - reached end of string while parsing quoted string INFO:(nil)
]]

Additional Information

It seems that SOGo actually restarts several times (maybe because of several requests from the web interface).

There is no problem when accessing this calendar with Gnome/evolution.

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2010-08-27 16:27

viewer   ~0001390

Last edited: 2010-08-27 16:31

Can we have the sample you are using so that we can track the event that is posing problem?

bertails

bertails

2010-08-27 16:54

reporter   ~0001394

I first have to erase the sensible data in it, but I'll give you that ASAP.

By the way, I have also tried to access the calendar from iCal and there is the same problem (the server restarts). Here is the message I got from iCal:

[[
The request for account “XXX@cal-dev.w3.org” failed.

The server responded with
“HTTP/1.1 502 Proxy Error”
to operation CalDAVAccountRefreshQueueableOperation.
]]

ludovic

ludovic

2010-09-03 15:55

administrator   ~0001411

Fixed in http://mtn.inverse.ca/revision/diff/105b4d78ea10a9821986149f8e9f4e646deacb5b/with/8cb90e9b9131045b60db27358a0651385c689a42

EXISTING tables should be modified.

Issue History

Date Modified Username Field Change
2010-08-27 15:46 bertails New Issue
2010-08-27 16:27 wsourdeau Note Added: 0001390
2010-08-27 16:31 wsourdeau Note Edited: 0001390
2010-08-27 16:54 bertails Note Added: 0001394
2010-09-01 19:36 ludovic Target Version => 1.3.2
2010-09-03 15:55 ludovic Note Added: 0001411
2010-09-03 15:55 ludovic Status new => resolved
2010-09-03 15:55 ludovic Fixed in Version => 1.3.2
2010-09-03 15:55 ludovic Resolution open => fixed
2010-09-03 15:55 ludovic Assigned To => ludovic