View Issue Details

IDProjectCategoryView StatusLast Update
0000070SOGoBackend Calendarpublic2009-07-23 15:26
Reporterantt Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.0.4 
Summary0000070: email notifications to multiple attendees from iCal
Description

When I try to create an appointment through iCal with more than one attendee, I get

<0x0xa0ee8b8[SOGoMailer]> error with recipient 'user1@domain.com,mailto:user2@domain.com'
and then SOGo dies:

EXCEPTION: <NSException: 0xa11ec88> NAME:SMTPException REASON:require state 2, now in 3 INFO:(nil)

child 30628 (0000005) was terminated by signal 6 (uptime=34s).

2009-07-20 10:15:24.432 sogod[30636] starting SOGo

in the mail server log I get

warning: Illegal address syntax from unknown[10.0.0.2] in RCPT command: user1@domain.com,mailto:user2@domain.com

and in iCal I get the following error:

The server responded with "HTTP/1.1 502 Proxy Error" to operation CalDAVScheduleEventQueueableOperation.

Additional Information

When using sendmail instead of smtp sogo does not crash but still fails to delived the emails, because the same problem -
sogod Recipient: user1@domain.com,mailto:user2@domain.com

and

sendmail: to=user1@domain.commailto:user2@domain.com
sendmail: user1@domain.commailto:user2@domain.com... Invalid route address

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2009-07-23 13:35

viewer   ~0000042

The handling of the "Recipients" header was not foolproof with regards to the separator used to distinguish the elements. This is now fixed.

Issue History

Date Modified Username Field Change
2009-07-21 10:11 antt New Issue
2009-07-23 13:35 wsourdeau Note Added: 0000042
2009-07-23 13:35 wsourdeau Status new => resolved
2009-07-23 13:35 wsourdeau Resolution open => fixed
2009-07-23 13:35 wsourdeau Assigned To => wsourdeau
2009-07-23 15:26 wsourdeau Status resolved => confirmed
2009-07-23 15:26 wsourdeau Status confirmed => resolved
2009-07-23 15:26 wsourdeau Fixed in Version => 1.0.4