View Issue Details

IDProjectCategoryView StatusLast Update
0000684SOGoBackend Mailpublic2010-08-11 16:34
Reporteralessio Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.1Fixed in Version1.3.1 
Summary0000684: SOGo put strange character on e-mail
Description

When I send a mail from SOGo webmail sogo-1.2_20100709-1.el5, this is the source on mailserver

Return-Path: <federico@sogo.it>
Delivered-To: alessio@sogo..it
Received: (qmail 3805 invoked by alias); 10 Jun 2010 14:49:32 -0000
Delivered-To: alias-localdelivery-alessio@*.it
Received: (qmail 3802 invoked by uid 3000); 10 Jun 2010 14:49:32 -0000
to: =?utf-8?q?alessio=20fattorini?= <alessio@***.it>
from: =?utf-8?q?Federico=20Simoncelli?= <federico@sogo.it>
message-id: <ed4-4c10fb80-1-45880700@86702820>^M
subject: Test^M
date: Thu, 10 Jun 2010 16:49:32 +0200^M
MIME-Version: 1.0^M
content-type: text/plain; charset="utf-8"^M
reply-to: =?utf-8?q?Federico=20
?= <federico@sogo.it>
User-Agent: SOGoMail 1.2.2^M
content-transfer-encoding: 7bit^M

^M
Teststs^M
ahhaha^M
ajajajajjajaa^M
ajjajajajajajajajajajajaja


Why SOGo puts ^M at the end of some lines?

Many clients have problem to visualize mail like this, Outlook for example (see attach)

TagsNo tags attached.

Activities

2010-07-09 12:02

 

mail01.jpg (144,564 bytes)   
mail01.jpg (144,564 bytes)   
ludovic

ludovic

2010-07-12 16:49

administrator   ~0001176

Might be due to this:

http://mtn.inverse.ca/revision/diff/0ba5dc28795d933db244f667ecc927420db2ab60/with/44974f9cbdca49b2868f64f007241c5a79656662

ludovic

ludovic

2010-07-13 12:41

administrator   ~0001181

I simply cannot reproduce that issue.

Just to make sure, you're using "smtp" as the SOGoMailingMechanism?

Also, would there be a way for you to send me the exact copy of the mail, not a copy/paste.

2010-07-14 10:46

 

mail_SOGo_CRLF (695 bytes)   
Return-Path: <giacomo@nethesis.it>
Delivered-To: filippo@nethservice.nethesis.it
Received: (qmail 25858 invoked by alias); 6 Jul 2010 10:04:36 -0000
Delivered-To: alias-localdelivery-filippo@nethesis.it
Received: (qmail 25846 invoked by uid 5082); 6 Jul 2010 10:04:35 -0000
to: =?utf-8?q?Filippo=20Carletti?= <filippo@nethesis.it>
from: =?utf-8?q?Giacomo=20Sanchietti?= <giacomo@nethesis.it>
message-id: <39c5-4c32ff80-19-128922e0@65165721>
subject: test
date: Tue, 06 Jul 2010 12:04:35 +0200
MIME-Version: 1.0
content-type: text/plain; charset="utf-8"
reply-to: =?utf-8?q?Giacomo=20Sanchietti?= <giacomo@nethesis.it>
User-Agent: SOGoMail 1.0
content-transfer-encoding: 7bit


test mail
mail_SOGo_CRLF (695 bytes)   
filippocarletti

filippocarletti

2010-07-14 10:48

reporter   ~0001184

We're using sendmail as SOGoMailingMechanism because, last time we checked, smtp was not RFC conforming (email addresses MUST be in angle brackets):
http://tools.ietf.org/html/rfc2821#section-3.3

I've attached a test email showing the problem.

filippocarletti

filippocarletti

2010-07-14 10:51

reporter   ~0001185

I've seen issue 0000559, do you prefer that we use smtp instead of sendmail?

ludovic

ludovic

2010-07-14 10:52

administrator   ~0001186

Try SMTP, because the link I pasted earlier ONLY affects the SMTP code.

alessio

alessio

2010-07-23 09:51

reporter   ~0001223

Testing on sogo 1.2.2 nightly in smtp mode, it works.
Qpsmtpd doesn't reject e-mail anymore and strange chars disappear.

Return-Path: <alessio@.it>
Delivered-To: federico@
.it
Received: (qmail 3967 invoked by alias); 9 Jul 2010 16:18:23 -0000
Delivered-To: alias-localdelivery-federico@*.it
Received: (qmail 3964 invoked by uid 453); 9 Jul 2010 16:18:23 -0000
X-Virus-Checked: Checked by ClamAV on nethesis.it
Received: from localhost (HELO localhost) (127.0.0.1)
by nethesis.it (qpsmtpd/0.83) with ESMTP; Fri, 09 Jul 2010 18:18:23 +0200
to: <federico@.it>
from: =?utf-8?q?alessio=20
?= <alessio@.it>
message-id: <f62-4c374c00-b-67a8a700@226065669>
subject: tetslshlos
date: Fri, 09 Jul 2010 18:18:23 +0200
MIME-Version: 1.0
content-type: text/plain; charset="utf-8"
reply-to: =?utf-8?q?alessio=20
?= <alessio@***
.it>
User-Agent: SOGoMail 1.2.2
content-length: 55
content-transfer-encoding: 7bit

tetststsvsla
abhahaa

ahioahipa
tes
ateststststs

ludovic

ludovic

2010-08-11 16:34

administrator   ~0001296

Fixed in ca.inverse.sope.

http://mtn.inverse.ca/revision/diff/533a8567bdff250c185e8f60cb31bfe5da83612a/with/348e50b9d8d1562398b61e02f9e2764c6e11ab0c

Issue History

Date Modified Username Field Change
2010-07-09 12:02 alessio New Issue
2010-07-09 12:02 alessio File Added: mail01.jpg
2010-07-12 16:46 ludovic Status new => assigned
2010-07-12 16:46 ludovic Assigned To => ludovic
2010-07-12 16:46 ludovic Target Version => 1.3.0
2010-07-12 16:49 ludovic Note Added: 0001176
2010-07-13 12:41 ludovic Note Added: 0001181
2010-07-14 10:46 filippocarletti File Added: mail_SOGo_CRLF
2010-07-14 10:48 filippocarletti Note Added: 0001184
2010-07-14 10:51 filippocarletti Note Added: 0001185
2010-07-14 10:52 ludovic Note Added: 0001186
2010-07-20 10:25 ludovic Target Version 1.3.0 => 1.3.1
2010-07-23 09:51 alessio Note Added: 0001223
2010-08-11 16:34 ludovic Note Added: 0001296
2010-08-11 16:34 ludovic Status assigned => resolved
2010-08-11 16:34 ludovic Fixed in Version => 1.3.1
2010-08-11 16:34 ludovic Resolution open => fixed