View Issue Details

IDProjectCategoryView StatusLast Update
0000594SOGoWeb Address Bookpublic2010-06-16 16:32
ReporterJason Oster Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.2.2 
Summary0000594: "New Card" in shared LDAP address book -> Proxy Error
Description

I have my LDAP server setup for authentication and as an address book, as documented in the configuration guide.

In the web interface, a user can right click on the "Global Address Book" (LDAP) and select "New Card". A pop up window opens with the following error:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /SOGo/so/jason.oster/Contacts/public//5924-4BD8A700-1-39142B00.vcf/editAsContact.

Reason: Error reading from remote server

Additional Information

Selecting "New List" in the same context menu presents a slightly better error message in a JavaScript alert() -- "New Card" should do this, or else disable both options in the context menu for LDAP address books.

TagsNo tags attached.

Activities

Jason Oster

Jason Oster

2010-04-28 18:23

reporter   ~0000985

Here is a patch which uses an alert, like the "new list" feature.

2010-04-28 18:23

 

SOGo-public_address_book_add_contact.patch (10,465 bytes)   
--- UI/Common/BrazilianPortuguese.lproj/Localizable.strings	b6d6a53d78421a85f8d70265d832e7a4102e4b40
+++ UI/Common/BrazilianPortuguese.lproj/Localizable.strings	8bc7dafa3c884d77b09d0310666de12b76080722
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Você não está liberado para acessar este módulo ou este sistema. Por favor, contate seu administrador de sistemas.";
============================================================
--- UI/Common/Czech.lproj/Localizable.strings	85fb96fe08e0469be7b30c9b863da64afcd41198
+++ UI/Common/Czech.lproj/Localizable.strings	6d59f943013442cd9c1b67b880ee92db232e4b84
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Nemáte oprávnění pro přístup k tomuto modulu nebo systému. Kontaktujte prosím svého systémového administrátora.";
============================================================
--- UI/Common/Dutch.lproj/Localizable.strings	900b2e160771de9059332ec66f991386ef17519c
+++ UI/Common/Dutch.lproj/Localizable.strings	5b864d4fab9cdf78d87ac9df560aba8bfea6798b
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "U hebt geen toegang tot deze module of dit systeem. Neem contact op met uw systeem beheerder.";
============================================================
--- UI/Common/English.lproj/Localizable.strings	cdfe95dc8ffa78f58929e060fdb978a3cbd57627
+++ UI/Common/English.lproj/Localizable.strings	4d320ddcde0b1e450b0bdb91416124b12f2d456d
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "You are not allowed to access this module or this system. Please contact your system administrator.";
============================================================
--- UI/Common/French.lproj/Localizable.strings	517e532f00fffe4e6d6ba445ef0c4c726339179e
+++ UI/Common/French.lproj/Localizable.strings	ade42979e36bf12533ce155ef882ae5878b61920
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "Un dossier du même nom existe déjà.";
 "You cannot create a list in a shared address book." 
         = "Impossible de créer une liste dans un dossier partagé.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Vous n'êtes pas autorisé à accéder à ce module ou ce système. Veuillez contacter votre administrateur système.";
============================================================
--- UI/Common/German.lproj/Localizable.strings	c61bdb3950f0db7e546cf2a46f38bbdb54edb0a7
+++ UI/Common/German.lproj/Localizable.strings	eeb21f8b73df59e2e4d86a61118d5fa2d87381b2
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "Ein Ordner mit diesem Namen existiert bereits.";
 "You cannot create a list in a shared address book." 
         = "Es ist nicht möglich, eine Liste in einem gemeinsamen Adressbuch zu erstellen.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Sie sind nicht berechtigt auf dieses Modul oder System zuzugreifen. Bitte kontaktieren Sie ihren Systemadministrator.";
============================================================
--- UI/Common/Hungarian.lproj/Localizable.strings	610fb55a866b790900d98283271bbb1173eff537
+++ UI/Common/Hungarian.lproj/Localizable.strings	6a9c77bb1ffb86ff9177e3b7f725216f6c57bdd9
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Önnek nem engedélyezett a hozzáférés ehhez a modulhoz vagy rendszerhez. Kérem lépjen kapcsolatba a rendszergazdával.";
============================================================
--- UI/Common/Italian.lproj/Localizable.strings	63f7c832770616670efa78a2a6c2b4b4130736f3
+++ UI/Common/Italian.lproj/Localizable.strings	126e27d5fbd39c9018b6aeb8f6232207b61f4580
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Non sei abilitato ad accedere a questo modulo. Contatta il tuo amministratore di sistema.";
============================================================
--- UI/Common/Russian.lproj/Localizable.strings	6fbb57865149f24193eea9952c1b204678ebb2e7
+++ UI/Common/Russian.lproj/Localizable.strings	659da1210c5967f7f62b593c6fc32f8c985aea08
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Вам не предоставлено право доступа к этому модулю/системе. Пожалуйста, свяжитесь с администратором.";
============================================================
--- UI/Common/Spanish.lproj/Localizable.strings	9fe9e893cc3963205d903b963882c844daa14dd1
+++ UI/Common/Spanish.lproj/Localizable.strings	5b909abd5e65dc1460d5e4522b8f72067ad260d8
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "You are not allowed to access this module or this system. Please contact your system administrator.";
============================================================
--- UI/Common/Swedish.lproj/Localizable.strings	7005ad7b96bb08d2c489b2eeaeabada2bd5368ed
+++ UI/Common/Swedish.lproj/Localizable.strings	51c79a899f1fd43b6f49192379916445849b3af5
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "En mapp med det namnet finns redan.";
 "You cannot create a list in a shared address book." 
         = "Du kan inte skapa en lista i en delad adressbok.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Du har inte åtkomsträttighet till modulen eller systemet. Kontakta din systemadministratör.";
============================================================
--- UI/Common/Welsh.lproj/Localizable.strings	32372255b43221d7d1987f0fc9ba7de43c127eed
+++ UI/Common/Welsh.lproj/Localizable.strings	abc6dbed63e217cb6cd175fcb5f3b24d6d5876b6
@@ -50,6 +50,8 @@
 "A folder by that name already exists." = "A folder by that name already exists.";
 "You cannot create a list in a shared address book." 
         = "You cannot create a list in a shared address book.";
+"You cannot create a contact in a shared address book." 
+        = "You cannot create a contact in a shared address book.";
 
 "You are not allowed to access this module or this system. Please contact your system administrator."
 = "Nid oes gennych caniatad mynediad i'r modiwl hwn na'r system hwn. Cysylltwch a'r Gweinyddwr Systemau os gwelwch yn dda.";
============================================================
--- UI/WebServerResources/ContactsUI.js	f33090bc0bb6db51fcc94b95da6d67a3f67e9fec
+++ UI/WebServerResources/ContactsUI.js	86ea9e5bf22f3747edbed0e5e5f237923d7010e5
@@ -518,7 +521,11 @@ function newContact(sender) {
 }
 
 function newContact(sender) {
-    openContactWindow(URLForFolderID(Contact.currentAddressBook) + "/newcontact");
+    var li = $(Contact.currentAddressBook);
+    if (li.hasClassName("remote"))
+        alert(getLabel("You cannot create a contact in a shared address book."));
+    else
+        openContactWindow(URLForFolderID(Contact.currentAddressBook) + "/newcontact");
 
     return false; /* stop following the link */
 }
francis

francis

2010-05-04 15:25

administrator   ~0000993

Fixed in revision 3076c5f627f3ef8a7b54cfac5834981257fcdc05.

Jason Oster

Jason Oster

2010-05-05 17:49

reporter   ~0000995

I'd like to reopen this issue, because the behavior hasn't changed in last night's nightly build.

Jason Oster

Jason Oster

2010-05-05 17:54

reporter   ~0000996

Correction: The error message has changed, but that would be the problem; there is still an error.

For reference the new error message in the popup window is:

An error occurred during object publishing

the requested object could not be found!

Is there something wrong with duplicating the alert used by the other button (New List)? Or making both buttons unclickable, that seems even more user-friendly than an alert. Either way, user experience is bad when a new useless window is opened.

francis

francis

2010-06-16 16:32

administrator   ~0001113

There's no more obscure error message (and popup window) from SOPE, but there's still an alert.

Disabling buttons from the toolbar will be done eventually but is not yet planed.

Issue History

Date Modified Username Field Change
2010-04-28 17:23 Jason Oster New Issue
2010-04-28 18:23 Jason Oster Note Added: 0000985
2010-04-28 18:23 Jason Oster File Added: SOGo-public_address_book_add_contact.patch
2010-05-04 15:25 francis Note Added: 0000993
2010-05-04 15:25 francis Status new => resolved
2010-05-04 15:25 francis Fixed in Version => 1.2.2
2010-05-04 15:25 francis Resolution open => fixed
2010-05-04 15:25 francis Assigned To => francis
2010-05-05 17:49 Jason Oster Note Added: 0000995
2010-05-05 17:49 Jason Oster Status resolved => feedback
2010-05-05 17:49 Jason Oster Resolution fixed => reopened
2010-05-05 17:54 Jason Oster Note Added: 0000996
2010-06-16 16:32 francis Note Added: 0001113
2010-06-16 16:32 francis Status feedback => resolved
2010-06-16 16:32 francis Resolution reopened => fixed