View Issue Details

IDProjectCategoryView StatusLast Update
0005303SOGoWeb Mailpublic2021-05-18 13:37
ReporterChristian Mack Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.1.0 
Fixed in Version5.1.1 
Summary0005303: email folders with questionmark "?" in name are unusable
Description

Questionmarks are valid characters in IMAP folder names.
When creating such a folder with SOGo 5.1.0 release, it will create it without problem.
You also can copy and move emails into that folder.
But when you try to open such a folder, SOGo will give you an 'Request failed' error on the right upper side, and not list any emails within that folder.

Steps To Reproduce
  1. login as userA to SOGo webinterface
  2. open Mail view
    3a. either select account and press three dots --> "New Folder..."
    3b. or select a folder and press three dots --> "New Subfolder..."
  3. type some name containing a questionmark, e.g. "folder with questionmark?"
  4. click on "OK"
    => folder will be created
  5. open another folder e.g. Inbox
  6. select an email in the list of emails by clicking on the icon in front of it
  7. click on the three dots above the list of emails --> "Move To" --> account name --> "folder with questionmark?"
    => email will be moved to that folder
  8. try to open folder "folder with questionmark?"
    => you get the above error, and nothing is displayed as content of that folder
  9. use another email client and check that postbox of userA
    => you can see "folder with questionmark?" and the email within it properly, and without any errors.
Additional Information

SOGo 5.1.0 release
Dovecot 2.3.14 (with mdbox storage)

When you try to create such a folder on the SOGo demo site, it will give you the following error box:
'An error occured while creating the mailbox "folder with questionmark?"
OK'

And you will get an error on right upper side with:
'The folder with name "folder with questionmark?" could not be created.'

But this will not prevent other email clients to create such a folder!

Tagsemail

Activities

francis

francis

2021-05-14 14:38

administrator   ~0015263

The limit is imposed by your IMAP server, not SOGo. I don't know for your dovecot instance, but for our demo site, the problem is that we use an older version of Cyrus imapd and the question mark wasn't yet supported.

Christian Mack

Christian Mack

2021-05-17 03:11

developer   ~0015267

Seems I wasn't clear enough.
Our IMAP server dovecot 2.3 has no problems with question marks in folder names.
With other email clients (Thunderbird, Outlook and Apple Mail) I can use them without problems.

I can create those folders with questionmark and move/copy emails into it with SOGo.
The only thing not working is accessing that folder and list its content, which in turn prevents me from accessing those emails moved or copied into it.

Related Changesets

sogo: master 657f00f9

2021-05-18 13:34:46

francis

Details Diff
fix(mail): handle folders that end with a question mark

We now avoid using NSURL.

Fixes 0005303
Affected Issues
0005303
mod - SoObjects/Mailer/SOGoMailFolder.m Diff File
mod - UI/MailerUI/UIxMailFolderActions.m Diff File
mod - UI/WebServerResources/js/Mailer/sgMailboxListItem.directive.js Diff File

Issue History

Date Modified Username Field Change
2021-04-20 04:48 Christian Mack New Issue
2021-04-20 04:48 Christian Mack Tag Attached: email
2021-05-14 14:38 francis Note Added: 0015263
2021-05-17 03:11 Christian Mack Note Added: 0015267
2021-05-18 13:36 francis Changeset attached => sogo master 657f00f9
2021-05-18 13:36 francis Assigned To => francis
2021-05-18 13:36 francis Resolution open => fixed
2021-05-18 13:37 francis Status new => resolved
2021-05-18 13:37 francis Fixed in Version => 5.1.1