View Issue Details

IDProjectCategoryView StatusLast Update
0000493SOGoWeb Preferencespublic2010-04-06 11:42
Reporterwimmer Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.2.2Fixed in Version1.2.2 
Summary0000493: Sieve filtering
Description

I found strange behavior in SOGo Sieve filtering.
case 1)

  • I start with no filtering rule, no sogo.sieve file on mail server

  • I create new rule:
    -> "Subject"-"contains"-"buy"
    -> "File the message in:"-"shop"
    -> set "Active"
    -> "Save and Close"
    ==> sogo.sieve file on mail sever is created and it includes correct sieve rules:
    require ["fileinto"];
    if anyof (header :contains "subject" "buy") {
    fileinto "shop";
    }

  • then I go again into SOGo filtering page
    -> I disable "Active" flag
    -> "Save and Close"

    • I see some activity in the dovecot managesieve log on mail server
      ==> but no change in sogo.sieve file
  • then I try to do some change in my rule (or delete it completly),
    I see it on SOGo page, I see activity in the managesieve log
    ==> but no changes in sogo.sieve file

case 2)

  • I start with no filtering rule, no sogo.sieve file on mail server
  • I create new rule:
    -> "match all messages"-"Forward the message to:"-"my@address.com"
    -> set "Active"
    -> "Save and Close"
    ==> but Preferences window stay open, no activity in managesieve log, no sogo.sieve is created

I tried to reproduce it on http://sogo-demo.inverse.ca/ but sieve filtering doesn't work in any way there.

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2010-04-02 16:20

viewer   ~0000863

Fixed in 1d50284cefca6f8926df742321e4f938e6a5b91f.
The problem was due to the fact that Dovecat rightfully denied the deletion of the active script, which is required when the filters are all disabled. Please test the next nightlies.

wimmer

wimmer

2010-04-05 14:45

reporter   ~0000866

case 1) works nice now.
case 2) doesn't work yet.

So:

  • I start with no filtering rule
  • I create new rule "forwarding":
    -> "match all messages"-"Forward the message to:"-"my@address.com"
    -> "Save and Close"
    -> double click on this rule again (for re-open) - and there is no content in the window
    -> so I cannot close Preferences window by "Save and Close" anyway and sieve rule is not created on the server side
wsourdeau

wsourdeau

2010-04-06 11:42

viewer   ~0000874

Fixed in 550399a545ec39b76756d03253cfce780c28915b. A few conditions were not taken into account in the "allmessages" mode.

Issue History

Date Modified Username Field Change
2010-03-16 06:36 wimmer New Issue
2010-03-19 14:00 ludovic Target Version => 1.2.2
2010-04-02 16:20 wsourdeau Note Added: 0000863
2010-04-02 16:20 wsourdeau Status new => resolved
2010-04-02 16:20 wsourdeau Fixed in Version => 1.2.2
2010-04-02 16:20 wsourdeau Resolution open => fixed
2010-04-02 16:20 wsourdeau Assigned To => wsourdeau
2010-04-05 14:45 wimmer Note Added: 0000866
2010-04-05 14:45 wimmer Status resolved => feedback
2010-04-05 14:45 wimmer Resolution fixed => reopened
2010-04-06 11:42 wsourdeau Note Added: 0000874
2010-04-06 11:42 wsourdeau Status feedback => resolved
2010-04-06 11:42 wsourdeau Resolution reopened => fixed