View Issue Details

IDProjectCategoryView StatusLast Update
0004806SOGoActiveSyncpublic2019-09-13 10:46
Reporteri1 Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSubuntu OS Version18.04
Product Version4.0.8 
Fixed in Version4.1.0 
Summary0004806: Reciveving mails on IPhoneX results in error
Description

While using IPhone X to receive specific email, IPhone client
reports "Error receiving mail. Error connecting server" (it is
message translated from russian)
And all new mails after that cannot be received due to error.

Exact sogo version: 4.0.8.20190905-1

Steps To Reproduce

Put attached file into dovecot's user's Maildir/cur folder
and try to receive mail from IPhone X client

Additional Information

Log messages while receiving that email:
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR(-[NGImap4ResponseParser _parseData]): got content size '0'!
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR(-[NGImap4ResponseParser _parseBodyContent]): got no data.
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR: got no body content for key: 'body[1]'
Sep 06 16:06:18 sogod [25501]: [ERROR] <0x55dce45f2f90[SOGoMailObject]:17383> got no data for key: body[1]
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR(-[NGImap4ResponseParser _parseData]): got content size '0'!
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR(-[NGImap4ResponseParser _parseBodyContent]): got no data.
Sep 06 16:06:18 sogod [25501]: <0x0x55dce3fbb2a0[NGImap4ResponseParser]> ERROR: got no body content for key: 'body[1]'
Sep 06 16:06:18 sogod [25501]: [ERROR] <0x55dce45f2f90[SOGoMailObject]:17383> got no data for key: body[1]
2019-09-06 16:06:18.638 sogod[25501:25501] EXCEPTION: <NSException: 0x55dce43a24d0> NAME:NSRangeException REASON:in substringWithRange:, range { 0, 18446744073709551615
} extends beyond size (4096) INFO:(null)

TagsNo tags attached.

Activities

i1

i1

2019-09-06 10:18

reporter  

i1

i1

2019-09-06 10:21

reporter  

iphone-error.jpeg (45,662 bytes)   
iphone-error.jpeg (45,662 bytes)   
Christian Mack

Christian Mack

2019-09-09 04:13

developer   ~0013735

Just as info:
This email has
Content-Type: multipart/alternative;
boundary="===============3511391524473416982=="

with 3 parts!!!!
1) Completely empty without MIME type even! This is probably the cause of the error.

2) Normal Text part:
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable

3) Normal HTML part:
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: quoted-printable

ludovic

ludovic

2019-09-13 10:46

administrator   ~0013741

Fix applied - https://github.com/inverse-inc/sope/commit/f567f984bf1c9f2cad86a3f66667f5ad8b796760

Related Changesets

sogo: master 662ee865

2019-09-13 09:52:04

ludovic

Details Diff
(fix) avoid incorrect truncation leading to exception (fixes 0004806) Affected Issues
0004806
mod - ActiveSync/SOGoMailObject+ActiveSync.m Diff File
mod - NEWS Diff File

Issue History

Date Modified Username Field Change
2019-09-06 10:18 i1 New Issue
2019-09-06 10:18 i1 File Added: 1567670414.M98909P20768.mx,S=46224,W=47031:2,S
2019-09-06 10:21 i1 File Added: iphone-error.jpeg
2019-09-09 04:13 Christian Mack Note Added: 0013735
2019-09-13 09:55 ludovic Changeset attached => sogo master 662ee865
2019-09-13 09:55 ludovic Assigned To => ludovic
2019-09-13 09:55 ludovic Resolution open => fixed
2019-09-13 10:46 ludovic Note Added: 0013741
2019-09-13 10:46 ludovic Status new => resolved
2019-09-13 10:46 ludovic Fixed in Version => 4.1.0