View Issue Details

IDProjectCategoryView StatusLast Update
0000454SOGoWeb Calendarpublic2010-03-09 12:10
Reporterchrisl Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.1 
Target Version1.2.2Fixed in Version1.2.2 
Summary0000454: Events added in web client calendar appear one hour earlier in Lightning for timezone Australia/Melbourne
Description

and events added in Lightning appear one hour earlier in web client calendar.

My timezone is set to Australia/Melbourne on the server, in the sogo .GNUStepDefaults, on the client machine, and in Thunderbird.

TagsNo tags attached.

Activities

2010-02-23 08:02

 

lightning_out_by_1_hour.jpg (116,571 bytes)   
lightning_out_by_1_hour.jpg (116,571 bytes)   

2010-02-23 08:03

 

web_client_out_by_1_hour.jpg (111,298 bytes)   
web_client_out_by_1_hour.jpg (111,298 bytes)   
chrisl

chrisl

2010-02-23 08:05

reporter   ~0000617

I reported this problem in a previous version (maybe 0.98???) to Wolfgang and it was fixed but now seems to have crept back in.

ludovic

ludovic

2010-02-23 09:00

administrator   ~0000618

If you open the event in the Web interface, is the date/time correct in the start/end fields?

chrisl

chrisl

2010-02-23 10:11

reporter   ~0000628

No. Its incorrect both in the start/end fields and the calendar "grid".
You can see it in this screenshot: http://www.scalableogo.org/bugs/file_download.php?file_id=85&type=bug

The "11 am - thunderbird" event starts at 11am in Lightning but in the web client it starts at 12.

revans

revans

2010-03-08 15:41

reporter   ~0000686

We are having the same issue (CST time zone) Web view and desktop view (thunderbird) are one hour off, either an hour off in webview or 1 hour off in desktop view.
running

sogo-1.2_20100220-1.el5
all plugins .99 version
centos 5.4 x86_64

wsourdeau

wsourdeau

2010-03-09 12:10

viewer   ~0000699

We were basing the computing of tz period on the wrong assumpation that dst and standard time were occurring in the same order in the northern and southern hemisphere.

Chris: this should be fixed for you.
Ryan: which timezone exactly are you using, because I did not manage to recreate your problem. If it still occurs, please reopen this bug....

Thanks

Issue History

Date Modified Username Field Change
2010-02-23 08:02 chrisl New Issue
2010-02-23 08:02 chrisl File Added: lightning_out_by_1_hour.jpg
2010-02-23 08:03 chrisl File Added: web_client_out_by_1_hour.jpg
2010-02-23 08:05 chrisl Note Added: 0000617
2010-02-23 09:00 ludovic Note Added: 0000618
2010-02-23 09:10 ludovic Target Version => 1.2.2
2010-02-23 10:11 chrisl Note Added: 0000628
2010-03-08 15:41 revans Note Added: 0000686
2010-03-09 12:10 wsourdeau Note Added: 0000699
2010-03-09 12:10 wsourdeau Status new => resolved
2010-03-09 12:10 wsourdeau Fixed in Version => 1.2.2
2010-03-09 12:10 wsourdeau Resolution open => fixed
2010-03-09 12:10 wsourdeau Assigned To => wsourdeau