View Issue Details

IDProjectCategoryView StatusLast Update
0004502SOGoWeb Generalpublic2018-11-23 14:21
Reporternuwohg Assigned Tofrancis  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version4.0.0 
Fixed in Version4.0.5 
Summary0004502: Calendar and addressbook export
Description

When trying to export an calenar or addressbook I get this error message: "the called object returned no result" and nothing is exported.
SOGo version is: sogo_4.0.0.20180703-1_amd64.deb

TagsNo tags attached.

Activities

francis

francis

2018-07-09 14:00

administrator   ~0012943

Any error in your sogo logs?

nuwohg

nuwohg

2018-07-10 03:01

reporter   ~0012945

Yes:

Exporting personal addressbook:

sogo.log
########
Jul 10 08:51:21 sogod [1513]: 87.140.100.188 "GET /SOGo/so/p.stirnberg@ruhrmail.de/Contacts/personal/export HTTP/1.0" 500 36/0 0.007 - - 0

nginx access.log
################
87.140.100.188 - - [10/Jul/2018:08:55:02 +0200] "GET /SOGo/so/p.stirnberg@ruhrmail.de/Contacts/personal/export HTTP/1.1" 500 36 "https://ruhrmail.email/SOGo/so/p.stirnberg@ruhrmail.de/Contacts/view" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/66.0.3359.181 Chrome/66.0.3359.181 Safari/537.36"

nginx error.log
###############
empty

ASolana

ASolana

2018-09-04 06:23

reporter   ~0013013

This issue still appears on SOGo 4.0.1:

  • sogo.log
    Sep 04 12:10:23 sogod [50058]: 10.4.198.78 "GET /SOGo/so/usuari.ana/Contacts/personal/export HTTP/1.1" 500 36/0 0.072 - - 0
nuwohg

nuwohg

2018-09-04 06:38

reporter   ~0013014

This issue still appears on SOGo 4.0.2

francis

francis

2018-09-05 10:39

administrator   ~0013015

No exception? Can one of you try to debug [UIxContactFolderActions exportAction]?

nuwohg

nuwohg

2018-09-11 05:18

reporter   ~0013018

Sorry, I'm no developer and don't know how to do this. Setting SOGoUIxDebugEnabled to YES does not have any effect in sogo.log.

francis

francis

2018-09-12 09:22

administrator   ~0013021

If you feel adventurous:

https://sogo.nu/support/faq/how-do-i-debug-sogo.html

nuwohg

nuwohg

2018-09-12 09:25

reporter   ~0013022

Well, I tried that and got errors which I couldn't resolve so I didn't got this dbg thing working, sorry.

ASolana

ASolana

2018-09-18 08:22

reporter   ~0013038

  • I've tried to follow the debug procedure too, but I haven't got any relevant information, perhaps I did something wrong.

My SOGo 4.0.2 server uses a MySQL DB.

  • A log example trying to export a calendar, executing sogo with more debug activated:

Sep 18 14:01:12 sogod [35737]: |SOGo| starting method 'GET' on uri '/SOGo/so/usuari.ana/Calendar/personal.ics/export'
Sep 18 14:01:12 sogod [35737]: |SOGo| traverse(acquire): usuari.ana => Calendar => personal.ics => export
Sep 18 14:01:12 sogod [35737]: |SOGo| do traverse name: 'usuari.ana'
Sep 18 14:01:12 sogod [35737]: |SOGo| do traverse name: 'Calendar'
Sep 18 14:01:12 sogod [35737]: |SOGo| do traverse name: 'personal.ics'
2018-09-18 14:01:12.152 sogod[35737] <MySQL4Channel[0x0x55cd51407300] connection=0x0x55cd513af880> SQL: SELECT c_path4 FROM sogo_folder_info WHERE c_path2 = 'usuari.ana' AND c_folder_type = 'Appointment';
2018-09-18 14:01:12.152 sogod[35737] <MySQL4Channel[0x0x55cd51407300] connection=0x0x55cd513af880> query has results, entering fetch-mode.
2018-09-18 14:01:12.152 sogod[35737] <MySQL4Channel[0x0x55cd50e9d720] connection=0x0x55cd50e19450> SQL: SELECT c_foldername FROM sogo_folder_info WHERE c_path = '/Users/usuari.ana/Calendar/C4E2-5ACF3580-5-19960680';
2018-09-18 14:01:12.152 sogod[35737] <MySQL4Channel[0x0x55cd50e9d720] connection=0x0x55cd50e19450> query has results, entering fetch-mode.
2018-09-18 14:01:12.153 sogod[35737] <MySQL4Channel[0x0x55cd51407300] connection=0x0x55cd513af880> SQL: SELECT c_foldername FROM sogo_folder_info WHERE c_path = '/Users/usuari.ana/Calendar/8BDE-5A8EB800-7-374D1F80';
2018-09-18 14:01:12.153 sogod[35737] <MySQL4Channel[0x0x55cd51407300] connection=0x0x55cd513af880> query has results, entering fetch-mode.
2018-09-18 14:01:12.153 sogod[35737] <MySQL4Channel[0x0x55cd50e9d720] connection=0x0x55cd50e19450> SQL: SELECT c_foldername FROM sogo_folder_info WHERE c_path = '/Users/usuari.ana/Calendar/8E4F-5A8EB780-2B-1CDE5CE0';
2018-09-18 14:01:12.154 sogod[35737] <MySQL4Channel[0x0x55cd50e9d720] connection=0x0x55cd50e19450> query has results, entering fetch-mode.
Sep 18 14:01:12 sogod [35737]: |SOGo| do traverse name: 'export'
Sep 18 14:01:12 sogod [35737]: |SOGo| set clientObject: <0x55cd515920b0[SOGoAppointmentFolderICS]: name=personal.ics container=0x55cd516fb8a0/Calendar>
Sep 18 14:01:12 sogod [35737]: |SOGo| request took 0.010611 seconds to execute
Sep 18 14:01:12 sogod [35737]: 10.4.x.x, 10.4.x.x "GET /SOGo/so/usuari.ana/Calendar/personal.ics/export HTTP/1.1" 500 36/0 0.012 - - 0

francis

francis

2018-09-18 08:25

administrator   ~0013039

Can one of you create a backup of a problematic account (using sogo-tool) and send it to me by email? Thanks.

gupal

gupal

2018-10-03 13:11

reporter   ~0013074

Having the same issue with 4.0.2.20181001 on Debian 9.
Does anybody know of a workaround for this issue?

nuwohg

nuwohg

2018-10-04 02:01

reporter   ~0013075

Please give me an e-mail address so that I can send you the file.

ASolana

ASolana

2018-10-05 09:36

reporter   ~0013079

The issue appears for all users.
I've uploaded usuari.ana backup (it's a test user).

ASolana

ASolana

2018-10-05 09:39

reporter  

usuari.ana.zip (632,213 bytes)
ASolana

ASolana

2018-10-05 09:39

reporter   ~0013080

The issue appears for all users.
I've uploaded usuari.ana.zip backup file (it's a test user).

gupal

gupal

2018-10-16 06:00

reporter   ~0013111

Finally I found a workaround and was able to export my data from SOGo.

  1. Access CardDAV and CalDAV with Thunderbird (Lightning & CardBook)
  2. Export data from Thunderbird

I did not use all available entry fields, but from what I can tell, it seems like all data was exported correctly, even had no problems with character-encoding during the import in a different CardDAV & CalDAV Server.

nuwohg

nuwohg

2018-10-16 06:23

reporter   ~0013112

This works also with Apple or Evolution, but it's unfortunately not what my users need. Export should work from webinterface for those who don't use any mail client.

ASolana

ASolana

2018-10-17 12:02

reporter   ~0013116

Messages folder exports fails in my server too (Ubuntu 16.04), same error message: "the called object returned no result"

sascha.kasch@sumcumo.com

sascha.kasch@sumcumo.com

2018-10-23 08:05

reporter   ~0013125

Also have that problem on 4.0.3 stable, any progress here? I have another installation on nightly that is not affected, but I am not able to find the source.

francis

francis

2018-10-23 09:15

administrator   ~0013128

I need a stack trace as I can't reproduce this problem.

nuwohg

nuwohg

2018-10-23 09:24

reporter   ~0013130

Same on sogo_4.0.3.20181023-1.

Unfortunately I don't know how to create a stack trace.

francis

francis

2018-10-23 09:45

administrator   ~0013131

https://sogo.nu/support/faq/how-do-i-debug-sogo.html

nuwohg

nuwohg

2018-10-23 10:13

reporter   ~0013132

As I mentioned before, this doesn't work for me and I have not enough skills to get this working.
I tried to guess the right PID and created a stack trace with this call -> gdb -p PID | tee trace.txt

I attach the 2 files which I created, maybe this helps.

nuwohg

nuwohg

2018-10-23 10:14

reporter  

trace1.txt (13,159 bytes)   
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
Attaching to process 7692
Reading symbols from /usr/sbin/sogod...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libSOGo.so.4...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libGDLContentStore.so.4.9...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libGDLAccess.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libGDLAccess.so.4.9.63...done.
done.
Reading symbols from /usr/lib/libWEExtensions.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libWEExtensions.so.4.9.94...done.
done.
Reading symbols from /usr/lib/sogo/libNGCards.so.4.9...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libNGObjWeb.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGObjWeb.so.4.9.37...done.
done.
Reading symbols from /usr/lib/libNGMime.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGMime.so.4.9.3...done.
done.
Reading symbols from /usr/lib/libNGLdap.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGLdap.so.4.9.35...done.
done.
Reading symbols from /usr/lib/libNGStreams.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGStreams.so.4.9.57...done.
done.
Reading symbols from /usr/lib/libNGExtensions.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGExtensions.so.4.9.203...done.
done.
Reading symbols from /usr/lib/libEOControl.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libEOControl.so.4.9.74...done.
done.
Reading symbols from /usr/lib/libDOM.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libDOM.so.4.9.24...done.
done.
Reading symbols from /usr/lib/libSaxObjC.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libSaxObjC.so.4.9.66...done.
done.
Reading symbols from /usr/lib/libgnustep-base.so.1.24...Reading symbols from /usr/lib/debug/.build-id/28/a3352325fbd75d0f008d4e23d6e31512a08469.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libobjc.so.4...Reading symbols from /usr/lib/debug/.build-id/0d/28a1e3f9f86b79b563b5c0b0f04ff8052cd91c.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libm.so.6...Reading symbols from /usr/lib/debug/.build-id/1b/95e3a8b8788b07e4f59ee69b1877f9deb42033.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libgcc_s.so.1...Reading symbols from /usr/lib/debug/.build-id/51/ad5fd294cd6c813bed40717347a53434b80b7a.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libpthread.so.0...Reading symbols from /usr/lib/debug/.build-id/42/85cd3158dde596765c747ae210ab6cbd258b22.debug...done.
done.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Reading symbols from /lib/x86_64-linux-gnu/libc.so.6...Reading symbols from /usr/lib/debug/.build-id/aa/889e26a70f98fa8d230d088f7cc5bf43573163.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libmemcached.so.11...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libSBJson.so.2...Reading symbols from /usr/lib/debug//usr/lib/libSBJson.so.2.3.1...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/liblasso.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libglib-2.0.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libcrypt.so.1...Reading symbols from /usr/lib/debug/.build-id/ec/4f346406f484627a18e73e3a4f6289f8db8ee3.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libdl.so.2...Reading symbols from /usr/lib/debug/.build-id/b8/95f0831f623c5f23603401d4069f9f94c24761.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/liblber-2.4.so.2...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libz.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssl.so.1.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgmp.so.10...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libavahi-common.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libavahi-client.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgnutls.so.30...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libxslt.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libxml2.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libffi.so.6...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/librt.so.1...Reading symbols from /usr/lib/debug/.build-id/5d/83e0642e645026dbb11f89f7df7106bd821495.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicui18n.so.57...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicuuc.so.57...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicudata.so.57...(no debugging symbols found)...done.
Reading symbols from /lib64/ld-linux-x86-64.so.2...Reading symbols from /usr/lib/debug/.build-id/26/3f909dbe11a66f7c6233e3ff0521148d9f8370.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libsasl2.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libstdc++.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libxmlsec1-openssl.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libxmlsec1.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libpcre.so.3...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libresolv.so.2...Reading symbols from /usr/lib/debug/.build-id/71/3d47d5f599289c0a91ade8f0122b2b4aa78b2e.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libdbus-1.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libp11-kit.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libidn.so.11...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libtasn1.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libnettle.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libhogweed.so.4...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/liblzma.so.5...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libsystemd.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libselinux.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/liblz4.so.1...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libgcrypt.so.20...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libgpg-error.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/gconv/UTF-16.so...Reading symbols from /usr/lib/debug/.build-id/1c/e97a750a50495e34696724855bf84445ea162f.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/gconv/UTF-32.so...Reading symbols from /usr/lib/debug/.build-id/a9/461873654d6e6049e85497ac8006929fa25b15.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_compat.so.2...Reading symbols from /usr/lib/debug/.build-id/00/361e92218af1bbdcb64b955f4a999cb222536e.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnsl.so.1...Reading symbols from /usr/lib/debug/.build-id/01/a6959e0f750358e48a3636f9d8cc30a7414ce6.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_nis.so.2...Reading symbols from /usr/lib/debug/.build-id/d5/4501d3e5ca71dc139bd1fe35b6569dc1855617.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_files.so.2...Reading symbols from /usr/lib/debug/.build-id/9d/8b83eeddf7cb86ff2022d501a98c310bd4c75b.debug...done.
done.
Reading symbols from /usr/lib/GNUstep/SOGo/Contacts.SOGo/./Contacts...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/Mailer.SOGo/./Mailer...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/Appointments.SOGo/./Appointments...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcurl.so.4...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libnghttp2.so.14...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libidn2.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/librtmp.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssh2.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libpsl.so.5...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libkrb5.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libk5crypto.so.3...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libcom_err.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libunistring.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libkrb5support.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libkeyutils.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MailPartViewers.SOGo/./MailPartViewers...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libSOGoUI.so.4.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/CommonUI.SOGo/./CommonUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MainUI.SOGo/./MainUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/ContactsUI.SOGo/./ContactsUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/ActiveSync.SOGo/./ActiveSync...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libwbxml2.so.1...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libexpat.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/SchedulerUI.SOGo/./SchedulerUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/AdministrationUI.SOGo/./AdministrationUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MailerUI.SOGo/./MailerUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SoProducts-4.9/SoCore.sxp/./SoCore...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/SoProducts-4.9/SoCore.sxp/./SoCore...done.
done.
Reading symbols from /usr/lib/GNUstep/SOGo/PreferencesUI.SOGo/./PreferencesUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/GDLAdaptors-4.9/MySQL.gdladaptor/./MySQL...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/GDLAdaptors-4.9/MySQL.gdladaptor/./MySQL...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libmariadbclient.so.18...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SaxDrivers-4.9/libxmlSAXDriver.sax/./libxmlSAXDriver...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/SaxDrivers-4.9/libxmlSAXDriver.sax/./libxmlSAXDriver...done.
done.
0x00007fa3ebb9f660 in __poll_nocancel () at ../sysdeps/unix/syscall-template.S:84
(gdb) quit
A debugging session is active.

	Inferior 1 [process 7692] will be detached.

Quit anyway? (y or n) y
Detaching from program: /usr/sbin/sogod, process 7692
trace1.txt (13,159 bytes)   
nuwohg

nuwohg

2018-10-23 10:15

reporter  

trace2.txt (14,159 bytes)   
GNU gdb (Debian 7.12-6) 7.12.0.20161007-git
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
Attaching to process 7693
Reading symbols from /usr/sbin/sogod...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libSOGo.so.4...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libGDLContentStore.so.4.9...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libGDLAccess.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libGDLAccess.so.4.9.63...done.
done.
Reading symbols from /usr/lib/libWEExtensions.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libWEExtensions.so.4.9.94...done.
done.
Reading symbols from /usr/lib/sogo/libNGCards.so.4.9...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libNGObjWeb.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGObjWeb.so.4.9.37...done.
done.
Reading symbols from /usr/lib/libNGMime.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGMime.so.4.9.3...done.
done.
Reading symbols from /usr/lib/libNGLdap.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGLdap.so.4.9.35...done.
done.
Reading symbols from /usr/lib/libNGStreams.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGStreams.so.4.9.57...done.
done.
Reading symbols from /usr/lib/libNGExtensions.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libNGExtensions.so.4.9.203...done.
done.
Reading symbols from /usr/lib/libEOControl.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libEOControl.so.4.9.74...done.
done.
Reading symbols from /usr/lib/libDOM.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libDOM.so.4.9.24...done.
done.
Reading symbols from /usr/lib/libSaxObjC.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libSaxObjC.so.4.9.66...done.
done.
Reading symbols from /usr/lib/libgnustep-base.so.1.24...Reading symbols from /usr/lib/debug/.build-id/28/a3352325fbd75d0f008d4e23d6e31512a08469.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libobjc.so.4...Reading symbols from /usr/lib/debug/.build-id/0d/28a1e3f9f86b79b563b5c0b0f04ff8052cd91c.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libm.so.6...Reading symbols from /usr/lib/debug/.build-id/1b/95e3a8b8788b07e4f59ee69b1877f9deb42033.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libgcc_s.so.1...Reading symbols from /usr/lib/debug/.build-id/51/ad5fd294cd6c813bed40717347a53434b80b7a.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libpthread.so.0...Reading symbols from /usr/lib/debug/.build-id/42/85cd3158dde596765c747ae210ab6cbd258b22.debug...done.
done.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Reading symbols from /lib/x86_64-linux-gnu/libc.so.6...Reading symbols from /usr/lib/debug/.build-id/aa/889e26a70f98fa8d230d088f7cc5bf43573163.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libmemcached.so.11...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libSBJson.so.2...Reading symbols from /usr/lib/debug//usr/lib/libSBJson.so.2.3.1...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/liblasso.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libglib-2.0.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libcrypt.so.1...Reading symbols from /usr/lib/debug/.build-id/ec/4f346406f484627a18e73e3a4f6289f8db8ee3.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libdl.so.2...Reading symbols from /usr/lib/debug/.build-id/b8/95f0831f623c5f23603401d4069f9f94c24761.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libldap_r-2.4.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/liblber-2.4.so.2...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libz.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssl.so.1.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgmp.so.10...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libavahi-common.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libavahi-client.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgnutls.so.30...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libxslt.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libxml2.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libffi.so.6...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/librt.so.1...Reading symbols from /usr/lib/debug/.build-id/5d/83e0642e645026dbb11f89f7df7106bd821495.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicui18n.so.57...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicuuc.so.57...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libicudata.so.57...(no debugging symbols found)...done.
Reading symbols from /lib64/ld-linux-x86-64.so.2...Reading symbols from /usr/lib/debug/.build-id/26/3f909dbe11a66f7c6233e3ff0521148d9f8370.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libsasl2.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libstdc++.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libxmlsec1-openssl.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libxmlsec1.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libpcre.so.3...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libresolv.so.2...Reading symbols from /usr/lib/debug/.build-id/71/3d47d5f599289c0a91ade8f0122b2b4aa78b2e.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libdbus-1.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libp11-kit.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libidn.so.11...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libtasn1.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libnettle.so.6...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libhogweed.so.4...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/liblzma.so.5...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libsystemd.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libselinux.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/liblz4.so.1...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libgcrypt.so.20...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libgpg-error.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/gconv/UTF-16.so...Reading symbols from /usr/lib/debug/.build-id/1c/e97a750a50495e34696724855bf84445ea162f.debug...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/gconv/UTF-32.so...Reading symbols from /usr/lib/debug/.build-id/a9/461873654d6e6049e85497ac8006929fa25b15.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_compat.so.2...Reading symbols from /usr/lib/debug/.build-id/00/361e92218af1bbdcb64b955f4a999cb222536e.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnsl.so.1...Reading symbols from /usr/lib/debug/.build-id/01/a6959e0f750358e48a3636f9d8cc30a7414ce6.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_nis.so.2...Reading symbols from /usr/lib/debug/.build-id/d5/4501d3e5ca71dc139bd1fe35b6569dc1855617.debug...done.
done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_files.so.2...Reading symbols from /usr/lib/debug/.build-id/9d/8b83eeddf7cb86ff2022d501a98c310bd4c75b.debug...done.
done.
Reading symbols from /usr/lib/GNUstep/SOGo/Contacts.SOGo/./Contacts...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/Mailer.SOGo/./Mailer...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/Appointments.SOGo/./Appointments...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libcurl.so.4...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libnghttp2.so.14...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libidn2.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/librtmp.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libssh2.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libpsl.so.5...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libkrb5.so.3...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libk5crypto.so.3...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libcom_err.so.2...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libunistring.so.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libkrb5support.so.0...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libkeyutils.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MailPartViewers.SOGo/./MailPartViewers...(no debugging symbols found)...done.
Reading symbols from /usr/lib/sogo/libSOGoUI.so.4.0...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/CommonUI.SOGo/./CommonUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MainUI.SOGo/./MainUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/ContactsUI.SOGo/./ContactsUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/ActiveSync.SOGo/./ActiveSync...(no debugging symbols found)...done.
Reading symbols from /usr/lib/libwbxml2.so.1...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libexpat.so.1...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/SchedulerUI.SOGo/./SchedulerUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/AdministrationUI.SOGo/./AdministrationUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SOGo/MailerUI.SOGo/./MailerUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/SoProducts-4.9/SoCore.sxp/./SoCore...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/SoProducts-4.9/SoCore.sxp/./SoCore...done.
done.
Reading symbols from /usr/lib/GNUstep/SOGo/PreferencesUI.SOGo/./PreferencesUI...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/GDLAdaptors-4.9/MySQL.gdladaptor/./MySQL...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/GDLAdaptors-4.9/MySQL.gdladaptor/./MySQL...done.
done.
Reading symbols from /usr/lib/x86_64-linux-gnu/libmariadbclient.so.18...(no debugging symbols found)...done.
Reading symbols from /lib/x86_64-linux-gnu/libnss_dns.so.2...Reading symbols from /usr/lib/debug/.build-id/48/c37c0eb2099ff3d698b9f6e006b7eb76994ad5.debug...done.
done.
Reading symbols from /usr/lib/GNUstep/SaxDrivers-4.9/libxmlSAXDriver.sax/./libxmlSAXDriver...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/SaxDrivers-4.9/libxmlSAXDriver.sax/./libxmlSAXDriver...done.
done.
Reading symbols from /usr/lib/GNUstep/SaxDrivers-4.9/versitCardsSaxDriver.sax/./versitCardsSaxDriver...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/WOxElemBuilders-4.9/WOExtensions.wox/./WOExtensions...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/WOxElemBuilders-4.9/WOExtensions.wox/./WOExtensions...done.
done.
Reading symbols from /usr/lib/libWOExtensions.so.4.9...Reading symbols from /usr/lib/debug//usr/lib/libWOExtensions.so.4.9.31...done.
done.
Reading symbols from /usr/lib/GNUstep/WOxElemBuilders-4.9/SOGoElements.wox/./SOGoElements...(no debugging symbols found)...done.
Reading symbols from /usr/lib/GNUstep/WOxElemBuilders-4.9/WEExtensions.wox/./WEExtensions...Reading symbols from /usr/lib/debug//usr/lib/GNUstep/WOxElemBuilders-4.9/WEExtensions.wox/./WEExtensions...done.
done.
0x00007fa3ebb9f660 in __poll_nocancel () at ../sysdeps/unix/syscall-template.S:84
(gdb) quit
A debugging session is active.

	Inferior 1 [process 7693] will be detached.

Quit anyway? (y or n) y
Detaching from program: /usr/sbin/sogod, process 7693
trace2.txt (14,159 bytes)   
francis

francis

2018-11-21 11:12

administrator   ~0013188

If someone can provide me root access to a test server that exposes the issue, I could produce a stacktrace and identify the problem.

Related Changesets

sogo: master 237ac4a3

2018-11-23 14:20:33

francis

Details Diff
Fix folder export when XSRF validation is enabled

Fixes 0004502
Affected Issues
0004502
mod - NEWS Diff File
mod - UI/Contacts/UIxContactFolderActions.m Diff File
mod - UI/SOGoUI/SOGoDirectAction.m Diff File
mod - UI/SOGoUI/UIxComponent.m Diff File
mod - UI/Scheduler/UIxCalFolderActions.m Diff File
mod - UI/WebServerResources/Gruntfile.js Diff File
mod - UI/WebServerResources/bower.json Diff File
mod - UI/WebServerResources/js/Common/Resource.service.js Diff File

Issue History

Date Modified Username Field Change
2018-07-03 13:48 nuwohg New Issue
2018-07-09 14:00 francis Note Added: 0012943
2018-07-10 03:01 nuwohg Note Added: 0012945
2018-09-04 06:23 ASolana Note Added: 0013013
2018-09-04 06:38 nuwohg Note Added: 0013014
2018-09-05 10:39 francis Note Added: 0013015
2018-09-11 05:18 nuwohg Note Added: 0013018
2018-09-12 09:22 francis Note Added: 0013021
2018-09-12 09:25 nuwohg Note Added: 0013022
2018-09-18 08:22 ASolana Note Added: 0013038
2018-09-18 08:25 francis Note Added: 0013039
2018-10-03 13:11 gupal Note Added: 0013074
2018-10-04 02:01 nuwohg Note Added: 0013075
2018-10-05 09:36 ASolana Note Added: 0013079
2018-10-05 09:39 ASolana File Added: usuari.ana.zip
2018-10-05 09:39 ASolana Note Added: 0013080
2018-10-16 06:00 gupal Note Added: 0013111
2018-10-16 06:23 nuwohg Note Added: 0013112
2018-10-17 12:02 ASolana Note Added: 0013116
2018-10-23 08:05 sascha.kasch@sumcumo.com Note Added: 0013125
2018-10-23 09:15 francis Note Added: 0013128
2018-10-23 09:24 nuwohg Note Added: 0013130
2018-10-23 09:45 francis Note Added: 0013131
2018-10-23 10:13 nuwohg Note Added: 0013132
2018-10-23 10:14 nuwohg File Added: trace1.txt
2018-10-23 10:15 nuwohg File Added: trace2.txt
2018-11-21 11:12 francis Note Added: 0013188
2018-11-23 14:21 francis Changeset attached => sogo master 237ac4a3
2018-11-23 14:21 francis Assigned To => francis
2018-11-23 14:21 francis Resolution open => fixed
2018-11-23 14:21 francis Status new => resolved
2018-11-23 14:21 francis Fixed in Version => 4.0.5