View Issue Details

IDProjectCategoryView StatusLast Update
0004378SOGoGUIpublic2018-01-31 10:04
ReporterPhilipp Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version16.04
Product Versionnightly master 
Fixed in Version4.0.0 
Summary0004378: Whole SOGo window closes on Reply/Forward md-dialog close
Description

Verrry strange thing happens. We have intranet with link to open SOGo webmail in new window, like this:

http://demo.sogo.nu

When I open SOGo via this link, new window appears, I do log in (if not already), then choose any mail and do replay or forward to raise md-dialog. Then closing the dialog results in whole window being closed (!!!).

Steps To Reproduce

Create HTML file with contents:

http://demo.sogo.nu

and open in in browser. Login with sogo1/sogo1, click any received mail and click reply or forward, then click close dialog. Bah! Window closes.

Additional Information

It seems that happens if <a> tag target attribute have any non-empty value. BUT when going to SOGo webmail directly by typing URL and in JS console setting window.name (which is populated by target=) does not produce undesired behaviour.

TagsNo tags attached.

Activities

Philipp

Philipp

2018-01-31 08:04

reporter   ~0012539

This bug seems not to be related to Angular, since opening Angular md-dialog demo via link with target=_blank does not close whole window on dialog close. Also, 'Write new message' md-dialog closing is not affected.

Philipp

Philipp

2018-01-31 08:13

reporter   ~0012540

In description HTML got parsed, click on [^] to reproduce bug.

Related Changesets

sogo: master e29ce4ac

2018-01-31 10:02:47

francis

Details Diff
(js) Improve popup detection in mail editor

Fixes 0004378
Affected Issues
0004378
mod - UI/WebServerResources/js/Mailer/MessageController.js Diff File

Issue History

Date Modified Username Field Change
2018-01-31 07:59 Philipp New Issue
2018-01-31 08:04 Philipp Note Added: 0012539
2018-01-31 08:13 Philipp Note Added: 0012540
2018-01-31 10:03 francis Changeset attached => sogo master e29ce4ac
2018-01-31 10:03 francis Assigned To => francis
2018-01-31 10:03 francis Resolution open => fixed
2018-01-31 10:04 francis Status new => resolved
2018-01-31 10:04 francis Fixed in Version => 4.0.0