View Issue Details

IDProjectCategoryView StatusLast Update
0004198SOGoBackend Mailpublic2017-07-04 10:19
ReporterChristian Mack Assigned Toludovic  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version2.3.21 
Fixed in Version2.3.22 
Summary0004198: send limit prevents sending of emails with attachment
Description

We have a lot of spammers trough hacked accounts via SOGo lately.
Therefore we activated the send limits for the SOGo frontend.
With these setting a user is only able to send to 100 recipients in 5 minutes, or will be blocked from sending for 15 minutes.

But after activation, every email with an attachment has triggered the blocking error message in the webinterface.
Therefore noone is able to send emails with attachments, even if it is the first email and only to one recipient!

We had to disable this restriction, in order to restore normal email sending behaviour.
Therefore these settings are unusable.

Steps To Reproduce

1) add the send limit to sogo.conf

SOGoMaximumMessageSubmissionCount = 0;
SOGoMaximumRecipientCount = 100;
SOGoMaximumSubmissionInterval = 300;
SOGoMessageSubmissionBlockInterval = 900;

2) restart sogod and memcached
3) Go to the webinterface and create an email with attachment
4) try to send this email
=> you get the blocking error message

TagsNo tags attached.

Activities

ludovic

ludovic

2017-06-16 08:27

administrator   ~0011953

I've just tested with the latest v2 release and I cannot reproduce the issue with the exact same settings you have.

Can you make sure it's not your SMTP server that is rejecting the mail?

Christian Mack

Christian Mack

2017-06-16 08:48

developer   ~0011955

I have checked my SMTP server, and he doesn't get any emails, while those blocks occur.
Which is what I expect SOGo to do , when the limits are reached.
Therefore, he can not reject them.

Also the problem vanished the moment I commented those settings out and restarted sogod.

As this only happens with attachments, we have also set
SOGoMailSpoolPath = "/var/sogotemp";
Attachments are stored there.
Could this cause it?

ludovic

ludovic

2017-06-16 09:37

administrator   ~0011957

Well, can SOGo write to that directory?

It's hard for me to figure out what could be wrong.

Do you have a test system on which you can reliably reproduce the issue?

We will look at it and fix it ASAP if so.

efuste

efuste

2017-06-16 10:53

reporter   ~0011960

We have the same problem with the SOGoMaximumMessageSizeLimit feature since it's introduction in the v2 seri (2.3.19)

As the users were used to have the popup with the MTA message before, we revert to the previous conf.

Hope it could help.

Christian Mack

Christian Mack

2017-06-16 13:29

developer   ~0011975

SOGo can write to this directory and it does.

ls -ld /var/sogotemp/

drwxr-xr-x 5466 sogo sogo 270336 Jun 16 19:20 /var/sogotemp/

Sadly I do not have a working V2 test setup right now.
Will get one working next week.

Christian Mack

Christian Mack

2017-06-27 10:39

developer   ~0012008

Sorry it took so long.

I have set up the Test system.
There the behavior is a tad different.
The first email can always be send.
But the second email will always trigger the block.

Will send you the access infos per private email.

Related Changesets

sogo: v2 722c8139

2017-07-04 09:57:05

ludovic

Details Diff
(fix) respect disabled state of sending rate-limiting (fixes 0004198) Affected Issues
0004198
mod - SoObjects/SOGo/SOGoSystemDefaults.m Diff File
mod - UI/MailerUI/UIxMailEditor.m Diff File

sogo: master 07fa2025

2017-07-04 09:57:05

ludovic

Details Diff
(fix) respect disabled state of sending rate-limiting (fixes 0004198) Affected Issues
0004198
mod - SoObjects/SOGo/SOGoSystemDefaults.m Diff File
mod - UI/MailerUI/UIxMailEditor.m Diff File

Issue History

Date Modified Username Field Change
2017-06-16 04:23 Christian Mack New Issue
2017-06-16 08:27 ludovic Note Added: 0011953
2017-06-16 08:27 ludovic Severity major => minor
2017-06-16 08:48 Christian Mack Note Added: 0011955
2017-06-16 09:37 ludovic Note Added: 0011957
2017-06-16 10:53 efuste Note Added: 0011960
2017-06-16 13:29 Christian Mack Note Added: 0011975
2017-06-27 10:39 Christian Mack Note Added: 0012008
2017-07-04 09:58 ludovic Changeset attached => sogo v2 722c8139
2017-07-04 09:58 ludovic Assigned To => ludovic
2017-07-04 09:58 ludovic Resolution open => fixed
2017-07-04 09:58 ludovic Changeset attached => sogo master 07fa2025
2017-07-04 10:19 ludovic Status new => resolved
2017-07-04 10:19 ludovic Fixed in Version => 2.3.22