View Issue Details

IDProjectCategoryView StatusLast Update
0000415SOGoWeb Mailpublic2010-02-15 17:54
Reporteraschild Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0 
Fixed in Version1.2.1 
Summary0000415: S/MIME Signature shown as invalid, even when TB tells OK
Description

When I send a S/MIME signed message to my Sogo account (1.2.0),
then sogo tells me that the signature is invalid.

But the very same message accessed from thunderbird tells me that the signature is valid.

For me it looks like there is some language dependency in the S7MIME checking code.
Have a look at the attached print screen.

Additional Information

The original message has been created and signed with MS Outlook 2007 German.

TagsNo tags attached.

Activities

2010-02-12 17:27

 

smime.gif (5,825 bytes)   
smime.gif (5,825 bytes)   
aschild

aschild

2010-02-12 17:30

reporter   ~0000546

The sogo server is Debian Lenny 64 bit with Sogo build Version 1.2.0 (@vizzini.inverse.ca 201002121151)

wsourdeau

wsourdeau

2010-02-15 16:37

viewer   ~0000560

Hi,

Could you provide us with a copy of such message in .eml format?

2010-02-15 16:43

 

Test SMime.eml (8,359 bytes)

2010-02-15 16:44

 

Bildschirmfoto.png (13,676 bytes)   
Bildschirmfoto.png (13,676 bytes)   
aschild

aschild

2010-02-15 16:46

reporter   ~0000561

The attached eml file shows the seond printscreen.
The message was generated with Thunderbird 2.0.23 under linux.
I think the problem is probably more server side, some locale settings...

ludovic

ludovic

2010-02-15 17:00

administrator   ~0000562

Have you installed GNUstep's SSL bundle?

aschild

aschild

2010-02-15 17:03

reporter   ~0000563

Yes,

I downloaded and compiled it. (Probably with DE locale..)

ludovic

ludovic

2010-02-15 17:04

administrator   ~0000564

Remove it, or move it to /usr/share/GNUstep/Libraries/gnustep-base/Versions/1.19/Resources/ or something.

This is bug in GNUstep.

aschild

aschild

2010-02-15 17:52

reporter   ~0000565

I did delete the /usr/share/GNUstep/Libraries/gnustep-base/Versions/1.16/Resources/SSL.bundle directory and rebooted the server.
But still the same error is displayed.

Is there something else I must remove ?

ludovic

ludovic

2010-02-15 17:54

administrator   ~0000566

You MUST remove also the empty directories in éusr/share/GNUstep/Libraries/gnustep-base/Versions/1.16/Resources

1.16
Versions

and so on until it's non-empty.

Issue History

Date Modified Username Field Change
2010-02-12 17:27 aschild New Issue
2010-02-12 17:27 aschild File Added: smime.gif
2010-02-12 17:30 aschild Note Added: 0000546
2010-02-15 16:37 wsourdeau Note Added: 0000560
2010-02-15 16:43 aschild File Added: Test SMime.eml
2010-02-15 16:44 aschild File Added: Bildschirmfoto.png
2010-02-15 16:46 aschild Note Added: 0000561
2010-02-15 17:00 ludovic Note Added: 0000562
2010-02-15 17:03 aschild Note Added: 0000563
2010-02-15 17:04 ludovic Note Added: 0000564
2010-02-15 17:04 ludovic Status new => resolved
2010-02-15 17:04 ludovic Fixed in Version => 1.2.1
2010-02-15 17:04 ludovic Resolution open => won't fix
2010-02-15 17:04 ludovic Assigned To => ludovic
2010-02-15 17:52 aschild Note Added: 0000565
2010-02-15 17:52 aschild Status resolved => feedback
2010-02-15 17:52 aschild Resolution won't fix => reopened
2010-02-15 17:54 ludovic Note Added: 0000566
2010-02-15 17:54 ludovic Status feedback => closed
2010-02-15 17:54 ludovic Resolution reopened => fixed