View Issue Details

IDProjectCategoryView StatusLast Update
0004066SOGoWeb Calendarpublic2017-03-08 15:59
ReporterDavid Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6
Product Versionnightly v2 
Fixed in Version2.3.20 
Summary0004066: User can't see own events
Description

When users save new event it is not displayed in their own sogo web calendar. Other users sharing the same calendar can see the event correctly.

Steps To Reproduce

In web calendar click New Event button, then click Save and Close. The event is saved but not displayed.

Additional Information

Deleting user preferences with sogo-tool doesn't help.

TagsNo tags attached.

Activities

ludovic

ludovic

2017-03-06 09:10

administrator   ~0011436

Just tried and it works.

Make sure the calendar is actually set to be displayed.

David

David

2017-03-06 09:35

reporter   ~0011437

Just tried to remove a user with sogo-tool completely and even with completely fresh account it doesn't work. The event is saved, displayed on top in the list of event but not in the calendar view.

David

David

2017-03-06 09:39

reporter   ~0011438

Also checked sogo.log and there's nothing special, just looks like quite normal during the event save.

David

David

2017-03-06 10:04

reporter   ~0011439

Last edited: 2017-03-06 10:05

View 2 revisions

Tested on more systems and more browsers and the issue is only IE specific, other browsers work fine. Any suggestions (except convincing users not to use IE)?

Related Changesets

sogo: v2 9df8eb36

2017-03-08 15:58:47

francis

Details Diff
(js) Prevent 304 HTTP status code in IE

Fixes 0004066
Affected Issues
0004066
mod - NEWS Diff File
mod - UI/WebServerResources/generic.js Diff File

Issue History

Date Modified Username Field Change
2017-03-06 04:35 David New Issue
2017-03-06 09:10 ludovic Severity major => minor
2017-03-06 09:10 ludovic Note Added: 0011436
2017-03-06 09:35 David Note Added: 0011437
2017-03-06 09:39 David Note Added: 0011438
2017-03-06 10:04 David Note Added: 0011439
2017-03-06 10:05 David Note Edited: 0011439 View Revisions
2017-03-08 15:59 francis Changeset attached => sogo v2 9df8eb36
2017-03-08 15:59 francis Assigned To => francis
2017-03-08 15:59 francis Resolution open => fixed
2017-03-08 15:59 francis Status new => resolved
2017-03-08 15:59 francis Fixed in Version => 2.3.20