View Issue Details

IDProjectCategoryView StatusLast Update
0003992SOGoBackend Calendarpublic2017-03-03 08:48
Reporterdani Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6
Product Version3.2.5 
Fixed in Version3.2.8 
Summary0003992: Double mailto: when creating an event with invitees in another calendar
Description

Situation:

  • Serveur Running CentOS 6 (also tested with CentOS 5) and SOGo 3.2.5 (nightly 3.2.5.20170112-1)
  • Client running Thunderbird 45.6.0 / Lightning 4.7.6 / sogo-connector 31.0.3 / sogo-integrator 31.0.3 on either Windows or Linux

Two users involved: dani and dimitri. Dani has write access to dimitri's calendar, and create on it an event and invite a 3rd person (dani AT fws.fr in the sample ICS)

The notification sent to the invitee has an incorrect SENT-BY, with a double mailto: so if the invitee reply (either accepts or declines), a failure notice will be received, because it will try to send the email with a mailto: prefix (the first mailto: is trimed, not the second)

It might be related to bug 3368 and this commit: https://github.com/inverse-inc/sogo/commit/7197b7eb41265f1b1b905d77dcd927a6c7a5a949

Additional Information

Attached is a sample ICS, as received by the invitee. daniel AT firewall-services.com is the one creating the event (dani), dimitri AT firewall-services.com (dimitri) is where the event is created by dani (on dimitri's personal calendar) and dani AT fws.fr is the invitee

TagsNo tags attached.

Activities

dani

dani

2017-01-12 11:24

reporter  

sample.ics (967 bytes)   
BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20170112T160521Z
LAST-MODIFIED:20170112T160540Z
DTSTAMP:20170112T160540Z
UID:d8e23b01-5214-4257-91ac-70ced0799aee
SUMMARY:test
ORGANIZER;PARTSTAT=ACCEPTED;ROLE=CHAIR;SENT-BY="mailto:mailto:daniel@firewa
 ll-services.com";RSVP=TRUE;CN=Dimitri Lecourt:mailto:dimitri@firewall-serv
 ices.com
ATTENDEE;ROLE=REQ-PARTICIPANT;PARTSTAT=NEEDS-ACTION;RSVP=TRUE:mailto:dani@f
 ws.fr
DTSTART;TZID=Europe/Paris:20170113T130000
DTEND;TZID=Europe/Paris:20170113T133000
TRANSP:OPAQUE
CLASS:PUBLIC
X-MOZ-GENERATION:2
SEQUENCE:1
END:VEVENT
END:VCALENDAR
sample.ics (967 bytes)   
dani

dani

2017-01-12 11:28

reporter   ~0011202

I should add that the issue doesn't exist when the event is created from the web interface directly. Only if created through Thunderbird (or maybe other Caldav clients too, I haven't tested)

ludovic

ludovic

2017-03-01 16:25

administrator   ~0011403

I can reproduce the issue, I'll look into it. It looks like it's the SOGo Connector extension adding it twice.

Related Changesets

sogo: master 79a0d5e1

2017-03-03 08:47:59

ludovic

Details Diff
(fix) handle broken CalDAV clients sending bogus SENT-BY (fixes 0003992) Affected Issues
0003992
mod - NEWS Diff File
mod - SoObjects/Appointments/SOGoAppointmentObject.m Diff File

Issue History

Date Modified Username Field Change
2017-01-12 11:24 dani New Issue
2017-01-12 11:24 dani File Added: sample.ics
2017-01-12 11:28 dani Note Added: 0011202
2017-03-01 16:25 ludovic Note Added: 0011403
2017-03-03 08:48 ludovic Changeset attached => sogo master 79a0d5e1
2017-03-03 08:48 ludovic Assigned To => ludovic
2017-03-03 08:48 ludovic Resolution open => fixed
2017-03-03 08:48 ludovic Status new => closed
2017-03-03 08:48 ludovic Fixed in Version => 3.2.8