View Issue Details

IDProjectCategoryView StatusLast Update
0003840SOGoWeb Calendarpublic2016-11-30 12:14
Reportermaxy Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Versionnightly v2 
Fixed in Version3.2.4 
Summary0003840: task list: Please add sort by start time
Description

Sorting the task list by start time allows a simple time based priorization, and makes it easier to view projects that are actionable/ignore the ones that aren't, etc.

This sorting order is also recommended in some productivity oriented circles, for example in the book: http://theproductivitypro.com/whattodo/

TagsNo tags attached.

Activities

maxy

maxy

2016-10-14 04:13

reporter   ~0010739

The other bug seems to be related to the mail search, this report is about the task list in the web calendar. The user interface is similar, but the mail search doesn't include a sorting widget, while the task list has one, and this bug request one additional sorting method.

Are you planning to merge this two different views further?

Otherwise I don't think they are duplicates.

Related Changesets

sogo: master 52cdb71d

2016-11-30 12:13:48

francis

Details Diff
Add sort by start date for the tasks list

Fixes 0003840
Affected Issues
0003840
mod - NEWS Diff File
mod - UI/Scheduler/NSArray+Scheduler.h Diff File
mod - UI/Scheduler/NSArray+Scheduler.m Diff File
mod - UI/Scheduler/UIxCalListingActions.m Diff File
mod - UI/Templates/SchedulerUI/UIxCalMainView.wox Diff File

Issue History

Date Modified Username Field Change
2016-10-13 05:35 maxy New Issue
2016-10-14 03:24 Christian Mack Relationship added duplicate of 0002951
2016-10-14 04:13 maxy Note Added: 0010739
2016-11-30 11:44 francis Relationship deleted 0002951
2016-11-30 12:14 francis Changeset attached => sogo master 52cdb71d
2016-11-30 12:14 francis Assigned To => francis
2016-11-30 12:14 francis Resolution open => fixed
2016-11-30 12:14 francis Status new => resolved
2016-11-30 12:14 francis Fixed in Version => 3.2.4