View Issue Details

IDProjectCategoryView StatusLast Update
0003776SOGoApple iPhone OSpublic2017-03-13 07:10
ReporterAnim_IT Assigned Toludovic  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformApple iOS (iPhone and iPad)OSiOSOS Version9.3.2
Product Version2.3.12 
Fixed in Version2.3.21 
Summary0003776: Calendar Event is duplicated when moved between calendars
Description

In a scenario where a SOGo user has more than one calendar: whenever a calendar event is moved from one calendar to another on an iOS device, the event gets duplicated in the target calendar, so after the transfer, there are two identical events. If I then move one of the duplicated events back to the original calendar, it gets duplicated there, too (so now there are 3 identical events).

Steps To Reproduce

When there are two calendars in the SOGo account: make an event and save it in one of the calendars. If you tap on the event, you can choose the target calendar. If you choose the other calendar in your account and hit "back", you can see there are now two identical calendar events in the target calendar.

Additional Information

This can be reproduced on any iOS device (tried and could be reproduced on an iPhone 6, an iPhone 6s, an iPhone 6s plus and several iPads). The iOS version does not seem to have any influence on the outcome.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2016-08-23 11:06

developer   ~0010610

Could you check the raw source of those events?
Do they have different UID: values?

Anim_IT

Anim_IT

2016-09-06 09:18

reporter  

SOGo_UIDs_3776.JPG (160,679 bytes)   
SOGo_UIDs_3776.JPG (160,679 bytes)   
Anim_IT

Anim_IT

2016-09-06 09:19

reporter   ~0010633

Last edited: 2016-09-06 09:19

Hi Christian,
there are two UID entries in each calendar event, I wasn't sure which one is the one you're looking for. Therefore I attached a screenshot of both events' raw data.

Christian Mack

Christian Mack

2016-09-06 10:05

developer   ~0010634

The first UID is that of the event, the second one is the UID of the Alarm, which is not of interest here.
As you can see, you have different event UIDs.
That means iOS didn't move, it copied the event.
For SOGo this means, they are different, which is why it didn't overwrite when copying back to the original calendar.
Instead it created a third copy.

I don't see how SOGo can guess when to copy and when to move, if the client don't say so.

Anim_IT

Anim_IT

2016-09-07 10:40

reporter  

SOGo_UIDs_3776v2.1.JPG (71,439 bytes)   
SOGo_UIDs_3776v2.1.JPG (71,439 bytes)   
Anim_IT

Anim_IT

2016-09-07 10:40

reporter  

SOGo_UIDs_3776v2.2.JPG (91,755 bytes)   
SOGo_UIDs_3776v2.2.JPG (91,755 bytes)   
Anim_IT

Anim_IT

2016-09-07 10:40

reporter  

SOGo_UIDs_3776v2.3.JPG (71,592 bytes)   
SOGo_UIDs_3776v2.3.JPG (71,592 bytes)   
Anim_IT

Anim_IT

2016-09-07 10:51

reporter   ~0010637

I understand what you are saying. However, this does not seem to be true, as you can see in the attached screenshots. The first shows the event which was created using the SOGo web interface. The second shows the event that iOS moved, not copied (since the UID is identical), and the third shows that SOGo copied the event, which then has a different UID.

Issue History

Date Modified Username Field Change
2016-07-25 09:12 Anim_IT New Issue
2016-08-23 11:06 Christian Mack Note Added: 0010610
2016-09-06 09:18 Anim_IT File Added: SOGo_UIDs_3776.JPG
2016-09-06 09:19 Anim_IT Note Added: 0010633
2016-09-06 09:19 Anim_IT Note Edited: 0010633
2016-09-06 10:05 Christian Mack Note Added: 0010634
2016-09-07 10:40 Anim_IT File Added: SOGo_UIDs_3776v2.1.JPG
2016-09-07 10:40 Anim_IT File Added: SOGo_UIDs_3776v2.2.JPG
2016-09-07 10:40 Anim_IT File Added: SOGo_UIDs_3776v2.3.JPG
2016-09-07 10:51 Anim_IT Note Added: 0010637
2017-03-13 07:10 ludovic Status new => resolved
2017-03-13 07:10 ludovic Fixed in Version => 2.3.21
2017-03-13 07:10 ludovic Resolution open => fixed
2017-03-13 07:10 ludovic Assigned To => ludovic