View Issue Details

IDProjectCategoryView StatusLast Update
0003632SOGoPackaging (RedHat)public2016-04-14 13:14
Reporterst41ker Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6
Product Version2.3.10 
Fixed in Versionnightly v2 
Summary0003632: Latest CentOS 6 libldb update incompatible with samba 4.1.18 from sogo repo
Description

New version of libldb (libldb-1.1.25-2.el6_7.x86_64) is incompatible with current ldb storage module for samba 4.

It prevents samba from starting with the following error:
[2016/04/13 11:25:20.506616, 0] ../lib/util/util_runcmd.c:317(samba_runcmd_io_handler)
/usr/sbin/samba_dnsupdate: ldb: module version mismatch in ../source4/dsdb/samdb/ldb_modules/acl.c : ldb_version=1.1.25 module_version=1.1.17

Steps To Reproduce

Update CentOS 6 to latest, and restart samba 4.1.18 installed from sogo repo.

Additional Information

Quick fix is to downgrade libldb and all it's dependencies to previous version.
Alternative is to rebuild samba package with the new libldb version.

TagsNo tags attached.

Activities

ludovic

ludovic

2016-04-13 11:48

administrator   ~0009971

We don't support OpenChange anymore on RHEL6.

So these packages shouldn't be used and are set to be removed.

Thanks,

plevesque

plevesque

2016-04-14 13:13

reporter   ~0009983

Packages related to OpenChange (libldb, libtalloc, samba, …) were removed from our master RHEL5/RHEL6 SOGo repositories.

Changes are already reflected on our nightly public repositories and will be applied on the stable v2 and v3 SOGo repositories in the next few days.

Issue History

Date Modified Username Field Change
2016-04-13 06:18 st41ker New Issue
2016-04-13 11:48 ludovic Note Added: 0009971
2016-04-13 11:48 ludovic Status new => closed
2016-04-13 11:48 ludovic Assigned To => ludovic
2016-04-13 11:48 ludovic Resolution open => no change required
2016-04-14 13:13 plevesque Note Added: 0009983
2016-04-14 13:14 plevesque Status closed => resolved
2016-04-14 13:14 plevesque Resolution no change required => fixed
2016-04-14 13:14 plevesque Fixed in Version => nightly v2