View Issue Details

IDProjectCategoryView StatusLast Update
0003526SOGoWeb Mailpublic2016-05-25 10:54
Reporterchris_gm Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version8 (Jessie)
Product Version3.0.1 
Fixed in Version3.1.1 
Summary0003526: Adding Recpipients from Address Book
Description

When creating a new mail, I am trying to add recipients to the to-address from the address-book. But - and maybe I am overlooking something - I cannot find how and where? Maybe it's really missing?

Steps To Reproduce

Open Webmail, create new mail

TagsNo tags attached.

Relationships

related to 0003443 resolvedfrancis when sending an email, you can not choose between multiple "mail" entries 

Activities

chris_gm

chris_gm

2016-02-16 04:15

reporter   ~0009543

During testing, i found out, that it's not possible to "browse" the contacts/address book to add a contact as a recpipient. When typing, the mail-module tries to find a recpipient. There's one problem: When a contact has more than one mail-address (for example work and home), only the first is shown and it's not possible to choose to which address to send.

chris_gm

chris_gm

2016-02-16 04:18

reporter   ~0009544

Seems to be the same issue as 0003443

Related Changesets

sogo: master fd4b0942

2016-05-25 10:25:53

francis

Details Diff
Expose all email addresses in autocompletion

This change is immediately applicable to LDAP-based system address
books. However, personal SQL-based address books must have their quick
tables recreated. To do so, one must use sogo-tool to backup and restore
the user's data.

Resolves 0003443, 0003526
Affected Issues
0003443, 0003526
mod - NEWS Diff File
mod - SoObjects/Contacts/NGVCard+SOGo.m Diff File
mod - SoObjects/Contacts/SOGoContactGCSFolder.m Diff File
mod - UI/Templates/MailerUI/UIxMailEditor.wox Diff File
mod - UI/WebServerResources/js/Contacts/Card.service.js Diff File
mod - UI/WebServerResources/js/Mailer/MessageEditorController.js Diff File

Issue History

Date Modified Username Field Change
2016-02-16 02:00 chris_gm New Issue
2016-02-16 04:15 chris_gm Note Added: 0009543
2016-02-16 04:18 chris_gm Note Added: 0009544
2016-02-16 07:16 ludovic Severity major => feature
2016-02-17 04:30 Christian Mack Relationship added related to 0003443
2016-05-25 10:52 francis Changeset attached => sogo master fd4b0942
2016-05-25 10:52 francis Assigned To => francis
2016-05-25 10:52 francis Resolution open => fixed
2016-05-25 10:54 francis Status new => resolved
2016-05-25 10:54 francis Fixed in Version => 3.1.1