View Issue Details

IDProjectCategoryView StatusLast Update
0003477SOGoWeb Mailpublic2016-02-03 17:38
ReporterMcMichaeli Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformClientOSUbuntuOS Version14.04 LTS
Product Version3.0.0 
Fixed in Version3.0.1 
Summary0003477: Move message button missing in v3.0.0 web interface
Description

The ability to move (refile) a message (or a selection of messages) into a different folder is currently missing from the v3.0.0 web interface. For customers who like to keep their messages well organised in folders this is a large omission.

A screenshot is attached showing the available options.

Steps To Reproduce

Using Chrome 48.0.2564.97 or Firefox 44.0 on Ubuntu 14.04 LTS desktop (64 bit) log onto SOGo v3.0.0 web interface.

Select one or more messages in the Inbox by clicking on their avatar.

The search bar at the top of the message list changes to a selected message action list.

No move option is available.

Additional Information

A work-around is to use the above procedure to copy the messages to the destination folder and then delete them from the original one. For people used to the convenience of a simple move operation in the v2.x interface this is an added complexity.

TagsNo tags attached.

Activities

McMichaeli

McMichaeli

2016-02-01 07:45

reporter  

SOGO3_move.jpg (24,835 bytes)   
SOGO3_move.jpg (24,835 bytes)   
francis

francis

2016-02-01 08:04

administrator   ~0009380

How about clicking on the "Copy" button and then the "Delete" button?

McMichaeli

McMichaeli

2016-02-01 09:12

reporter   ~0009382

Yes, I noted this as a work-around in the Additional Information above.

When we have spent ages training users that it is a bad idea to copy messages to folders because it leads to duplicate copies (and often duplicate responses) it is a shame to no longer have a simple move function, which eliminates this.

rolek

rolek

2016-02-01 11:45

reporter   ~0009388

This is the one thing that keeps us from switching to SOGo v3, thanks for reporting it.

ludovic

ludovic

2016-02-01 11:53

administrator   ~0009389

There's no such thing like a MOVE using the IMAP protocol. It's always a COPY + DELETE.

That's why we removed that option for now.

McMichaeli

McMichaeli

2016-02-01 11:58

reporter   ~0009390

That's understood at an IMAP API level. Unfortunately, pretty much every e-mail client I can think of implements a move at the UI level. Even GMail does it and that has the concept of tags rather than using folders at all!

It is going to make it very difficult for us to "sell" the upgrade to our customers, who are all trained to move things to folders for ease of reference/archival purposes. A non-technical person does not necessarily realise a move is just a copy plus a delete. Plus most of our users are lazy! ;-)

alain.abbas

alain.abbas

2016-02-02 05:43

reporter   ~0009403

yes really missing

bkeller

bkeller

2016-02-02 14:21

reporter   ~0009406

yes, this is not a gadget.

francis

francis

2016-02-03 17:38

administrator   ~0009438

https://github.com/inverse-inc/sogo/commit/f321e1c949401268024fe9a2b5cfc7901437e83e

Issue History

Date Modified Username Field Change
2016-02-01 07:45 McMichaeli New Issue
2016-02-01 07:45 McMichaeli File Added: SOGO3_move.jpg
2016-02-01 08:04 francis Note Added: 0009380
2016-02-01 09:12 McMichaeli Note Added: 0009382
2016-02-01 11:45 rolek Note Added: 0009388
2016-02-01 11:53 ludovic Note Added: 0009389
2016-02-01 11:58 McMichaeli Note Added: 0009390
2016-02-02 05:43 alain.abbas Note Added: 0009403
2016-02-02 14:21 bkeller Note Added: 0009406
2016-02-03 17:38 francis Note Added: 0009438
2016-02-03 17:38 francis Status new => resolved
2016-02-03 17:38 francis Fixed in Version => 3.0.1
2016-02-03 17:38 francis Resolution open => fixed
2016-02-03 17:38 francis Assigned To => francis