View Issue Details

IDProjectCategoryView StatusLast Update
0003461SOGoPackaging (Debian)public2016-02-23 11:58
Reporterzhb Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.6 
Fixed in Version2.3.9 
Summary0003461: Warning message with default /etc/apache2/conf-available/SOGo.conf
Description

OS: Debian/Ubuntu
Issue:

Each time restarting Apache will raise error like this:

[Wed Jan 27 10:56:13.206285 2016] [proxy:warn] [pid 16215] AH01146: Ignoring parameter 'retry=60' for worker 'http://127.0.0.1:20000/SOGo' because of worker sharing
[Wed Jan 27 10:56:13.206486 2016] [proxy:warn] [pid 16215] AH01146: Ignoring parameter 'connectiontimeout=5' for worker 'http://127.0.0.1:20000/SOGo' because of worker sharing
[Wed Jan 27 10:56:13.206529 2016] [proxy:warn] [pid 16215] AH01146: Ignoring parameter 'timeout=360' for worker 'http://127.0.0.1:20000/SOGo' because of worker sharing

Additional Information

It's able to suppress this warning by swapping the order of two "ProxyPass" setting in /etc/apache2/conf-available/SOGo.conf, but is it right to do so?

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2016-01-28 03:05

developer   ~0009350

which worker are you using in apache?

zhb

zhb

2016-02-16 23:18

reporter   ~0009557

prefork.

Christian Mack

Christian Mack

2016-02-17 04:23

developer   ~0009559

Then you can swap the ActiveSync and normal SOGo ProxyPass directives.

zhb

zhb

2016-02-17 04:59

reporter   ~0009560

I fixed it by swapping those two ProxyPass directives. The problem is, you should update the SOGo.conf for Apache too.

MarcelIT

MarcelIT

2016-02-23 09:50

reporter   ~0009582

Last edited: 2016-02-23 09:50

View 2 revisions

@zhb
Can post your two ProxyPass directives?

zhb

zhb

2016-02-23 09:54

reporter   ~0009583

Hi @MarcelIT:

Default setting is:

#################
ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0

ProxyPass /Microsoft-Server-ActiveSync \
http://127.0.0.1:20000/SOGo/Microsoft-Server-ActiveSync \
retry=60 connectiontimeout=5 timeout=360
#################

I just swap the order of them:

#################
ProxyPass /Microsoft-Server-ActiveSync \
http://127.0.0.1:20000/SOGo/Microsoft-Server-ActiveSync \
retry=60 connectiontimeout=5 timeout=360

ProxyPass /SOGo http://127.0.0.1:20000/SOGo retry=0
#################

Related Changesets

sogo: v2 8617ddc0

2016-02-23 11:56:28

francis

Details Diff
Review order of ProxyPass directives

Fixes 0003461
Affected Issues
0003461
mod - Apache/SOGo.conf Diff File

sogo: master a8ccaac1

2016-02-23 11:56:28

francis

Details Diff
Review order of ProxyPass directives

Fixes 0003461
Affected Issues
0003461
mod - Apache/SOGo.conf Diff File

Issue History

Date Modified Username Field Change
2016-01-27 06:52 zhb New Issue
2016-01-28 03:05 Christian Mack Note Added: 0009350
2016-02-16 23:18 zhb Note Added: 0009557
2016-02-17 04:23 Christian Mack Note Added: 0009559
2016-02-17 04:59 zhb Note Added: 0009560
2016-02-23 09:50 MarcelIT Note Added: 0009582
2016-02-23 09:50 MarcelIT Note Edited: 0009582 View Revisions
2016-02-23 09:54 zhb Note Added: 0009583
2016-02-23 11:57 francis Changeset attached => sogo v2 8617ddc0
2016-02-23 11:57 francis Assigned To => francis
2016-02-23 11:57 francis Resolution open => fixed
2016-02-23 11:58 francis Status new => resolved
2016-02-23 11:58 francis Fixed in Version => 2.3.9
2016-02-23 11:58 francis Changeset attached => sogo master a8ccaac1