View Issue Details

IDProjectCategoryView StatusLast Update
0003437SOGoBackend Address Bookpublic2016-03-16 07:19
Reporterraffael Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Fixed in Version3.0.2 
Summary0003437: In CardDAV and WebUI search only Contacts with emails are returned when no filter is given
Description

CardDAV reports without filters are returning only cards having an email address.
The same happens if you search in the webinterface and then delete the search again. Only Contacts having an email address are shown then.

IMHO the problem has something to do with searching for Dot (.) in the query it looks something like this: "like UPPER('%.%')"
Maybe this works with postgres (could not test) but doesn't work with mysql for sure.

Steps To Reproduce
  1. Create a contact without email in sogo demo using sogo2 user.

  2. run this:
    curl --basic -u sogo2:sogo2 -X REPORT --include -H "Depth: 1" -H "Content-Type: text/xml" --data-binary '<?xml version="1.0" encoding="UTF-8" ?><CARD:addressbook-query xmlns="DAV:" xmlns:CARD="urn:ietf:params:xml:ns:carddav"><prop /><CARD:filter /></CARD:addressbook-query>' http://sogo-demo.inverse.ca/SOGo/dav/sogo2/Contacts/personal

  3. Check answer if new new is listed

Reproduce in WEB-UI:

  1. Create a contact without email in sogo demo using sogo2 user.
  2. Search addresses for "asdf"
  3. Delete characters in search
  4. Check if new contact is listed
Additional Information

I think that this git commits might have something to do with it:
for carddav: 2c723070c69899055b456119f6e8f42c279d0c57
for ui search: 2c723070c69899055b456119f6e8f42c279d0c57

TagsNo tags attached.

Activities

francis

francis

2016-03-15 14:35

administrator   ~0009749

Can't reproduce on http://sogo-demo.inverse.ca/SOGo/. Which version of SOGo do you use?

raffael

raffael

2016-03-16 07:13

reporter   ~0009757

Looks like it was fixed with commit: 99765aae53bfce84842f933d63185eabb2971124
Thanks

Issue History

Date Modified Username Field Change
2016-01-13 13:12 raffael New Issue
2016-02-15 12:34 francis Project SOGo Integrator => SOGo
2016-03-15 14:35 francis Note Added: 0009749
2016-03-16 07:13 raffael Note Added: 0009757
2016-03-16 07:19 francis Status new => resolved
2016-03-16 07:19 francis Fixed in Version => 3.0.2
2016-03-16 07:19 francis Resolution open => fixed
2016-03-16 07:19 francis Assigned To => francis