View Issue Details

IDProjectCategoryView StatusLast Update
0003359SOGoWeb Mailpublic2015-10-23 12:46
Reporterwimmer Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.2 
Fixed in Version2.3.3 
Summary0003359: 'Reply All' doesn't work when message was sent from Thunderbird to Bcc: recipient only
Description

SOGo WebGUI crashes in this case

Steps To Reproduce

1) send e-mail from Thunderbird to some "Bcc:" recipient and with empty "To:" field
=> Thunderbird uses following line in that case:
To: "undisclosed-recipients (utajeni adresati)": ;

2) go to the same sender account to SOGo WebGUI, open that message in his Sent folder and choose "Reply All".
=> WebGUI opens Error window with "Proxy Error - Reason: Error reading from remote server" content.
=> SOGo writes following message into sogo.log:
EXCEPTION: <NSException: 0x564eec2bb420> NAME:NSInvalidArgumentException REASON:[GSMutableString -compare:options:range:] nil string argument INFO:(null)
Oct 05 23:38:04 sogod [11795]: <0x0x564eebd55330[WOWatchDogChild]> child 11817 exited
Oct 05 23:38:04 sogod [11795]: <0x0x564eebd55330[WOWatchDogChild]> (terminated due to signal 6)
Oct 05 23:38:04 sogod [11795]: <0x0x564eeba8d600[WOWatchDog]> child spawned with pid 22608

3) when you choose "Reply" action in WebGUI on the same message, all works fine

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2015-10-05 17:54 wimmer New Issue
2015-10-23 12:46 ludovic Note Added: 0009028
2015-10-23 12:46 ludovic Status new => resolved
2015-10-23 12:46 ludovic Fixed in Version => 2.3.3
2015-10-23 12:46 ludovic Resolution open => fixed
2015-10-23 12:46 ludovic Assigned To => ludovic