View Issue Details

IDProjectCategoryView StatusLast Update
0003296SOGoBackend Calendarpublic2017-03-29 10:20
Reporteresco Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version7
Product Version2.3.1 
Target Version2.3.9Fixed in Version3.2.9 
Summary0003296: problems with escaping of comma for attendee (too many backslashes)
Description

Hello,

at the moment there seem to be some problems with escaping of commas in the name of attendee of an event.

If you invite "foo, bar" <foo@bar> in the web interface this will be translated to "foo\, bar" in thunderbird and the raw view of the web interface. In the backup its translated to "foo\, bar".

But the main problem is that if you make changes to the event it changes to "foo\\, bar", .. "foo\\\\, bar" and so on until 1000000 characters are reached and I get a 500 server error.

Database is PostgreSQL.

esco

TagsNo tags attached.

Activities

m0ps

m0ps

2015-09-24 06:47

reporter   ~0008944

Last edited: 2015-09-24 06:49

Hello!
We are also faced with this issue. Also reproduced on 2.3.2
Database is MySQL 5.5.

schizoid

schizoid

2015-09-24 06:50

reporter   ~0008945

+1

esco

esco

2015-11-27 15:27

reporter   ~0009171

Still in 2.3.3a

stephan

stephan

2016-02-19 04:57

reporter   ~0009569

The reason is that SOGo wrongly encodes CNs of ORGANIZERs and ATTENDEEs in invitation. Please have a look at https://tools.ietf.org/html/rfc5545

cnparam = "CN" "=" param-value
param-value = paramtext / quoted-string
... and so on
There is no encoding with backslashes for CNs with commas. It must be "".

The correct value of CNs with commas is
ORGANIZER;CN="Smith, John":mailto:jsmith@example.com
but SOGo saves
ORGANIZER;CN=Smith\, John:mailto:jsmith@example.com

Please check with outlook. Invitation from outlook (and other calendar-sw) are correct. But answers from SOGo start the process of adding multiple \\.

ludovic

ludovic

2016-03-15 10:40

administrator   ~0009747

Will also be cherry-picked in v3.0.3.

esco

esco

2016-08-16 03:56

reporter   ~0010606

Last edited: 2016-08-16 04:00

This should be fixed in 3.x, too.

esco

esco

2017-03-28 05:10

reporter   ~0011603

Please, this should be fixed in 3.x, too.

rci

rci

2017-03-29 03:35

reporter   ~0011609

Last edited: 2017-03-29 05:02

Same here (SOGo 3.2.7). Did not report it because there are some more severe problems with SOGo here.
It seems to be an infinite number of "\" after some time. We have seen it in a recurring event with about 10 attendees.

Not the whole content...:

\\\\\\\\\\\\\\\\
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

It's a few megabytes of "\"!

ludovic

ludovic

2017-03-29 09:53

administrator   ~0011617

There must be an other unhandled case because that was fixed 1.5 year go.

We will investigate.

esco

esco

2017-03-29 10:09

reporter   ~0011618

I don't think that this was ever fixed in 3.x. Only in 2.x..

ludovic

ludovic

2017-03-29 10:12

administrator   ~0011619

The code WAS cherry-picked in v3.

I made a few simple tests in v3 but couldn't reproduce the issue so far.

I'll try with an external Outlook / Exchange invitation.

esco

esco

2017-03-29 10:15

reporter   ~0011620

But not in the GitHub Repo?
https://github.com/inverse-inc/sogo/commits/master/SOPE/NGCards/NSDictionary%2BNGCards.m

ludovic

ludovic

2017-03-29 10:19

administrator   ~0011621

Excellent find!

I was looking at similar changes we did in NSString+NGCards.m.

Fix has been cherry-picked.

Related Changesets

sogo: v2 17afe7c0

2016-03-15 10:38:38

ludovic

Details Diff
(fix) avoid escaping values that are quoted (fixes 0003296) Affected Issues
0003296
mod - SOPE/NGCards/NSDictionary+NGCards.m Diff File
mod - Tests/Unit/TestVersit.m Diff File

sogo: master c11d961b

2016-03-15 10:38:38

ludovic

Details Diff
(fix) avoid escaping values that are quoted (fixes 0003296) Affected Issues
0003296
mod - SOPE/NGCards/NSDictionary+NGCards.m Diff File
mod - Tests/Unit/TestVersit.m Diff File

Issue History

Date Modified Username Field Change
2015-07-29 07:40 esco New Issue
2015-09-24 06:47 m0ps Note Added: 0008944
2015-09-24 06:49 m0ps Note Edited: 0008944
2015-09-24 06:50 schizoid Note Added: 0008945
2015-11-27 15:27 esco Note Added: 0009171
2016-02-19 04:57 stephan Note Added: 0009569
2016-03-14 13:58 francis Target Version => 2.3.9
2016-03-15 10:40 ludovic Changeset attached => sogo v2 17afe7c0
2016-03-15 10:40 ludovic Assigned To => ludovic
2016-03-15 10:40 ludovic Resolution open => fixed
2016-03-15 10:40 ludovic Note Added: 0009747
2016-03-15 10:40 ludovic Status new => resolved
2016-03-15 10:40 ludovic Fixed in Version => 2.3.9
2016-08-16 03:56 esco Note Added: 0010606
2016-08-16 03:56 esco Status resolved => feedback
2016-08-16 03:56 esco Resolution fixed => reopened
2016-08-16 04:00 esco Note Edited: 0010606
2016-08-29 09:32 francis Status feedback => resolved
2016-08-29 09:32 francis Resolution reopened => fixed
2017-03-28 05:10 esco Note Added: 0011603
2017-03-28 05:10 esco Status resolved => feedback
2017-03-28 05:10 esco Resolution fixed => reopened
2017-03-29 03:35 rci Note Added: 0011609
2017-03-29 03:36 rci Note Edited: 0011609
2017-03-29 04:55 rci Note Edited: 0011609
2017-03-29 05:02 rci Note Edited: 0011609
2017-03-29 09:53 ludovic Note Added: 0011617
2017-03-29 10:09 esco Note Added: 0011618
2017-03-29 10:09 esco Status feedback => assigned
2017-03-29 10:12 ludovic Note Added: 0011619
2017-03-29 10:15 esco Note Added: 0011620
2017-03-29 10:19 ludovic Changeset attached => sogo master c11d961b
2017-03-29 10:19 ludovic Note Added: 0011621
2017-03-29 10:20 ludovic Status assigned => resolved
2017-03-29 10:20 ludovic Fixed in Version 2.3.9 => 3.2.9
2017-03-29 10:20 ludovic Resolution reopened => fixed