View Issue Details

IDProjectCategoryView StatusLast Update
0003295SOGoWeb Calendarpublic2015-09-15 17:29
Reporterwimmer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.3.1 
Target Version2.3.2Fixed in Version2.3.2 
Summary0003295: String values of "Category" and "Calendar" elements are not translated
Description

When user hasn't saved his preferences, SOGo 2.3.1 doesn't translate string values of "Category" and "Calendar" elements into target language.

See picture of "New event" window in both SOGo-2.3.1 and SOGo-2.3.0
Translation doesn't work in "Preferences -> Calendar Options -> Categories" also.

TagsNo tags attached.

Activities

wimmer

wimmer

2015-07-27 11:53

reporter  

sogo-231.png (25,624 bytes)   
sogo-231.png (25,624 bytes)   
wimmer

wimmer

2015-07-27 11:54

reporter  

sogo-230.png (32,599 bytes)   
sogo-230.png (32,599 bytes)   
francis

francis

2015-09-15 16:01

administrator   ~0008916

I can't reproduce the problem with the calendar name, but I fixed the problem with the calendar categories.

See https://github.com/inverse-inc/sogo/commit/b910501afa8106a3585e50aae931bccb359b5272

wimmer

wimmer

2015-09-15 16:49

reporter   ~0008918

I can confirm both "Category" and "Calendar" elements are translated fine after applying your patch.
Thanks

Issue History

Date Modified Username Field Change
2015-07-27 11:53 wimmer New Issue
2015-07-27 11:53 wimmer File Added: sogo-231.png
2015-07-27 11:54 wimmer File Added: sogo-230.png
2015-07-30 10:40 ludovic Target Version => 2.3.2
2015-09-15 16:01 francis Note Added: 0008916
2015-09-15 16:49 wimmer Note Added: 0008918
2015-09-15 17:29 francis Status new => resolved
2015-09-15 17:29 francis Fixed in Version => 2.3.2
2015-09-15 17:29 francis Resolution open => fixed
2015-09-15 17:29 francis Assigned To => francis