View Issue Details

IDProjectCategoryView StatusLast Update
0003231SOGoBackend Generalpublic2015-07-22 12:45
Reporterklti Assigned Toludovic  
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version7
Fixed in Version2.3.1 
Summary0003231: 2.3.0 cannot connect to MySQL in most recent CentOS
Description

After upgrading CentOS 7 systems (which brings the "upgrade" to 7.1), SOGo can no longer connect to MySQL. The Logs show this:

2015-06-04 13:49:37.867 sogod[18337] ERROR((null)): could not allocate MySQL4 connection!
Jun 04 13:49:37 sogod [18337]: [ERROR] <0x0x7febfea7f520[GCSChannelManager]> could not open channel <MySQL4Channel[0x0x7febfeed6e90] connection=0x(null)> for mysql://localhost/mail/sogo_users
Jun 04 13:49:37 sogod [18337]: [WARN] <0x0x7febfea7f520[GCSChannelManager]> will prevent opening of this channel 5 seconds after 2015-06-04 13:49:37 +0200

I reproduced this on two systems, one installed as 7.0 and the updated through the normal package upgrade process, and one installed directly with 7.1, results are identical. Sogo worked when the system still using the older packages, it didn't after the upgrade. Interestingly, the upgrade did not seem to touch anything sogo / gnustep / mysql / mariadb related (as far as I can see, see additional information).

This issue has already been discussed a while ago on the mailing list:

Steps To Reproduce
  • update CentOS 7 system to latest (yum update)
  • configure SOGo with MySQL
  • restart SOGo
Additional Information

This is the list of updated packages yum gave:

Installed:
NetworkManager.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 NetworkManager-adsl.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7
NetworkManager-bluetooth.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 NetworkManager-team.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7
NetworkManager-wifi.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 NetworkManager-wwan.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7
kernel.x86_64 0:3.10.0-229.4.2.el7

Dependency Installed:
NetworkManager-libnm.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 kbd-legacy.noarch 0:1.15.5-11.el7 trousers.x86_64 0:0.3.11.2-3.el7

Updated:
NetworkManager-glib.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 NetworkManager-tui.x86_64 1:1.0.0-14.git20150121.b4ea599c.el7 alsa-firmware.noarch 0:1.0.28-2.el7
alsa-lib.x86_64 0:1.0.28-2.el7 audit.x86_64 0:2.4.1-5.el7 audit-libs.x86_64 0:2.4.1-5.el7
audit-libs-python.x86_64 0:2.4.1-5.el7 augeas-libs.x86_64 0:1.1.0-17.el7 authconfig.x86_64 0:6.2.8-9.el7
avahi.x86_64 0:0.6.31-14.el7 avahi-autoipd.x86_64 0:0.6.31-14.el7 avahi-libs.x86_64 0:0.6.31-14.el7
bash.x86_64 0:4.2.46-12.el7 bind-libs-lite.x86_64 32:9.9.4-18.el7_1.1 bind-license.noarch 32:9.9.4-18.el7_1.1
binutils.x86_64 0:2.23.52.0.1-30.el7_1.2 biosdevname.x86_64 0:0.6.1-2.el7 btrfs-progs.x86_64 0:3.16.2-1.el7
centos-logos.noarch 0:70.0.6-2.el7.centos centos-release.x86_64 0:7-1.1503.el7.centos.2.8 cronie.x86_64 0:1.4.11-13.el7
cronie-anacron.x86_64 0:1.4.11-13.el7 cryptsetup-libs.x86_64 0:1.6.6-3.el7 dbus.x86_64 1:1.6.12-11.el7
dbus-libs.x86_64 1:1.6.12-11.el7 device-mapper.x86_64 7:1.02.93-3.el7 device-mapper-libs.x86_64 7:1.02.93-3.el7
dhclient.x86_64 12:4.2.5-36.el7.centos dhcp-common.x86_64 12:4.2.5-36.el7.centos dhcp-libs.x86_64 12:4.2.5-36.el7.centos
dnsmasq.x86_64 0:2.66-13.el7_1 dracut.x86_64 0:033-241.el7_1.1 dracut-config-rescue.x86_64 0:033-241.el7_1.1
dracut-network.x86_64 0:033-241.el7_1.1 e2fsprogs.x86_64 0:1.42.9-7.el7 e2fsprogs-libs.x86_64 0:1.42.9-7.el7
elfutils-libelf.x86_64 0:0.160-1.el7 elfutils-libs.x86_64 0:0.160-1.el7 ethtool.x86_64 2:3.15-2.el7
facter.x86_64 1:2.4.4-1.el7 fail2ban.noarch 0:0.9.1-4.el7 fail2ban-firewalld.noarch 0:0.9.1-4.el7
fail2ban-sendmail.noarch 0:0.9.1-4.el7 fail2ban-server.noarch 0:0.9.1-4.el7 fail2ban-systemd.noarch 0:0.9.1-4.el7
firewalld.noarch 0:0.3.9-11.el7 freetype.x86_64 0:2.4.11-10.el7_1.1 glib-networking.x86_64 0:2.40.0-1.el7
glib2.x86_64 0:2.40.0-4.el7 gmp.x86_64 1:6.0.0-11.el7 gnutls.x86_64 0:3.3.8-12.el7
grep.x86_64 0:2.20-1.el7 grub2.x86_64 1:2.02-0.16.el7.centos grub2-tools.x86_64 1:2.02-0.16.el7.centos
grubby.x86_64 0:8.28-11.el7 httpd.x86_64 0:2.4.6-31.el7.centos httpd-tools.x86_64 0:2.4.6-31.el7.centos
hwdata.x86_64 0:0.252-7.8.el7_1 initscripts.x86_64 0:9.49.24-1.el7 iproute.x86_64 0:3.10.0-21.el7
iprutils.x86_64 0:2.4.3-3.el7 irqbalance.x86_64 2:1.0.7-1.el7 iwl100-firmware.noarch 0:39.31.5.1-36.el7
iwl1000-firmware.noarch 1:39.31.5.1-36.el7 iwl105-firmware.noarch 0:18.168.6.1-36.el7 iwl135-firmware.noarch 0:18.168.6.1-36.el7
iwl2000-firmware.noarch 0:18.168.6.1-36.el7 iwl2030-firmware.noarch 0:18.168.6.1-36.el7 iwl3160-firmware.noarch 0:22.0.7.0-36.el7
iwl3945-firmware.noarch 0:15.32.2.9-36.el7 iwl4965-firmware.noarch 0:228.61.2.24-36.el7 iwl5000-firmware.noarch 0:8.83.5.1_1-36.el7
iwl5150-firmware.noarch 0:8.24.2.2-36.el7 iwl6000-firmware.noarch 0:9.221.4.1-36.el7 iwl6000g2a-firmware.noarch 0:17.168.5.3-36.el7
iwl6000g2b-firmware.noarch 0:17.168.5.2-36.el7 iwl6050-firmware.noarch 0:41.28.5.1-36.el7 iwl7260-firmware.noarch 0:22.0.7.0-36.el7
kbd.x86_64 0:1.15.5-11.el7 kbd-misc.noarch 0:1.15.5-11.el7 kernel-tools.x86_64 0:3.10.0-229.4.2.el7
kernel-tools-libs.x86_64 0:3.10.0-229.4.2.el7 kexec-tools.x86_64 0:2.0.7-19.el7_1.2 kmod.x86_64 0:14-10.el7
kmod-libs.x86_64 0:14-10.el7 kpartx.x86_64 0:0.4.9-77.el7 krb5-libs.x86_64 0:1.12.2-14.el7
libblkid.x86_64 0:2.23.2-22.el7_1 libcgroup.x86_64 0:0.41-8.el7 libcom_err.x86_64 0:1.42.9-7.el7
libdrm.x86_64 0:2.4.56-2.el7 libgcc.x86_64 0:4.8.3-9.el7 libgcrypt.x86_64 0:1.5.3-12.el7_1.1
libgomp.x86_64 0:4.8.3-9.el7 libgudev1.x86_64 0:208-20.el7_1.3 libmount.x86_64 0:2.23.2-22.el7_1
libnl3.x86_64 0:3.2.21-8.el7 libnl3-cli.x86_64 0:3.2.21-8.el7 libpcap.x86_64 14:1.5.3-4.el7_1.2
libsoup.x86_64 0:2.46.0-3.el7 libss.x86_64 0:1.42.9-7.el7 libstdc++.x86_64 0:4.8.3-9.el7
libtasn1.x86_64 0:3.8-2.el7 libteam.x86_64 0:1.15-1.el7 libuuid.x86_64 0:2.23.2-22.el7_1
libxml2.x86_64 0:2.9.1-5.el7_1.2 linux-firmware.noarch 0:20140911-0.1.git365e80c.el7 mcollective.noarch 0:2.8.2-1.el7
mcollective-common.noarch 0:2.8.2-1.el7 mcollective-package-agent.noarch 0:4.4.0-1.el7 mcollective-package-common.noarch 0:4.4.0-1.el7
microcode_ctl.x86_64 2:2.1-10.el7 mod_ssl.x86_64 1:2.4.6-31.el7.centos nettle.x86_64 0:2.7.1-4.el7
nspr.x86_64 0:4.10.8-1.el7_1 nss.x86_64 0:3.18.0-2.2.el7_1 nss-softokn.x86_64 0:3.16.2.3-9.el7
nss-softokn-freebl.x86_64 0:3.16.2.3-9.el7 nss-sysinit.x86_64 0:3.18.0-2.2.el7_1 nss-tools.x86_64 0:3.18.0-2.2.el7_1
nss-util.x86_64 0:3.18.0-1.el7_1 numactl-libs.x86_64 0:2.0.9-4.el7 openldap.x86_64 0:2.4.39-6.el7
openssh.x86_64 0:6.6.1p1-12.el7_1 openssh-clients.x86_64 0:6.6.1p1-12.el7_1 openssh-server.x86_64 0:6.6.1p1-12.el7_1
openssl.x86_64 1:1.0.1e-42.el7.4 openssl-libs.x86_64 1:1.0.1e-42.el7.4 p11-kit.x86_64 0:0.20.7-3.el7
p11-kit-trust.x86_64 0:0.20.7-3.el7 pam.x86_64 0:1.1.8-12.el7 parted.x86_64 0:3.1-20.el7
pcre.x86_64 0:8.32-14.el7 perl.x86_64 4:5.16.3-285.el7 perl-Pod-Escapes.noarch 1:1.04-285.el7
perl-libs.x86_64 4:5.16.3-285.el7 perl-macros.x86_64 4:5.16.3-285.el7 plymouth.x86_64 0:0.8.9-0.13.20140113.el7.centos
plymouth-core-libs.x86_64 0:0.8.9-0.13.20140113.el7.centos plymouth-scripts.x86_64 0:0.8.9-0.13.20140113.el7.centos policycoreutils.x86_64 0:2.2.5-15.el7
policycoreutils-devel.x86_64 0:2.2.5-15.el7 policycoreutils-python.x86_64 0:2.2.5-15.el7 procps-ng.x86_64 0:3.3.10-3.el7
puppet.noarch 0:3.8.1-1.el7 pygobject3-base.x86_64 0:3.8.2-6.el7 python-backports.x86_64 0:1.0-8.el7
python-urlgrabber.noarch 0:3.10-6.el7 rpm.x86_64 0:4.11.1-25.el7 rpm-build-libs.x86_64 0:4.11.1-25.el7
rpm-libs.x86_64 0:4.11.1-25.el7 rpm-python.x86_64 0:4.11.1-25.el7 ruby.x86_64 0:2.0.0.598-24.el7
ruby-irb.noarch 0:2.0.0.598-24.el7 ruby-libs.x86_64 0:2.0.0.598-24.el7 rubygem-bigdecimal.x86_64 0:1.2.0-24.el7
rubygem-io-console.x86_64 0:0.4.2-24.el7 rubygem-json.x86_64 0:1.7.7-24.el7 rubygem-psych.x86_64 0:2.0.0-24.el7
rubygem-rdoc.noarch 0:4.0.0-24.el7 rubygems.noarch 0:2.0.14-24.el7 selinux-policy.noarch 0:3.13.1-23.el7_1.7
selinux-policy-devel.noarch 0:3.13.1-23.el7_1.7 selinux-policy-targeted.noarch 0:3.13.1-23.el7_1.7 setup.noarch 0:2.8.71-5.el7
shadow-utils.x86_64 2:4.1.5.1-18.el7 sudo.x86_64 0:1.8.6p7-13.el7 systemd.x86_64 0:208-20.el7_1.3
systemd-libs.x86_64 0:208-20.el7_1.3 systemd-python.x86_64 0:208-20.el7_1.3 systemd-sysv.x86_64 0:208-20.el7_1.3
teamd.x86_64 0:1.15-1.el7 tuned.noarch 0:2.4.1-1.el7 tzdata.noarch 0:2015d-1.el7
util-linux.x86_64 0:2.23.2-22.el7_1 xfsprogs.x86_64 0:3.2.1-6.el7 xz.x86_64 0:5.1.2-9alpha.el7
xz-libs.x86_64 0:5.1.2-9alpha.el7 yum.noarch 0:3.4.3-125.el7.centos yum-plugin-fastestmirror.noarch 0:1.1.31-29.el7
zabbix.x86_64 0:2.2.9-1.el7 zabbix-agent.x86_64 0:2.2.9-1.el7

Replaced:
NetworkManager.x86_64 1:0.9.9.1-29.git20140326.4dba720.el7_0

TagsNo tags attached.

Relationships

duplicate of 0003225 resolvedludovic Cannot login to SOGo web interface: didn't set return value for type 'v' 

Activities

m3gz

m3gz

2015-06-11 11:08

reporter   ~0008620

This appears to have been discussed in the mailing list https://lists.inverse.ca/sogo/arc/users/2015-04/msg00116.html

As a workaround, Gilles Gagniard suggests to downgrade mariadb-libs to
5.5.35

Sigurd Holter

Sigurd Holter

2015-06-12 02:09

reporter   ~0008631

mariadb 5.5.37 works fine as well.

zhb

zhb

2015-07-02 20:38

reporter   ~0008691

Duplicate bugs: 0003231 0003225 0003253

ludovic

ludovic

2015-07-22 12:45

administrator   ~0008755

I suspect ABI issues between librairies. Our chroots were updated and all integration tests work. Retry with the upcoming 2.3.1 version.

Issue History

Date Modified Username Field Change
2015-06-04 08:06 klti New Issue
2015-06-11 11:08 m3gz Note Added: 0008620
2015-06-12 02:09 Sigurd Holter Note Added: 0008631
2015-07-02 20:38 zhb Note Added: 0008691
2015-07-10 05:42 Christian Mack Relationship added duplicate of 0003225
2015-07-22 12:45 ludovic Note Added: 0008755
2015-07-22 12:45 ludovic Status new => resolved
2015-07-22 12:45 ludovic Fixed in Version => 2.3.1
2015-07-22 12:45 ludovic Resolution open => fixed
2015-07-22 12:45 ludovic Assigned To => ludovic