View Issue Details

IDProjectCategoryView StatusLast Update
0003130SOGoBackend Generalpublic2015-03-18 10:16
ReporterAltibox Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSRHELOS Version6.6
Product Version2.2.16 
Fixed in Version2.2.17 
Summary0003130: Configurable /tmp
Description

We are experiencing some problems under heavy load. In some situations SOGo uses all the available space on /tmp. Aside from being problematic for SOGo, it also interferes with other programs that need to use /tmp.

Is it possible to get a configuration option to get SOGo to put temporary files in another location than /tmp?

Steps To Reproduce

There are not any steps to reproduce.

TagsNo tags attached.

Activities

francis

francis

2015-03-12 12:00

administrator   ~0008264

What is the value of the configuration parameter SOGoMailSpoolPath?

Altibox

Altibox

2015-03-13 04:12

reporter   ~0008270

According to the documentation SOGoMailSpoolPath is for temporary email drafts. Other temporary files such as uploaded attachments are written to /tmp, which is the path that I would like to be configurable.

ludovic

ludovic

2015-03-13 08:03

administrator   ~0008271

What files were stored in /tmp? Do you remember or have a sample?

Thanks,

Altibox

Altibox

2015-03-13 08:24

reporter   ~0008272

Last edited: 2015-03-13 08:24

View 2 revisions

There are two filenames that recur.

Files that match the name OGo.*.tmp, an example being OGoF33C5502B9D843.tmp. The are base64 encoded files which seem to be uploaded attachments.

The other files match the name sogod.*.tmp, example sogodD0AE5501F6DB07.tmp. They are also base64 encoded files that seem to be uploaded attachments.

I would rather not upload the actual contents of the files in question because they seem to be attachments uploaded by my users.

ludovic

ludovic

2015-03-18 09:48

administrator   ~0008291

Try to adjust:

NGMimeBuildMimeTempDirectory

By default, it's set to /tmp.

Altibox

Altibox

2015-03-18 09:59

reporter   ~0008295

Yes, that option works.

This option is not documented in the SOGo documentation as far as I can find, should it be?

I know that I am nitpicking, but it is not very obvious that NGMimeBuildMimeTempDirectory sets the temporary directory for SOGo.

ludovic

ludovic

2015-03-18 10:09

administrator   ~0008296

It sets it for SOPE, which SOGo uses.

It'll be added to the documentation.

Altibox

Altibox

2015-03-18 10:11

reporter   ~0008297

Last edited: 2015-03-18 10:14

View 2 revisions

Thank you very much. You may consider this issue fixed.

ludovic

ludovic

2015-03-18 10:16

administrator   ~0008298

https://github.com/inverse-inc/sogo/commit/cdb766e2eff3b6e420da48b3f396814edff96b4f

Issue History

Date Modified Username Field Change
2015-03-12 11:36 Altibox New Issue
2015-03-12 12:00 francis Note Added: 0008264
2015-03-13 04:12 Altibox Note Added: 0008270
2015-03-13 08:03 ludovic Note Added: 0008271
2015-03-13 08:24 Altibox Note Added: 0008272
2015-03-13 08:24 Altibox Note Edited: 0008272 View Revisions
2015-03-18 09:48 ludovic Note Added: 0008291
2015-03-18 09:59 Altibox Note Added: 0008295
2015-03-18 10:09 ludovic Note Added: 0008296
2015-03-18 10:11 Altibox Note Added: 0008297
2015-03-18 10:14 Altibox Note Edited: 0008297 View Revisions
2015-03-18 10:16 ludovic Note Added: 0008298
2015-03-18 10:16 ludovic Status new => resolved
2015-03-18 10:16 ludovic Fixed in Version => 2.2.17
2015-03-18 10:16 ludovic Resolution open => fixed
2015-03-18 10:16 ludovic Assigned To => ludovic