View Issue Details

IDProjectCategoryView StatusLast Update
0003082SOGoActiveSyncpublic2015-06-10 11:00
Reportermartinsimovic Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] MicrosoftOSWindowsOS Version7
Product Version2.2.14 
Fixed in Version2.3.1 
Summary0003082: Meetings organised from Outlook 2013 do not get invitees RVSP updates
Description

Outlook 2013 configured as EAS client to SOGo server 2.2.14 running on Trusty x_64

Meeting is added to calendar and people are invited. Notfication os correctly sent to invitees.
Invitee accepts the meeting and update is sent back to meeting organiser. Instead of updating Outlook calendar with correct (attending/declined) invitee status, Outlook shows following error message:

"We could not find this meeting in the calendar. It may have been moved or deleted"
.
This renders meeting organising via Outlook unusable.

TagsNo tags attached.

Activities

ludovic

ludovic

2015-01-28 15:34

administrator   ~0008113

The event IS updated in the organizer's calender Outlook.

The message from the mail view is misleading but IIRC, it's a bug in Outlook since it can't find the event ID from the GlobalObjectId.

martinsimovic

martinsimovic

2015-01-29 11:34

reporter   ~0008119

I am afraid that is not what I am seeing. Event in Organiser's calendar is not updated in my case.

tfu

tfu

2015-05-21 15:35

reporter   ~0008515

It seems that outlook doesn't use the GlobalObjectId to find the event in its calendar. Instead, it does the search based on the value of UID in the text/calendar attachment but has troubles to get the correct value when it is encoded as quoted-printable.
I assume the problem is that outlook expects CRLF at the end of a line (i.e. =CRLF).

ludovic

ludovic

2015-06-10 11:00

administrator   ~0008617

https://github.com/inverse-inc/sogo/commit/6bc471ad9a4dc35ec0789dd8efb73a6de5a6ea3f

Issue History

Date Modified Username Field Change
2015-01-28 07:01 martinsimovic New Issue
2015-01-28 15:33 ludovic Severity major => minor
2015-01-28 15:34 ludovic Note Added: 0008113
2015-01-29 11:34 martinsimovic Note Added: 0008119
2015-05-21 15:35 tfu Note Added: 0008515
2015-06-10 11:00 ludovic Note Added: 0008617
2015-06-10 11:00 ludovic Status new => resolved
2015-06-10 11:00 ludovic Fixed in Version => 2.3.1
2015-06-10 11:00 ludovic Resolution open => fixed
2015-06-10 11:00 ludovic Assigned To => ludovic