View Issue Details

IDProjectCategoryView StatusLast Update
0003050SOGoWeb Calendarpublic2015-01-13 14:06
Reporterwimmer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.13 
Fixed in Version2.2.14 
Summary0003050: WebGUI sets "Personal Calendar" in "New Event" window in all cases
Description

WebGUI sets "Personal Calendar" as target Calendar in "New Event" window in all cases. It does not respect what calendar is selected in the "CALENDARS" list.

TagsNo tags attached.

Relationships

duplicate of 0003049 resolvedfrancis "edit event" dialog always selects "private calendar" 
duplicate of 0002515 resolvedfrancis Edit calendar entry popup defaults to personal calendar, not the entry's calendar 

Activities

wimmer

wimmer

2015-01-04 10:39

reporter   ~0007986

This issue can be in relation to 0003049

francis

francis

2015-01-05 10:36

administrator   ~0007994

See https://github.com/inverse-inc/sogo/commit/59e6d6df4aa131ca1ea658a212ec1c30e516b5f1

wimmer

wimmer

2015-01-06 12:25

reporter   ~0008012

Hi Francis,
I applied your patch on 2.2.13.
Now SOGo creates new event correctly in the selected calendar. But when I wish to modify this event and change its target calendar, SOGo does not do this change.
I see no problem in the log. I can change other attributes.
After that I tried current git with the same result.

francis

francis

2015-01-06 14:00

administrator   ~0008013

You're right. I reviewed my fix.

https://github.com/inverse-inc/sogo/commit/dd6dd7251ca15dc5e758e733e2529003e08e7c7c

Thanks!

Issue History

Date Modified Username Field Change
2015-01-04 10:34 wimmer New Issue
2015-01-04 10:39 wimmer Note Added: 0007986
2015-01-05 10:36 francis Relationship added duplicate of 0003049
2015-01-05 10:36 francis Note Added: 0007994
2015-01-05 10:36 francis Status new => resolved
2015-01-05 10:36 francis Fixed in Version => 2.2.14
2015-01-05 10:36 francis Resolution open => fixed
2015-01-05 10:36 francis Assigned To => francis
2015-01-06 12:25 wimmer Note Added: 0008012
2015-01-06 12:25 wimmer Status resolved => feedback
2015-01-06 12:25 wimmer Resolution fixed => reopened
2015-01-06 14:00 francis Note Added: 0008013
2015-01-06 14:00 francis Status feedback => resolved
2015-01-06 14:00 francis Resolution reopened => fixed
2015-01-13 14:06 francis Relationship added duplicate of 0002515