View Issue Details

IDProjectCategoryView StatusLast Update
0002727SOGoApple Calendar (Mac OS X)public2014-09-15 14:23
Reportergreinick Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Client] AppleOSOS XOS Version10.9
Product Version2.2.3 
Target Version2.2.9Fixed in Version2.2.9 
Summary0002727: Calender subscription problem / CalDav OS X 10.9
Description

An user has created a calendar (Sperrtermine) in SOGo and set all r/w access to it for my user.

He subscribed me to that calendar and I see it in SOGo and I can add/edit entries.

With OS X 10.9 and my configured CalDav Account all SOGo Calendar show up in the calendar list.

But when I check the "Stellvertreter" in the preferences of Apple Kalender, ALL calendars of the user are subscribed in the Calendar List. Thous I don't have special ACL rights to.

Additional Information

All Calendars from that user are readable by all authenticated users. (Public entries see all)

TagsNo tags attached.

Activities

greinick

greinick

2014-04-17 08:49

reporter  

ludovic

ludovic

2014-05-07 13:58

administrator   ~0006998

Show me your SOGo configuration (/etc/sogo/sogo.conf).

Also show me the ACL dialog in SOGo for the calendar "Atelier-Ludwig..." for:

Any Authenticated User
Public Access (if enabled in SOGo)

greinick

greinick

2014-05-19 09:10

reporter   ~0007049

Hi,
i Added the screenshots and send you the config as pm.

/Götz

greinick

greinick

2014-05-19 09:11

reporter  

greinick

greinick

2014-05-19 09:11

reporter  

ludovic

ludovic

2014-05-22 15:01

administrator   ~0007079

Well the screenshots don't lie - you do have access to this calendar.

In the config your sent me privately, you have:

SOGoCalendarDefaultRoles = (
PublicDAndTViewer,
ConfidentialDAndTViewer,
PrivateDAndTViewer
);

Perhaps they were set to:

SOGoCalendarDefaultRoles = (
PublicViewer,
ConfidentialViewer,
PrivateViewer
);

when the calendars of lehre-kalendar users were created.

ludovic

ludovic

2014-09-15 14:23

administrator   ~0007516

Can't reproduce. Most likely fixed with this:

https://github.com/inverse-inc/sogo/commit/c5c2bfb7a6117b00d563bf0230fb435b6026972d

Issue History

Date Modified Username Field Change
2014-04-17 08:49 greinick New Issue
2014-04-17 08:49 greinick File Added: Bildschirmfoto 2014-04-17 um 14.49.07.png
2014-05-07 13:58 ludovic Note Added: 0006998
2014-05-19 09:10 greinick Note Added: 0007049
2014-05-19 09:11 greinick File Added: Bildschirmfoto 2014-05-19 um 15.10.06.png
2014-05-19 09:11 greinick File Added: Bildschirmfoto 2014-05-19 um 15.10.21.png
2014-05-22 15:01 ludovic Note Added: 0007079
2014-09-12 15:21 ludovic Target Version => 2.2.9
2014-09-15 14:23 ludovic Note Added: 0007516
2014-09-15 14:23 ludovic Status new => resolved
2014-09-15 14:23 ludovic Fixed in Version => 2.2.9
2014-09-15 14:23 ludovic Resolution open => fixed
2014-09-15 14:23 ludovic Assigned To => ludovic
2014-09-26 14:08 ludovic Category Apple iCal.app => Apple Calendar (Mac OS X)