View Issue Details

IDProjectCategoryView StatusLast Update
0002663SOGoActiveSyncpublic2014-03-19 08:26
Reporterslefevre Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version6.5
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0002663: [SOGoActiveSyncDispatcher processProvision:inResponse:]: unrecognized selector sent to instance 0x7f57209d2b40 INFO:(null)
Description

I trying out ActiveSync with an Android v4.1.2

On the server, I have the most recent SOGo and SOPE installed and I've restarted SOGo. I've configured apache appropriately w/ the ProxyPass for /Microsoft-Server-ActiveSync

In the Android, I go to setup a new Exchange account and specify the login, password, and server and tap next the server log displays the following:

----8<-----8<-----
2014-03-15 18:57:02.037 sogod[17687] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='motorola-DROIDBIONIC/1.0'
2600:1015:b012:b799::103, 2604:8800:126:1:a00:27ff:fe08:7705 - - [15/Mar/2014:18:57:02 GMT] "OPTIONS /SOGo/Microsoft-Server-ActiveSync HTTP/1.1" 200 0/0 0.049 - - 8K
2014-03-15 18:57:02.386 sogod[17687] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='motorola-DROIDBIONIC/1.0'
EXCEPTION: <NSException: 0x7f5733d9b9d8> NAME:NSInvalidArgumentException REASON:+[SOGoActiveSyncDispatcher processProvision:inResponse:]: unrecognized selector sent to instance 0x7f57209d2b40 INFO:(null)
Mar 15 18:57:03 sogod [17678]: <0x0x7f5733ac36c8[WOWatchDogChild]> child 17687 exited
Mar 15 18:57:03 sogod [17678]: <0x0x7f5733ac36c8[WOWatchDogChild]> (terminated due to signal 6, coredump)
Mar 15 18:57:03 sogod [17678]: <0x0x7f57338c8378[WOWatchDog]> child spawned with pid 18566
Mar 15 18:57:03 sogod [18566]: <0x0x7f57338eb968[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Mar 15 18:57:03 sogod [18566]: <0x0x7f57338eb968[SOGoCache]> Using host(s) '127.0.0.1' as server(s)
Mar 15 18:57:03 sogod [18566]: [ERROR] <0x0x7f5733a11538[SOGoUserManager]> addressbook source 'directory' has no displayname
2014-03-15 18:57:03.614 sogod[18566] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='motorola-DROIDBIONIC/1.0'
2014-03-15 18:57:03.628 sogod[18566] Note(SoObject): SoDebugKeyLookup is enabled!
2014-03-15 18:57:03.628 sogod[18566] Note(SoObject): SoDebugBaseURL is enabled!
2014-03-15 18:57:03.628 sogod[18566] Note(SoObject): relative base URLs are enabled.
EXCEPTION: <NSException: 0x7f5733da9eb8> NAME:NSInvalidArgumentException REASON:+[SOGoActiveSyncDispatcher processProvision:inResponse:]: unrecognized selector sent to instance 0x7f57209d2b40 INFO:(null)
Mar 15 18:57:04 sogod [17678]: <0x0x7f5733ac36c8[WOWatchDogChild]> child 18566 exited
Mar 15 18:57:04 sogod [17678]: <0x0x7f5733ac36c8[WOWatchDogChild]> (terminated due to signal 6, coredump)
Mar 15 18:57:04 sogod [17678]: <0x0x7f5733ac36c8[WOWatchDogChild]> avoiding to respawn child before 2014-03-15 18:57:08 -0400
----8<-----8<-----

I was running wireshark at the same time and was able to extract the following interchange between the Android and SOGO:

----8<-----8<-----
OPTIONS /Microsoft-Server-ActiveSync HTTP/1.1
Host: mail1.example.tld
Authorization: Basic c2xlZmV2cmVAY2lvNHNtYnMuY29tOmphc3BlcjEz
User-Agent: motorola-DROIDBIONIC/1.0
X-Forwarded-For: 2600:1015:b012:b799::103
X-Forwarded-Host: webmail.example.tld
X-Forwarded-Server: webmail.example.tld
Connection: Keep-Alive

HTTP/1.1 200 OK
Date: Sat, 15 Mar 2014 22:57:01 GMT
Cache-Control: private
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
Content-Length: 0
Allow: OPTIONS, POST
MS-Server-ActiveSync: 14.1
Content-Type: text/plain; charset=UTF-8
Public: OPTIONS, POST
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Connection: close
----8<-----8<-----

Steps To Reproduce

In Android device, select Settings
Scroll to Add Account and select
Select Email from account type list
Select Corporate from email type list
Enter email address and password in appropriate fields and select Next button
Enter email address in Domain\Username field, enter password, and server in appropriate fields, and select Next button.

Device displays message:
'Couldn't finish
Can't connect to server'
and prompts to edit settings

Note: using anything but the email address in the Domain/Username field yields and error indicating that it couldn't authenticate.

Additional Information

CentOS 6.5 up to date on all pkgs

Installed pkgs

rpm -qa | grep -i "sogo|sope" |sort

sogo-2.2.1-1.centos6.x86_64
sogo-activesync-2.2.1-1.centos6.x86_64
sogo-ealarms-notify-2.2.1-1.centos6.x86_64
sogo-tool-2.2.1-1.centos6.x86_64
sope49-appserver-4.9-20140307_1664.el6.1.x86_64
sope49-cards-2.2.1-1.centos6.x86_64
sope49-core-4.9-20140307_1664.el6.1.x86_64
sope49-gdl1-4.9-20140307_1664.el6.1.x86_64
sope49-gdl1-contentstore-2.2.1-1.centos6.x86_64
sope49-gdl1-mysql-4.9-20140307_1664.el6.1.x86_64
sope49-ldap-4.9-20140307_1664.el6.1.x86_64
sope49-mime-4.9-20140307_1664.el6.1.x86_64
sope49-sbjson-2.3.1-20140307_1664.el6.1.x86_64
sope49-xml-4.9-20140307_1664.el6.1.x86_64

TagsNo tags attached.

Activities

slefevre

slefevre

2014-03-18 06:51

reporter   ~0006719

Last edited: 2014-03-18 06:52

View 2 revisions

I was able to fix the error: "[ERROR] <0x0x7f5733a11538[SOGoUserManager]> addressbook source 'directory' has no displayname" with the following command by setting the displayName value in the SOGoUserSources setting.

i.e.
$ defaults write sogod SOGoUserSources '({canAuthenticate = YES; \
displayName = "User Directory"; id = directory; isAddressBook = YES; \
type = sql; userPasswordAlgorithm = "md5-crypt"; \
viewURL = "mysql://sogo:soG09281@localhost:3306/vmail/sogo_auth"; })'

This had no affect on the crash as ActiveSync still isn't working.

ludovic

ludovic

2014-03-18 19:08

administrator   ~0006723

I've disabled provisioning support for now. Can you try the upcoming nightly builds and report?

ludovic

ludovic

2014-03-19 07:18

administrator   ~0006734

Have you been able to try the nightly builds?

slefevre

slefevre

2014-03-19 07:52

reporter   ~0006735

I upgraded to the nightly builds and ActiveSync appears to be working. I was able to complete the setup process on the Android and it is currently syncing.

It appears that calendar, tasks, and emails have sync'd. I can't tell if contacts have sync'd yet but from the sogo.log its still running.

Thanks for the quick response on this!

Issue History

Date Modified Username Field Change
2014-03-15 19:35 slefevre New Issue
2014-03-18 06:51 slefevre Note Added: 0006719
2014-03-18 06:52 slefevre Note Edited: 0006719 View Revisions
2014-03-18 07:06 ludovic Target Version => 2.2.2
2014-03-18 19:08 ludovic Note Added: 0006723
2014-03-19 07:18 ludovic Note Added: 0006734
2014-03-19 07:52 slefevre Note Added: 0006735
2014-03-19 08:26 ludovic Status new => closed
2014-03-19 08:26 ludovic Assigned To => ludovic
2014-03-19 08:26 ludovic Resolution open => fixed
2014-03-19 08:26 ludovic Fixed in Version => 2.2.2