View Issue Details

IDProjectCategoryView StatusLast Update
0002624SOGoDocumentationpublic2014-03-10 14:46
ReporterChristian Mack Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.0 
Fixed in Version2.2.1 
Summary0002624: Add hint for SOGoCalendarDefaultReminder in Section Upgrading
Description

You have to set SOGoCalendarDefaultReminder in sogo.conf while upgrading to 2.2.0.
But there is no hint for that in the "SOGo Installation Guide".

When you do not set it you can not use calendars in SOGo.

TagsNo tags attached.

Relationships

related to 0002647 resolvedfrancis SOGoCalendarDefaultReminder default value does not work 

Activities

francis

francis

2014-02-27 08:38

administrator   ~0006577

Last edited: 2014-02-27 08:38

There's a default value already in SOGoDefaults.plist:

https://github.com/inverse-inc/sogo/blob/maint/SoObjects/SOGo/SOGoDefaults.plist#L72

Christian Mack

Christian Mack

2014-02-27 09:14

developer   ~0006578

Sorry, but "NONE" is not a valid setting for SOGoCalendarDefaultReminder according to the "SOGo Installation Guide" page 37.

So this doesn't work.
See also
http://www.mail-archive.com/users%40sogo.nu/msg17362.html

francis

francis

2014-02-27 09:51

administrator   ~0006579

I can't reproduce the problem. SOGoCalendarDefaultReminder is not defined in my configuration nor set in my user defaults and I don't have any error.

Christian Mack

Christian Mack

2014-02-28 04:59

developer   ~0006585

Last edited: 2014-02-28 05:03

I updated another server (CentOS 5) to 2.2.0 yesterday.
I didn't set SOGoCalendarDefaultReminder in /etc/sogo/sogo.conf.
Strangely the error didn't happen for me too.
Perhaps this is OS dependant?

See also
http://www.mail-archive.com/users%40sogo.nu/msg17383.html

Anyway. If "NONE" is a valid value for SOGoCalendarDefaultReminder, then the "SOGo Installation Guide" page 37 should say so.
And it should mention that it is the default.

francis

francis

2014-03-04 08:48

administrator   ~0006617

What is the platform on which you have the exception? Do you use packages?

Christian Mack

Christian Mack

2014-03-05 05:38

developer   ~0006632

I had it with a nightly build on CentOS 5.
Sorry don't remember which one.

Afterwards I always set SOGoCalendarDefaultReminder, so I didn't get it later.
But other people seem to hav it as per the mailinglist.

francis

francis

2014-03-05 13:47

administrator   ~0006640

Fixed.

See https://github.com/inverse-inc/sogo/commit/0c99323db3e5404301c249512b736d426bd41d09

Issue History

Date Modified Username Field Change
2014-02-27 07:36 Christian Mack New Issue
2014-02-27 08:38 francis Note Added: 0006577
2014-02-27 08:38 francis Note Edited: 0006577
2014-02-27 09:14 Christian Mack Note Added: 0006578
2014-02-27 09:51 francis Note Added: 0006579
2014-02-28 04:59 Christian Mack Note Added: 0006585
2014-02-28 05:03 Christian Mack Note Edited: 0006585
2014-03-04 08:48 francis Note Added: 0006617
2014-03-05 05:38 Christian Mack Note Added: 0006632
2014-03-05 13:47 francis Note Added: 0006640
2014-03-05 13:47 francis Status new => resolved
2014-03-05 13:47 francis Fixed in Version => 2.2.1
2014-03-05 13:47 francis Resolution open => fixed
2014-03-05 13:47 francis Assigned To => francis
2014-03-10 14:46 francis Relationship added related to 0002647