View Issue Details

IDProjectCategoryView StatusLast Update
0002469SOGoWeb Calendarpublic2014-09-09 15:20
Reporterpokotilenko Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.7 
Target Version2.2.8Fixed in Version2.2.8 
Summary0002469: "Maximum number of simultaneous bookings (1) reached for resource" due to TimeZone daylight saving mess
Description

Today is 24.10.2013. Our TZ is Europe/Kiev and we'll have daylight saving time shift 27.10.2013 04:00 from +3 to +2.

I create weekly event 28.10.2013 (after the shift) 10:00-11:00, invite meetingroom.
Next I create another weekly event just before the previous 28.10.2013 09:00-10:00, invite same meetingroom and 2 problems occur:

  1. Free/Busy of meetingroom shows +1h shifted (like it is busy 11:00-12:00)
  2. When trying to save such event the next error occurs:

Maximum number of simultaneous bookings (1) reached for resource "meetingroom_test@...". The conflicting event is "s1", and starts on 2014-03-31 10:00:00 +0300.

2014-03-31 is the first event occurrence after time will shift back (from +2 to +3)

Screens attached

There is workaround:

  1. remove repeat from first event
  2. add weekly repeat for the second
  3. readd weekly repeat for the first

In other words: if events are created in time order (09:00-10:00, then 10:00-11:00) - there is no problem, otherwise they overlap

TagsNo tags attached.

Activities

pokotilenko

pokotilenko

2013-10-24 07:41

reporter  

1.png (77,069 bytes)   
1.png (77,069 bytes)   
pokotilenko

pokotilenko

2013-10-24 07:42

reporter  

2.png (41,577 bytes)   
2.png (41,577 bytes)   
pokotilenko

pokotilenko

2013-10-24 07:43

reporter  

3.png (44,843 bytes)   
3.png (44,843 bytes)   
pokotilenko

pokotilenko

2013-10-24 07:44

reporter  

4.png (92,305 bytes)   
4.png (92,305 bytes)   
pokotilenko

pokotilenko

2013-10-24 07:48

reporter   ~0006176

Seems to be related to:
http://www.sogo.nu/bugs/view.php?id=1240

ludovic

ludovic

2014-09-09 15:18

administrator   ~0007481

https://github.com/inverse-inc/sogo/commit/e542ff56465a22767751ff3a4259ce0c5d3f2bb8

Issue History

Date Modified Username Field Change
2013-10-24 07:41 pokotilenko New Issue
2013-10-24 07:41 pokotilenko File Added: 1.png
2013-10-24 07:42 pokotilenko File Added: 2.png
2013-10-24 07:43 pokotilenko File Added: 3.png
2013-10-24 07:44 pokotilenko File Added: 4.png
2013-10-24 07:48 pokotilenko Note Added: 0006176
2014-09-09 15:17 ludovic Target Version => 2.2.8
2014-09-09 15:18 ludovic Note Added: 0007481
2014-09-09 15:18 ludovic Status new => closed
2014-09-09 15:18 ludovic Assigned To => ludovic
2014-09-09 15:18 ludovic Resolution open => fixed
2014-09-09 15:18 ludovic Fixed in Version => 2.2.8
2014-09-09 15:20 francis Status closed => resolved