View Issue Details

IDProjectCategoryView StatusLast Update
0002414SOGoBackend Mailpublic2014-01-30 09:47
Reporterluisxvi Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.7 
Fixed in Version2.2.0 
Summary0002414: HTML formatted body is compiled by the client to be entirely on the same line
Description

When using HTML format I notice the body of the message (without attachments) is coded in one single line. Some mail servers bounce the message when the line is too long (after tests I found messages bounced when the line is above 8187 characters more or less)

The log looks like this:
Jun 18 11:57:56 mail postfix/pipe[22818]: A1FCC17C70321: to=< xxxx@yyy.com>,
relay=cyrus, delay=0, status=bounced (data format error. Command output: xxxx:
Message contains invalid header )

If I send the same message through Thunderbird the body is coded in several
lines of less than 100 characters each.

Is there a way to set up SOGo to break the message body in several lines?

TagsNo tags attached.

Activities

2013-09-11 11:43

 

Body line too long.jpg (101,157 bytes)   
Body line too long.jpg (101,157 bytes)   
francis

francis

2014-01-30 09:47

administrator   ~0006460

Fixed in SOPE.

See https://github.com/inverse-inc/sope/commit/7280b9cf26d0c487cd05336462db5a6dd037e42c

Issue History

Date Modified Username Field Change
2013-09-11 11:43 luisxvi New Issue
2013-09-11 11:43 luisxvi File Added: Body line too long.jpg
2013-09-19 15:50 ludovic Status new => assigned
2013-09-19 15:50 ludovic Assigned To => jraby
2014-01-30 09:47 francis Note Added: 0006460
2014-01-30 09:47 francis Status assigned => resolved
2014-01-30 09:47 francis Fixed in Version => 2.2.0
2014-01-30 09:47 francis Resolution open => fixed
2014-01-30 09:47 francis Assigned To jraby => francis