View Issue Details

IDProjectCategoryView StatusLast Update
0002130SOGoBackend Generalpublic2012-12-05 08:53
Reporterwimmer Assigned Tojraby 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.2a 
Target Version2.0.3Fixed in Version2.0.3 
Summary0002130: Loss of the SOGOSPOOL directory
Description

I found interesting problem on my testing machine.
Sometimes SOGo WebGUI doesn't fill e-mail address and body of original message in the "Replaying Window" when I replay to that message.
I see this error in the log:
Dec 03 22:26:16 sogod [9796]: [ERROR] <0x7160A450[SOGoDraftObject]:newDraft1354569976-1> could not create folder for draft: '/var/spool/sogo/wimmer/newDraft1354569976-1'
The reason is that directory /var/spool/sogo/ doesn't exist in that moment.
But it existed before that.
I think that problem causes using of "rmdir -p' in the script /etc/cron.daily/sogo .
Look at line:
find "$SOGOSPOOL" -mindepth 1 -type d -empty -exec /bin/rmdir -p {} \; 2> /dev/null

rmdir -p, --parents
remove DIRECTORY and its ancestors

TagsNo tags attached.

Activities

ludovic

ludovic

2012-12-05 08:36

administrator   ~0005034

I guess your tmpwatch script is old because the current version looks like this:

#!/bin/sh

SOGOSPOOL=/var/spool/sogo

/usr/sbin/tmpwatch 24 "$SOGOSPOOL"
find "$SOGOSPOOL" -depth -mindepth 1 -type d -empty -exec /bin/rmdir {} \; 2> /dev/null

Notice there's no -p.

wimmer

wimmer

2012-12-05 08:45

reporter   ~0005035

This is not my script and it is not old ;-)
This script is included in your Debian packages (sogo_2.0.2a-1_amd64.deb,
sogo_2.0.0.20121130-1_amd64.deb)

ludovic

ludovic

2012-12-05 08:53

administrator   ~0005036

You are right, only the RHEL version was fixed.

Fix pushed: https://github.com/inverse-inc/sogo/commit/3606601c3922eecc60e8e3f0f21deafc25a994c3

Issue History

Date Modified Username Field Change
2012-12-03 17:17 wimmer New Issue
2012-12-03 18:51 ludovic Status new => assigned
2012-12-03 18:51 ludovic Assigned To => jraby
2012-12-03 18:51 ludovic Target Version => 2.0.3
2012-12-05 08:36 ludovic Note Added: 0005034
2012-12-05 08:36 ludovic Status assigned => closed
2012-12-05 08:36 ludovic Resolution open => no change required
2012-12-05 08:45 wimmer Note Added: 0005035
2012-12-05 08:45 wimmer Status closed => feedback
2012-12-05 08:45 wimmer Resolution no change required => reopened
2012-12-05 08:53 ludovic Note Added: 0005036
2012-12-05 08:53 ludovic Status feedback => closed
2012-12-05 08:53 ludovic Resolution reopened => fixed
2012-12-05 08:53 ludovic Fixed in Version => 2.0.3