View Issue Details

IDProjectCategoryView StatusLast Update
0002065SOGoWeb Mailpublic2012-11-15 10:45
Reporterflevee Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version2.0.1 
Target Version2.0.2aFixed in Version2.0.2a 
Summary0002065: Reply-to equals NULL
Description

Randomly, when a user composes a new message, the field reply-to equals null@domain. The issue occurs rarely.
The users haven't the right to modify this field in the options.

See the message https://inverse.ca/sogo/lists/arc/users/2012-10/msg00291.html

TagsNo tags attached.

Activities

ludovic

ludovic

2012-10-29 14:21

administrator   ~0004733

I know it a lot to ask but it would be nice to try to isolate this problem, in a reproducible manner. Try to toy around with memcached when you're about to compose a mail, etc.

We'll have to do the same thing to reproduce the issue, so a little bit of help here would be good.

flevee

flevee

2012-10-29 14:48

reporter   ~0004734

I have never faced the issue directly.
The emails were forwarded to me, showing that the header had been badly initialized. One of the user who faced the problem couldn't reproduce it when I asked him to do so. But it happened to him again two days after.

Nevertheless, I'll try to catch it when occuring.

Freddy

flevee

flevee

2012-11-05 08:02

reporter   ~0004772

Awaiting the opportunity to reproduce the issue, I show here an excerpt of the content of a malformed mail:

...
Received: from smtp.ensicaen.fr (smtp.ecole.ensicaen.fr [193.49.200.8])
by mailstore.ensicaen.fr (Postfix) with ESMTP id 64A95DA055
for <informatique@ecole.ensicaen.fr>; Mon, 5 Nov 2012 10:07:47 +0100 (CET)
Received: from smtp.ensicaen.fr (localhost [127.0.0.1])
by localhost (Postfix) with SMTP id F12D638E0007
for <informatique@ecole.ensicaen.fr>; Mon, 5 Nov 2012 09:58:52 +0100 (CET)
Received: from sogo.ecole.ensicaen.fr (sogo.ecole.ensicaen.fr [193.49.200.48])
by smtp.ensicaen.fr (Postfix) with ESMTPS id 2852D38E0001
for <informatique@ecole.ensicaen.fr>; Mon, 5 Nov 2012 09:58:52 +0100 (CET)
Received: from sogo by sogo.ecole.ensicaen.fr with local (Exim 4.72)
(envelope-from <nicolas.stephan@ecole.ensicaen.fr>)
id 1TVIdo-0001us-KS
for informatique@ecole.ensicaen.fr; Mon, 05 Nov 2012 10:06:44 +0100
Disposition-Notification-To: nicolas.stephan@ecole.ensicaen.fr
User-Agent: SOGoMail 2.0.2
reply-to: null@sogo.ecole.ensicaen.fr
X-Forward: 82.124.35.117
MIME-Version: 1.0
...

francis

francis

2012-11-06 08:33

administrator   ~0004780

You wrote: "The users haven't the right to modify this field in the options." How do yo control this? Have you modified the template of the preferences module? The "reply to email" field is always editable in the official version of SOGo.

For the problematic account, does the "reply to email" field appear empty in the preferences module?

Christian Mack

Christian Mack

2012-11-08 08:39

developer   ~0004800

This is not account specific.
It only occures very seldom.
It can occur with every account with an empty "reply to email" field in the SOGo user settings.

In our installation approx. 10 emails per day will have that wrong "Reply-To:" out of an average of 20,000 emails send per day via SOGo.

Sorry, we could not reproduce this relyable.
But when it happens, then the string "null" is written into the emails "Reply-To:" field, which should be empty or not there at all.

francis

francis

2012-11-12 13:30

administrator   ~0004825

Is the preference value set when you query sogo-tool?

sogo-tool user-preferences get defaults <uid> SOGoMailReplyTo

When not set, you should see :

2012-11-12 13:28:11.525 sogo-tool[14973] Value for key "SOGoMailReplyTo" not found in defaults

flevee

flevee

2012-11-12 13:54

reporter   ~0004826

For the user stephan (whose part of one mail is reproduced above), the command displays:

/usr/sbin/sogo-tool user-preferences get defaults stephan SOGoMailReplyTo

Nov 12 19:50:03 sogo-tool [29443]: <0x0x2762200[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Nov 12 19:50:03 sogo-tool [29443]: <0x0x2762200[SOGoCache]> Using host(s) 'localhost' as server(s)
2012-11-12 19:50:03.522 sogo-tool[29443] Value for key "SOGoMailReplyTo" not found in defaults

Here are his preferences:

preferences = (
{
Forward = {
enabled = <I1>;
forwardAddress = (
"xxxxxxxxxxxxx@gmail.com"
);
keepCopy = <
I1>;
};
SOGoContactsCategories = (
Ami,
Client,
"Coll\U00E8gue",
Concurrent,
Famille,
Fournisseur,
"Partenaire d'affaire",
Presse,
VIP
);
SOGoLanguage = French;
SOGoLoginModule = Mail;
SOGoMailComposeMessageType = html;
SOGoMailMessageCheck = manually;
SOGoMailMessageForwarding = inline;
SOGoMailShowSubscribedFoldersOnly = 0;
SOGoMailSignaturePlacement = below;
SOGoMailSortByThreads = 0;
SOGoRememberLastModule = 0;
SOGoSieveFilters = (
);
SOGoTimeFormat = "%H:%M";
SOGoTimeZone = Europe/Paris;
Vacation = {
autoReplyEmailAddresses = (
"nicolas.stephan@ecole.ensicaen.fr",
"stephan@ensicaen.fr"
);
autoReplyText = "";
daysBetweenResponse = 7;
enabled = <I0>;
endDate = <
I1340748000>;
endDateEnabled = <I0>;
ignoreLists = <
I1>;
};
};
},
{
Mail = {
DragHandleHorizontal = 200;
DragHandleVertical = 282;
SortingState = (
date,
0
);
};
}
);

francis

francis

2012-11-12 16:42

administrator   ~0004832

Please try the next nightly builds. They should build this night ..

flevee

flevee

2012-11-14 05:57

reporter   ~0004844

I've installed the nightly builds of the 14th of november and I'm going to log the reply-to on the mail gateway.
However, I can't redirect every user at this moment to this version since there's another bug with the enclosed files (http://www.sogo.nu/bugs/view.php?id=2096) which is too annoying.

ludovic

ludovic

2012-11-14 06:50

administrator   ~0004845

The fix for attachments "corruption" is also included in the nightly builds. The fix is in SOPE.

flevee

flevee

2012-11-14 08:43

reporter   ~0004846

Okay. The nightly build of the 14th of November is now installed and is being used by our users. Let's see.

flevee

flevee

2012-11-15 04:01

reporter   ~0004850

The nightly build is up for 20 hours and there has not been any header which equals null@...
Because the bug appears so randomly, I wish other people who monitor the bug could confirm that the issue has been resolved for them too.

francis

francis

2012-11-15 10:45

administrator   ~0004858

Reopen the ticket if the problem still occurs.

See https://github.com/inverse-inc/sogo/commit/e037ca0a4914785c4f34a50613292fa0ddc08775

Issue History

Date Modified Username Field Change
2012-10-24 06:02 flevee New Issue
2012-10-26 13:17 wsourdeau Target Version => 2.0.3
2012-10-29 14:21 ludovic Note Added: 0004733
2012-10-29 14:48 flevee Note Added: 0004734
2012-11-05 08:02 flevee Note Added: 0004772
2012-11-06 08:33 francis Note Added: 0004780
2012-11-08 08:39 Christian Mack Note Added: 0004800
2012-11-12 13:30 francis Note Added: 0004825
2012-11-12 13:54 flevee Note Added: 0004826
2012-11-12 16:42 francis Note Added: 0004832
2012-11-14 05:57 flevee Note Added: 0004844
2012-11-14 06:50 ludovic Note Added: 0004845
2012-11-14 08:43 flevee Note Added: 0004846
2012-11-15 04:01 flevee Note Added: 0004850
2012-11-15 10:44 francis Fixed in Version => 2.0.2a
2012-11-15 10:44 francis Target Version 2.0.3 => 2.0.2a
2012-11-15 10:45 francis Note Added: 0004858
2012-11-15 10:45 francis Status new => resolved
2012-11-15 10:45 francis Resolution open => fixed
2012-11-15 10:45 francis Assigned To => francis