View Issue Details

IDProjectCategoryView StatusLast Update
0002005SOGoOpenChange backendpublic2012-10-03 11:29
ReporterwsourdeauAssigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.0 
Target Version2.0.1Fixed in Version2.0.1 
Summary0002005: scalability: the fetching of entries of the indexing.tdb file takes too much time
Description

In MAPIStoreMapping, we fetch the content of that file and build a dictionary from it as will as its reverse. With 10000 entries, the process takes 6 seconds per iteration. Since this is performed during the opening of each MAPIStoreUserContext, the performance of OpenChange is severely impacted.

TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change
2012-10-03 11:25 wsourdeau New Issue
2012-10-03 11:25 wsourdeau Target Version => 2.0.1
2012-10-03 11:29 wsourdeau Note Added: 0004605
2012-10-03 11:29 wsourdeau Status new => resolved
2012-10-03 11:29 wsourdeau Fixed in Version => 2.0.1
2012-10-03 11:29 wsourdeau Resolution open => fixed
2012-10-03 11:29 wsourdeau Assigned To => wsourdeau